Please login or register.

Login with username, password and session length
Advanced search  

News:

If you want to flash your BIOS, please use our own Forum USB Flash tool - NOW UPDATED!

Pages: [1]   Go Down

Author Topic: MSI CX500 wireless problem  (Read 2409 times)

0 Members and 1 Guest are viewing this topic.

CanuoPa

  • Neo
  • *
  • Offline Offline
  • Posts: 4
MSI CX500 wireless problem
« on: 04-September-11, 15:17:48 »

Hello,
I have a problem with the wireless of my notebook since i bought it. So when it's on 3-4 meters of  the adapter (router)  everything is OK but when the distance is more the notebook is connected to the router but not connected to internet. I returned it to MSI service  where  the wireless card (don't remember the model) was replaced with Atheros AR9285.  I've installed the latest driver for it - 9.0.0.173 but it's still not working properly  and the problem is the same like before .:bonk:
Can you help me or give me any advice pls
Logged

Mark

  • Xpower
  • ***
  • Offline Offline
  • Posts: 4643
  • Former Moderator
Re: MSI CX500 wireless problem
« Reply #1 on: 04-September-11, 16:00:16 »

Are you sure it's not a signal problem from your router then? Do you have another notebook/desktop you can connect wirelessly to test? You could buy a better antenna for the router to boost the signal if it turns out to be the issue.

Have you tried updating the firmware on your router?
Logged

CanuoPa

  • Neo
  • *
  • Offline Offline
  • Posts: 4
Re: MSI CX500 wireless problem
« Reply #2 on: 04-September-11, 16:06:55 »

Sure, i tried with another laptop and it worked properly on 20+ meters distance.... Also i tried my laptop with another routers and  the problem is the same ...
Logged

Mark

  • Xpower
  • ***
  • Offline Offline
  • Posts: 4643
  • Former Moderator
Re: MSI CX500 wireless problem
« Reply #3 on: 04-September-11, 16:13:55 »

I've installed the latest driver for it - 9.0.0.173 but it's still not working properly  and the problem is the same like before .:bonk:

Is that actually the latest driver version? I only ask because there are newer versions here: http://forums.laptopvideo2go.com/topic/14833-latest-atheros-wlan-drivers-for-windows-7-and-vista-x86-x64/. Have a look and see if they work.
Logged

CanuoPa

  • Neo
  • *
  • Offline Offline
  • Posts: 4
Re: MSI CX500 wireless problem
« Reply #4 on: 04-September-11, 16:43:05 »

Now i installed the latest driver but the problem is still not fixed
Logged

Mark

  • Xpower
  • ***
  • Offline Offline
  • Posts: 4643
  • Former Moderator
Re: MSI CX500 wireless problem
« Reply #5 on: 04-September-11, 16:47:17 »

Is it showing as connected to the network and what signal strength is given? (A screen shot might help)
Logged

Ex Forum User 3

  • Hawk
  • *
  • Offline Offline
  • Posts: 26817
Re: MSI CX500 wireless problem
« Reply #6 on: 04-September-11, 18:30:03 »

Wifi only goes a long way where there are no things blocking the "view" Walls/doors: stone, iron and concrete block the signal to unworkable after a few meters.
If your signal falls below about 70~80% troubles will start.

Logged

CanuoPa

  • Neo
  • *
  • Offline Offline
  • Posts: 4
Re: MSI CX500 wireless problem
« Reply #7 on: 04-September-11, 19:32:53 »

So here it is a screenshot -  http://imageshack.us/f/833/wlan.jpg/
It shows i'm connected but actually i even cant connect to the router through the browser. It's on   6-7 meters distance  1 wall btw the laptop and the router, but i also tried clear connection (no walls)...
Logged

Ex Forum User 3

  • Hawk
  • *
  • Offline Offline
  • Posts: 26817
Re: MSI CX500 wireless problem
« Reply #8 on: 05-September-11, 09:34:12 »

Why is that a public network?
It seems to me something is blocking stuff.
Could be some custom firewall you installed.
Or your router doesn't provide DNS services properly.

Have you checked the parameters with ipconfig /all to see it everything is correct?
Logged
Pages: [1]   Go Up