Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: Linux does not boot with X299 Raider: ACPI Error  (Read 1686 times)

0 Members and 1 Guest are viewing this topic.

tobias.foerster+msiTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8

I purchased a new machine with an i7-7820X, a MSI X299 Raider and 64 GB of memory.
Unfortunately I have problems booting linux Ubuntu. It ends in emergency mode with the following error messages:


Code: [Select]
kernel: Error parsing PCC subspaces from PCCT
kernel: ACPI Error: [SDS0] Namespace lookup failure, AE_NOT_FOUND (20160930/psargs-359)
kernel: ACPI Error: Method parse/execution failed [\SHAD._STA] (Node ffff8f559e548050), AE_NOT_FOUND (20160930/psparse-543)

After some research I found 2 other people with similar hardware and the same problem here and here. But they have a board from Asus.

I tried different kernel version up to 4.12 (Ubuntu 17.10,17.04, Fedora 26) and different bios version for my motherboard (including Beta versions). Nothing helped all gave the same error. At the moment I can boot and use my system with the acpi=off boot option, but this disables Hyperthreading.

Is this a bios bug?
Logged

tobias.foerster+msiTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #1 on: 15-September-17, 12:35:48 »

It was a Bios bug.
With the new Beta Version (1.42) I can boot without problems.
Logged

joost

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #2 on: 15-September-17, 21:55:54 »

I'm having the exact same problem. On my new computer I cannot install Ubuntu, which I have been using for years, so want to keep using.

As it seems BIOS-vesion 1.42 solves this problem I would like to install/flash this one. On the official site I can only find the 1.2 version of the BIOS.
That is for X299 RAIDER motherboard which the shop installed in my computer (title suggest I'm in the right thread right...)

Where can I find version 1.42, even though it is just in beta?
Logged

tobias.foerster+msiTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #3 on: 16-September-17, 06:57:47 »

The downsload links are here in the forums download section:
https://forum-en.msi.com/index.php?topic=289634.0
Logged

joost

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #4 on: 16-September-17, 20:20:55 »

Great thanks for the link.

Flashing the BIOS gave no problems. I'm running version 1.42 now. I can see this when using system information on Windows 10 this is displayed as well.

Unfortunately this does not resolve my issue with booting Ubuntu.
I can get into Grub, but as soon as I select "Trying Unbuntu without installing" I get these fatal error messages.
It depends a little on which version of Ubuntu I use, 16.04 (I usually prefer LTS) or 17.04. I tried both "regular" Ubuntu and Ubunt MATE.
I reads stuff like:

Error parsingg PCC subspaces from PCCT
ACPI Error: Method parse/execution failed [\SHAD._STA1 (Node...) AE_NOT_FOUND
mce: [ Hardware error ]: CPU 2: Machine check Exception: 5 Bank 0: b20.......
mce: [ Hardware error ]: Machine check: Processor context corrupt

As I understand you had no problems installing Ubuntu with this BIOS?
Did you take any additonal steps? Obviously I'm very interested how you got this to work, or what I could do to get my system to work.

Any further tips would be highly appreciated.
Logged

tobias.foerster+msiTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #5 on: 17-September-17, 07:53:53 »

There is a bug in the Skylake processors which needs the newest version of the intel microcode package. I think that this is not part of the install iso.
You should turn off acpi while installing : see here
Additionally to acpi=off also add intel_pstate=disable, then you should be able to boot and install.
 After the installation you might have to boot ones with the same option to update everything, after that it worked for me with Ubuntu 17.04 and  Kernel 4.10.33.
I am not sure if 16.04 LTS works properly at the moment.
Logged

joost

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #6 on: 20-September-17, 19:01:30 »

Tobias thanks for your tips.
I've been succesfull in booting Ubuntu from USB and installing Ubuntu 17.04.
(I actually found acpi=off previously when Googling, but had inserted it in the wrong place in grub :bonk: )

After installing I've updated everything as much as I know.
Unfortunately I can only boot my computer when I add acpi=off intel_pstate=disable
As soon as I try to boot without these the computer crashes as before.

I should expect it to work with this updated software... :undecided:
I now have BIOS version 1.42
Kernel 4.10.0-35-generic
Intel microcode 3.20170707.1 (tried both from Ubuntu repository ~ubuntu17.04.4 and debian ~deb9u1)

Code: [Select]
$ uname -r
4.10.0-35-generic
$ apt policy intel-microcode
intel-microcode:
  Geïnstalleerd: 3.20170707.1~deb9u1
  Kandidaat:     3.20170707.1~ubuntu17.04.0
  Versietabel:
     3.20170707.1~ubuntu17.04.0 500
        500 http://nl.archive.ubuntu.com/ubuntu zesty-updates/restricted amd64 Packages
 *** 3.20170707.1~deb9u1 100
        100 /var/lib/dpkg/status
     3.20161104.1 500
        500 http://nl.archive.ubuntu.com/ubuntu zesty/restricted amd64 Packages

I have a NVidia Quadro P2000 graphics card running NVIDIA binary driver - version 375.66

If you have any other suggestions, again I would be grateful.
Logged

joost

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #7 on: 21-September-17, 11:15:04 »

I noticed that MSI released their non-beta version 1.40 a few days ago.

I replaced the beta-version with this version.
Per info MSI this version should be newer than the beta-version even if the minor version number is lower.
And I manually installed the latest kernel 4.13.0-041300-generic

So now I'm running
BIOS-version 1.40
Kernel 4.13.0-041300-generic
intel micrcode 3.20170707.1

But without acpi=off I still get:  "mce: [ Hardware error ]: Machine check: Processor context corrupt"

Still hoping for a solution for this problem. Without it I have to run this computer on Windows which I really don't like...
Logged

tobias.foerster+msiTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #8 on: 21-September-17, 12:09:02 »

I am also unstable now :nooo:.
It was stable with a Kernel version 4.10.0.33 (Bios 1.4 and ACPI on), then I updated the Kernel to 4.10.0.35, some other packages where also updated. Since then I have constant crashes and had to turn off ACPI.
Unfortunately just booting with the 33 kernel didn't help, so there might some other packages involved. I did not have time to have closer look and revert everything to versions before the 15th or 16th september.
For now I will just keep ACPI=off and work with that, I just don't have time the next two weeks to care about the problem. I upgraded from I7-3770 so I can live with only 8 possible threads for a few more weeks.
Next time I buy new hardware, I will wait til a few months after launch!

P.S.: I read some comments that this is related to Nvidia cards, so if you can test another graphics card.
Logged

hexer.x64

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
« Reply #9 on: 03-October-17, 10:44:12 »

Good afternoon!
We are faced with the same problem.
Have you solved it?
Logged

joost

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #10 on: 05-October-17, 09:08:28 »

Unfortunately I have not yet been able to solve the problem :nooo:
Logged

hexer.x64

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
« Reply #11 on: 05-October-17, 15:09:43 »

Do you tried to install bois 1.52 from beta?
I cant to take access to computer, he working on windows at this time.
Logged

joost

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #12 on: 05-October-17, 21:56:22 »

The versions I have tried most recently are kernel 4.13 en BIOS version 1.52 (this is a beta BIOS)
But still no luck.

$ sudo dmidecode -s bios-version
1.52
$ uname -sr
Linux 4.13.0-041300-generic
Logged

dpadilla0

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
« Reply #13 on: 09-October-17, 20:25:57 »

I'm also experiencing this issue on X299 Gaming Pro Carbon. Currently on BIOS 7A95v15. I will try disabling ACPI.
I hope there will be new BIOS that fixes this issue.
Logged

dpadilla0

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
« Reply #14 on: 10-October-17, 20:32:35 »

The issue seems to be related to the new Turbo Boost 3 not handled properly by the kernel.
Disabling Turbo Boost in the BIOS fixed the problem. With Turbo Boost disabled there is no need to use acpi=off
Logged

joost

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #15 on: 14-October-17, 20:54:45 »

YOU'RE AWESOME !!! :biggthumbsup: 

For me turning off Turbo Boost in the BIOS did the trick as well.
So on the 4.13 kernel with BIOS version 1.52 I can boot without acpi=off, enabling all threads per core.

So I can finally use my 8-core/16-thread CPU as it was meant on Ubuntu
Thnx for the tip!

(it's in dutch, but you'll get what I mean)
Code: [Select]
$ lscpu
Architecture:          x86_64
CPU-modus(sen):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                16
On-line CPU(s) list:   0-15
Draden per kern:       2
Kern(en) per voet:     8
Socket(s):             1
NUMA-node(s):          1
Producent-ID:          GenuineIntel
CPU-familie:           6
Model:                 85
Model name:            Intel(R) Core(TM) i7-7820X CPU @ 3.60GHz
Stepping:              4
CPU-frequentie (MHz):  3600.000
CPU max MHz:           3600,0000
CPU min MHz:           1200,0000
BogoMIPS:              7500.00
Virtualisatie:         VT-x
L1d-cache:             32K
L1i-cache:             32K
L2-cache:              1024K
L3-cache:              11264K
NUMA node0 CPU(s):     0-15
Logged

tobias.foerster+msiTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #16 on: 16-October-17, 09:42:48 »

Last week there was an update to the Kernel (now Linux 4.10.0-37-generic) since that my system is stable with acpi and turboboost turned on. I am still using Bios 1.4.
Logged

joost

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #17 on: 17-October-17, 12:02:26 »

@tobias

This seems odd, as I keep having trouble with the 4.13.5-041305-generic kernel which is newer. And BIOS 1.52 (also newer).
I cannot boot with Turbo Boost on, without acpi=off.

Could be that kernel 4.10 on BIOS 1.4 is stable. But in that case I would be careful with upgrading, as later versions definitely do not work (anymore).
Or maybe in my computer it is some other combination (videocard?) which makes it more sensitive to this problem.
Logged

tobias.foerster+msiTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #18 on: 17-October-17, 13:07:06 »

I upgraded to Bios 1.5 (non beta) there was no change  in stability.
I also changed to an AMD card some time ago, because there was a problem with using OpenGL over SSH. This was before the 37 Kernel  came out and did not have an effect on the issue.

As for the kernel version you are using, 4.13 is not yet in the stable release. It will be for Ubuntu 17.10. So it might be that your version does not have the fix yet.
Logged

jjcf89

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 1
« Reply #19 on: 05-December-17, 23:44:43 »

The issue seems to be related to the new Turbo Boost 3 not handled properly by the kernel.
Disabling Turbo Boost in the BIOS fixed the problem. With Turbo Boost disabled there is no need to use acpi=off
Just tried to install Ubuntu 16.04 on a MSI X299 SLI PLUS with i7-7820x.  Ran into same problem.  Turning off Turbo Boost allowed me to boot off usb and install.
Logged

bananabender

  • SERGEANT
  • *****
  • Offline Offline
  • Posts: 26
« Reply #20 on: 06-December-17, 00:36:17 »

Ubuntu 17.10 has been out for some time.  I've tried it on an older machine and it works OK.  On earlier versions you can still install the latest kernels from backports which are usally enabled by default.
Most Linux distros work well with most hardware but with newer processors such as Intel 7th and 8th generation, only the most recent kernels plus Intel microcode and possible other hardware drivers are needed to get it working.
I'm using Debian 9 (stable) with 4.13 kernel on this MSI notebook with ACPI but don't have a Turbo Boost option.
Logged

tobias.foerster+msiTopic starter

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 8
« Reply #21 on: 07-December-17, 08:42:03 »

Ubuntu 17.10 works now fine with my system.  Everything is working now, also the Turbo Boost.
But I recently had my first dead processor with the machine. ;-(( 
This meant I could not use for some time and had to wait for a replacement.
Logged
Pages: [1]   Go Up