Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: X399 not boot with 950 pro, need help pls.  (Read 197 times)

0 Members and 1 Guest are viewing this topic.

eong.chenTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
X399 not boot with 950 pro, need help pls.
« on: 11-September-17, 12:55:46 »

Just got my AMD 1950X and MSI X399 motherboard. After installation, I can not boot into my windows 10 from a Samsung 950 pro SSD. It stopped with a cursor blinking, after the display of logo. I tried to update bios and the firmware of SSD, I also tested memory and tired other solution, none of them work.
Finally I found a linux live cd and tried it, the linux ran without problem, and I rebooted, it can boot into windows without issue.
But I can not reboot the computer. It will run into the same problem after reboot. So it's really funny that I have to use linux to do a pre-loading for windows 10 every time?
It seems to be a compatible issue with the 950 pro SSD and the montherboard. It worked fine on my MSI X99 motherboard before I switch to AMD.
Please help! I'm a big fan of MSI(more than 15 MSI montherboards in the past 15 years.) and I don't want to switch to other brand motherboard.

Spec
-Motherboard: MSI  X399 Gaming Carbon AC
-PSU: Antec - HCP-1000 Platinum
-RAM: 32 GB,  4 DIMMs  Corsair Vengeance LPX CMK16GX4M2B3200C16
-GPU: GTX1080Ti MSI GamingX
-SSD:  512G Samsung 950 Pro
-OS: Win 10 Pro  (Old Install)
-OC: No OC
-BIOS: beta 1.43
« Last Edit: 11-September-17, 22:46:16 by eong.chen »
Logged

ssateneth

  • SERGEANT
  • *****
  • Offline Offline
  • Posts: 35
« Reply #1 on: 11-September-17, 20:04:47 »

Enable Windows 10 WHQL Support inside your BIOS. I also have a Samsung 950 pro and the PC wouldn't boot unless I had that setting enabled (as well as al lthe other secure boot stuff). This is because I already had Windows 8.1 installed on it in EUFI mode, which meant it had an EFI partition. If you have an EFI partition on one of your drives, you must enable Windows 10 WHQL Support. Be aware that it may take a long time to POST (might be stuck on POST code D4 for a long time). Just mash that delete key to get into the UEFI to change the setting and save then it should post fast and boot up fine.

At least this is the issue I had anyways. Sounded a lot like your problem. It's definitely a firmware issue as having a drive with an EFI partition should NOT lock up the POST sequence for a long time, regardless of some settings enabled or not, and I didn't have this issue on a previous MSI board (x99 xpower)
Logged
Board: X399 Gaming Pro Carbon AC
BIOS:  1.52 Beta
VGA:   EVGA 1080 Ti FTW3
PSU:  Seasonic X1250 1250W (104A 12v rail)
CPU:  AMD Ryzen Threadripper 1950X
MEM: 4x16GB, 3600MHz G.Skill Trident Z F4-3600C17Q-64GTZKW

HDD/SSD: Samsung 950 Pro 512GB, Samsung 850 Pro 2 TB
COOLER: Custom loop (EK Threadripper block)
Keyboard: Logitech K120 USB
Mouse: Logitech G403 USB
OC: 4.2 Ghz @ 1.45v
OS: Windows 10 64bit Professional

eong.chenTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
« Reply #2 on: 12-September-17, 03:08:19 »

I'm using legacy way too boot, not EUFI. I can boot into system if I boot with a linux live dist first. So I'm sure it is not EUFI.
Logged

plasma2222

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
« Reply #3 on: 12-September-17, 10:33:25 »

this seems to be an issue regarding nvme and legacy boot as the samsung 950 pro HAS a wrapper that enables it to boot legacy mode with nvme drives but the 950 evo, 960 evo and 960 pro lack it.  that's why you need to load the linux shell first to then boot from an nvme drive accoring to several sources :D

if you want to make it work this tutorial might help :)
Logged

plasma2222

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 3
« Reply #4 on: 12-September-17, 13:40:08 »

not sure why, but somehow i came to the conclusion the thread op has an 960 pro while he clearly stated he's using a 950 pro .... xD
Logged

eong.chenTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
« Reply #5 on: 12-September-17, 15:09:46 »

Thanks plasma2222. This explained the issue well. The solution looks a little bit complicated. Maybe I can change it to UEFI without data loss. I really don't want to reinstall my system, it is a long long time job.
If the X99 from MSI can support it, I think X399 should also support it. I sent out a technical support ticket to see if MSI will improve this. I'll keep the legacy for now. I barely reboot my desktop.
Thank you anyway.
Logged

Svet

  • T9246ED, Бивша комета
  • Administrator
  • *****
  • Offline Offline
  • Posts: 68340
« Reply #6 on: 13-September-17, 15:36:25 »

yes as workaround you need to enable Windows 10 WHQL Support and to install & use OS in pure UEFI Mode.
For legacy mode related to this particular SSD it will be fixed in a future BIOS versions.



Thanks plasma2222. This explained the issue well. The solution looks a little bit complicated. Maybe I can change it to UEFI without data loss. I really don't want to reinstall my system, it is a long long time job. If the X99 from MSI can support it, I think X399 should also support it. I sent out a technical support ticket to see if MSI will improve this. I'll keep the legacy for now. I barely reboot my desktop. Thank you anyway.

you can use the follow tutorial to switch the OS to UEFI without reinstalling:

related to possible switching without reinstall,
can recommend you this one that worked for me:

do disk backup 1st with:
https://www.macrium.com/download

once done, do this:
http://kb.macrium.com/KnowledgebaseArticle50151.aspx
and when its done after that do this:
[do the 2nd part "Fix Boot problems for GPT/UEFI Boot Systems" from the link below]
http://kb.macrium.com/KnowledgebaseArticle50168.aspx
Logged

eong.chenTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
« Reply #7 on: 14-September-17, 07:36:20 »

I already did convert my system disk to "uefi mode" without data loss, and it is working fine.
Just use the command utility in windows 10, no pain at all.  mbr2gpt /convert /allowfullOS
Thank you guys.

I have another question, how can I configure my raid? I set the bios to raid mode but didn't see any promote that I can get into a raid option rom to setup my disks.
Logged

plutomate

  • MAJOR
  • *****
  • Offline Offline
  • Posts: 1372
« Reply #8 on: 14-September-17, 07:48:28 »

since you enable win10 whql support, you will find RAIDXpert2 Configuration Utility under Settings
Logged
Pages: [1]   Go Up