Close

Register Now!

To Get More Info and Daily Reward.

Please login or register.
Pages: [1]   Go Down

Author Topic: Cool N Quiet Overclocking Bug With B350 Tomahawk Arctic  (Read 2713 times)

0 Members and 1 Guest are viewing this topic.

steven_ansellTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4

Hi all,

With the latest beta UEFI (VH73) and the latest release version (H7) for the B350 Tomahawk Arctic, I'm experiencing an issue with regards to overclocking at a UEFI level that I didn't experience in previous versions.

The bug is that if I enable Cool N Quiet in the UEFI, it disregards my overclock in Windows 10. Instead my speed remains at 2700MHz. If I disable Cool N Quiet, the overclock registers, but then of course the system remains at the overclocked speed all the time. Cool N Quiet works fine with the multiplier set to Auto.

Before the most recent board updates, these two settings did not conflict. I could happily have an everyday overclock of 3600MHz with Cool N Quiet enabled, which would allow the system to downclock to 2700MHz and reduce voltage accordingly.

I'm able to work around this with Ryzen Master, but I'd much rather do this at a UEFI level.

Has anyone else experienced this or otherwise reported it to MSI?
Logged

abba256

  • PRIVATE FIRST CLASS
  • ***
  • Offline Offline
  • Posts: 7
« Reply #1 on: 09-November-17, 21:25:29 »

https://forum-en.msi.com/index.php?topic=292478.0
Yes. I have this promlem too.

Reported problem to MSI - they answered that they can not replicate problem.
The only solution i found is to disable CnQ
Logged

xcom.register

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
« Reply #2 on: 14-November-17, 09:56:57 »

The bug is that if I enable Cool N Quiet in the UEFI, it disregards my overclock in Windows 10. Instead my speed remains at 2700MHz. If I disable Cool N Quiet, the overclock registers, but then of course the system remains at the overclocked speed all the time. Cool N Quiet works fine with the multiplier set to Auto.

Before the most recent board updates, these two settings did not conflict. I could happily have an everyday overclock of 3600MHz with Cool N Quiet enabled, which would allow the system to downclock to 2700MHz and reduce voltage accordingly.

I'm able to work around this with Ryzen Master, but I'd much rather do this at a UEFI level.
This also happens to my B350M Mortar Arctic, bios version 7a37vA7 (http://download.msi.com/bos_exe/mb/7A37vA7.zip).

Cool 'n Quiet enabled = multiplier sets itself to 27 (and i think vcore also changes to whatever the firmware wants)
Cool 'n Quiet disabled = multiplier  obeys my will -_-!

And as steven_ansell said, this did not happen in previous version of the firmware, in my case 7a37vA6 (http://download.msi.com/bos_exe/mb/7A37vA6.zip), both overclocking and Cool 'n Quiet worked perfectly fine.

I did not test Ryzen Master tho, but i will also prefer to do this at UEFI, i mean... that's the whole propose of having access to the SETUP program of a BIOS/UEFI.



(Also i want to see a way to control LED's in the motherboard that's not with MSI own applications, but i know that's not gonna happen so whatever)
Logged

order

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
« Reply #3 on: 04-December-17, 20:18:06 »

Same on "B350 PC MATE" board with last BIOS. Enabeling "Cool and Quiet" stick the cpu at 2800MHz.

HWINFO v.5.60 indikates that energy saving is enabled. But cool and quiet is disabeld in bios. Can anybody confirm that ?
Logged

buddyw53

  • STAFF SERGEANT
  • *
  • Offline Offline
  • Posts: 96
« Reply #4 on: 08-December-17, 16:18:49 »

Are 'Advanced C-States' (or something like that) enabled in BIOS? I have it enabled with my Mortar and Core Voltage drops way back when the CPU is idle (and that's most of the time) even though it's overclocked to 3.9Gig.  It drops to as low as .650 volts; that could mean power saving is enabled even though Cool-N-Quiet isn't enabled --and can't be in order to overclock.
Logged

steven_ansellTopic starter

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
« Reply #5 on: 30-December-17, 15:02:41 »

Are 'Advanced C-States' (or something like that) enabled in BIOS? I have it enabled with my Mortar and Core Voltage drops way back when the CPU is idle (and that's most of the time) even though it's overclocked to 3.9Gig.  It drops to as low as .650 volts; that could mean power saving is enabled even though Cool-N-Quiet isn't enabled --and can't be in order to overclock.

I've tried with C6 enabled, disabled and on auto: it has no effect on the bug.

Simply put, by having Cool N Quiet enabled, my overclock is ignored in Windows 10 and instead I'm locked at 2700MHz. The only setting where this won't happen is if I leave the multiplier at auto, at which point it will work. As such, I have to make the decision between overclocking and having Cool N Quiet.

If this had never worked, that'd be one thing, but it did work for a while in previous UEFI updates, so something must have broken it.
Logged

order

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 4
« Reply #6 on: 09-January-18, 10:07:28 »

Cool and Quiet cant be enabled in overclock. All information i found say its not posible. Thats why msi disabled it on overclocking. if you reenable it then the cpu ist stock at 2700 Mhz.
Logged

xcom.register

  • PRIVATE E-2
  • **
  • Offline Offline
  • Posts: 2
« Reply #7 on: 22-May-18, 08:13:02 »

This also happens to my B350M Mortar Arctic, bios version 7a37vA7 (http://download.msi.com/bos_exe/mb/7A37vA7.zip).

Cool 'n Quiet enabled = multiplier sets itself to 27 (and i think vcore also changes to whatever the firmware wants)
Cool 'n Quiet disabled = multiplier  obeys my will -_-!

And as steven_ansell said, this did not happen in previous version of the firmware, in my case 7a37vA6 (http://download.msi.com/bos_exe/mb/7A37vA6.zip), both overclocking and Cool 'n Quiet worked perfectly fine.

I did not test Ryzen Master tho, but i will also prefer to do this at UEFI, i mean... that's the whole propose of having access to the SETUP program of a BIOS/UEFI.



(Also i want to see a way to control LED's in the motherboard that's not with MSI own applications, but i know that's not gonna happen so whatever)
I feel the urge to revive this god forgotten post, and quote myself "this did not happen in previous version of the firmware" and  "both overclocking and Cool 'n Quiet worked perfectly fine".
Then why we can't have both?. Now I'm running A.74, and hoped to see this one working again...
Logged

buddyw53

  • STAFF SERGEANT
  • *
  • Offline Offline
  • Posts: 96
« Reply #8 on: 22-May-18, 18:07:25 »

I feel the urge to revive this god forgotten post, and quote myself "this did not happen in previous version of the firmware" and  "both overclocking and Cool 'n Quiet worked perfectly fine".
Then why we can't have both?. Now I'm running A.74, and hoped to see this one working again...
I don't think MSI can make up their minds how CnQ should function.  With latest BIOS on my Mortar ( the 1F version) enabling it drives CPU clock frequency to 1.5Ghz, constantly, disabling it and CPU frequency is correctly set but CPU VCore stays high all the time too. 

With previous version of BIOS if I set C-STates to Enabled then the CPU VCore, at least, would drop to very low values at idle.  With the current BIOS if i leave the core voltage at AUTO it does drop to low values! 

Luckily, when using a 3.9G overclock (about max the mortar's VRM's can safely handle for an 8 core Ryzen) the load voltage selected is ideal so that works out well enough to leave VCore at AUTO.

And of course if I leave everything at AUTO, with CnQ enabled, i can set any overclock or voltage with RyzenMaster and it works exactly correct by pulling back both voltage and individual cores when idling.  If there was a way to get RyzenMaster to automatically set the overclock profile at Windows boot-up I'd completely dispense with the BIOS overclock.   I would love if some third party would make a utility that does the same thing.
Logged

ste_xrysos

  • STAFF SERGEANT
  • *
  • Offline Offline
  • Posts: 69
« Reply #9 on: 26-May-18, 22:14:38 »

I don't think MSI can make up their minds how CnQ should function.  With latest BIOS on my Mortar ( the 1F version) enabling it drives CPU clock frequency to 1.5Ghz, constantly, disabling it and CPU frequency is correctly set but CPU VCore stays high all the time too.  

With previous version of BIOS if I set C-STates to Enabled then the CPU VCore, at least, would drop to very low values at idle.  With the current BIOS if i leave the core voltage at AUTO it does drop to low values!  

Luckily, when using a 3.9G overclock (about max the mortar's VRM's can safely handle for an 8 core Ryzen) the load voltage selected is ideal so that works out well enough to leave VCore at AUTO.

And of course if I leave everything at AUTO, with CnQ enabled, i can set any overclock or voltage with RyzenMaster and it works exactly correct by pulling back both voltage and individual cores when idling.  If there was a way to get RyzenMaster to automatically set the overclock profile at Windows boot-up I'd completely dispense with the BIOS overclock.   I would love if some third party would make a utility that does the same thing.
Yes but this shouldn't be the case. Relying on 3rd part software. We bought a product which is suppose to offer us these basic functions. For my B350 Tomahawk BIOS Version 7A34v1C works the closest it should. I can manually OC and both Vcore and Clock Speeds drop down fine. The only issue is that i can't set CPU Voltage below 1.3V which makes the whole thing useless once again.
Logged
Pages: [1]   Go Up