MSI Global English Forum

Motherboards => MSI AMD boards => Topic started by: Fingon on 25-October-09, 09:53:15

Title: K9A2 CF wont flash to Bios v. 1.A !!! (newest) - pls help!
Post by: Fingon on 25-October-09, 09:53:15

I have a problem. I have bought a new processor: AMD Phenom II x545. I looked on the support page of my MB (MSI K9A2 CF) and there the CPU is supported from the bios version 1.A. So I wanted to flash the Bios the the newest version (1.A). I used the MSI live update 4 program to flash it via windows mode. But everytime it boots it writes "CMOS checksum BAD", then I hit F1 to Bios and I see the version of my BIOS fell to the oldest version 1.1. Then I tried to flash it thru Flash disc (with boot files) and dos mod. The result is the same. I can flash my MB to version 1.8 but when I try the 1.A it wont flash it and my Bios fell to the oldest version (1.1). I realised that the exe files in version 1.1-1.8 are the same (afud412.exe) but the exe file in 1.A is different (afud4310.exe).

My questions are:

1) How to flash my MB to the version 1.A ?
2) Is version 1.A really needed for AMD Phenom II x545? I guess yes, because CPU was avaible in July 2009 and the bios 1.A went out in June 2009. I am able to flash it only to version 1.8 (december 2008).

Thank you for any help!!

EDIT: After reading this topic: I realised I have the VERSION 1 of this board (I purchased it right after the launch of the MB (November 2007). It means it doesnt support CPU over 95W, but my Phenpom II x545 has only 80W. I still cant update Bios to the 1.A version.

So my third question is:
3) Is the Bios update 1.A only for version 2 of this MB?

Thx for replies!
Title: Re: K9A2 CF wont flash to Bios v. 1.A !!! (newest) - pls help!
Post by: Jack on 25-October-09, 10:16:16
But everytime it boots it writes "CMOS checksum BAD"

A CMOS Checksum error is normal and expected after a BIOS Flash and/or a CMOS Clear.  The fact that this message appears, shows, that there was actually something programmed to the chip.

If you haven't done that yet, please clear CMOS with the main A/C power cable removed from your PSU and load "Optimized Defaults" in BIOS Setup.


I see the version of my BIOS fell to the oldest version 1.1

The BIOS Version should be shown on the POST Status Screen and there should be a date behind it.  Please check the BIOS Date and write it down:


oldest version 1.1

Are you absolutely and entirely sure that what you see is "1.1" and not "1.10"?  Because v1.A0 is actually just the hexadecimal notation for v1."10" (one dot ten).  The hexadecimal notation is only used in the BIOS File Ending.  Once flashed, the BIOS will not identify itself in hexadecimal notation but in decimal code (which means you will never see "v1.A0" after the flash but "v1.10" instead.

. I used the MSI live update 4 program

Here is a piece of well-meant advice for now and the future:  MSI Live Update should be avoided under all circumstances when it comes to BIOS Updates and/or information retrieval regarding your current BIOS Version.  Why?  Because this tool is stupid and one of there most risky applications for performing a BIOS Flash.  Please uninstall it completely.

Why do I call it stupid?  I call it stupid because it does not differentiate between hexadecimal notation and decimal notation.  It will show you that "v1.A0" is available.  The it will flash it, if you allow it to do so.  Of course, a v1.A0 Version will always come out as "v1.10" (one dot ten).  When you re-run MSI Live Update it will not recognize that v1.A0=v1.10 and tell you again that there is a newer version available (1.A0, which, again, is the same as v1.10, which was just properly flashed).

I believe that the update went just fine, that you are currently using v1.A0=v1.10 and that MSI Live Update is actually just creating a pseudo-problem which is currently confusing you.  The pseudo-problem will immediately be out of the world, if you uninstall MSI Live Update and rely on the BIOS ID String as it appears on the POST Status Screen (this includes the date shown there).

If a BIOS Update should ever be necessary again, please make sure that you won't use MSI Live Update but >>Use the MSI HQ Forum USB flasher<< ( instead.
Title: Re: K9A2 CF wont flash to Bios v. 1.A !!! (newest) - pls help!
Post by: Fingon on 25-October-09, 11:03:44
Thank you for the quick reply!!

Thats exactly what I have JUST found in this post by Svet:
Yes it is 1.10 of course!! I didnt know that 1.10 = 1.A0 ! Thank you for the reply. Then the MSI live update 4 program is dump that he wanted from me another update of Bios.

So thank you! Problem is solved.  :biggthumbsup:

Edit: Yes, because of MSI live update I learned how to flash bios via flash disc. :-) But I was still confused by that 1.10 and of course by program saying me I should update again.. :-P