MSI Global English Forum

Other MSI Components => Other MSI products => Topic started by: cardona302 on 31-October-15, 18:28:20

Title: My MSI DS200 Interceptor mouse is not working please help
Post by: cardona302 on 31-October-15, 18:28:20
I just bought the MSI DS200 Interceptor gaming mouse for my new MSI laptop. The laptop works just fine but the mouse is not working. I plug it in and it lights up and my computer makes that sound when you plug in a USB device and I can even change the color of the lights... and that's is it... the mouse pointer does not move and the buttons are non responsive. So I grabbed an extra mouse I had lying around and it worked just fine. Why is my MSI mouse not working. I have already tried reinstalling the drivers but that did nothing.
Title: Re: My MSI DS200 Interceptor mouse is not working please help
Post by: Pesoen on 05-January-16, 05:35:18
sorry for being a bit late, but have you tried using the mouse on another pc? easiest way to find a problem, is to try multiple computers, if it is a mouse or similar device.

i would suggest trying any other computer you can get access too, dont install the software, just plug it in, and see if it works, if it does, it might be a driver issue on your computer, if it still does not work, the mouse might be faulty.
Title: Re: My MSI DS200 Interceptor mouse is not working please help
Post by: colin.birch42 on 19-April-16, 23:19:24
I have the same problem, the mouse worked initially (approx 3 hrs) now it lights up but nothing. I tried it on my wifes laptop and got a "device faulty" message.
Title: Re: My MSI DS200 Interceptor mouse is not working please help
Post by: darkhawk on 20-April-16, 00:36:16
Best to contact MSI directly about it here : >>How to contact MSI.<< (https://forum-en.msi.com/index.php?topic=107326.0)
Title: Re: My MSI DS200 Interceptor mouse is not working please help
Post by: alphawolfcw on 13-August-19, 01:41:13
my dudes im not sure but i have found a solution there is dust inside the mouse if you use a dust air spray near the scroller wheel it fixed my issue i hope it fixes yours too. 


__-sign __ ALPHAWOLFCW -STEAM