MSI Global English Forum

Motherboards => MSI Intel boards => Topic started by: muskokarc on 20-July-19, 02:28:15

Title: System won't post without Ps2 keyboard...Error 99
Post by: muskokarc on 20-July-19, 02:28:15
Just grabbed a B75A-IE35 motherboard off ebay, put my old i7 2600k in it. All seems ok other than it "will not" post if I don't have a Ps2 keyboard plugged in. All I get is a black screen with a code 99 in the bottom right corner of the screen If I plug in a Ps2 keyboard the system posts and boots into Windows fine, brand new Windows 10 install. All Usb settings in the bios are enabled, it simply doesn't make any sense. The last Bios I can find, and is installed, is from 2013, version 10.10, so this system should post/boot just fine from a wireless usb keyboard. My Asus P8P67 Pro had no issues at all posting/booting to the exact same wireless usb keyboard.

Any ideas, or can someone suggest a bios setting I may be overlooking. I've gone through every bios option, can't seem to get beyond this annoyance.
Title: Re: System won't post without Ps2 keyboard...Error 99
Post by: muskokarc on 20-July-19, 15:36:28
Keyboard is a Logitech K520.

I found a bios update for this specific board from 2017 on the Chinese Msi site, stating improved usb keyboard and mouse capability, but it will not flash. When I use M-Flash it says there's no bios file to flash, yet the file is clearly in the root directory of my usb thumb drive. The extension of the bios file is different than the backup I created, why would that be? The backup is AA0, the newer bios is AA4. This is a version 4 board.

The board is currently out of the case on the bench. I've tried to boot from all 6 usb ports, won't post with a wireless usb keyboard in any of the usb ports. As soon as I plug in the Ps2 keyboard it posts/boots fine. I really don't want to have to use this ancient Ps2 keyboard.
Title: Re: System won't post without Ps2 keyboard...Error 99
Post by: badboy2k on 20-July-19, 16:09:51
in advanced - USB Configuration is Legacy USB Support Enabled?
Title: Re: System won't post without Ps2 keyboard...Error 99
Post by: muskokarc on 20-July-19, 16:28:38
in advanced - USB Configuration is Legacy USB Support Enabled?

Thanks for replying, yes it is. 
Title: Re: System won't post without Ps2 keyboard...Error 99
Post by: badboy2k on 20-July-19, 16:59:55
just to make sure are you plugging the USB into one of the rear USB 2.0 Ports not the Blue USB 3.0 Ports?
Title: Re: System won't post without Ps2 keyboard...Error 99
Post by: muskokarc on 20-July-19, 18:02:36
Yes, the board is out of the case, cpu, ram, wired usb mouse, on board video. I've tried all the back ports, usb 2/3, makes no difference. If that Ps2 plug isn't occupied, it won't post.

I even tried with a Ps2 to usb adapter with my wireless usb keyboard dongle plugged in, it posts, but the keyboard does not work. Something has to be in that Ps2 plug for it to post. I tried with just the Ps2 to usb adapter and nothing plugged into it, wouldn't post.
Title: Re: System won't post without Ps2 keyboard...Error 99
Post by: muskokarc on 21-July-19, 16:38:36
Not finding an answer or fix anywhere, guess I'll send it back, get a refund, and move on.