40x12x48 Dragonwriter problems



Just recently purchased my 40x12x48 and haven't been able to write one full CD :(

At random times during the writing process, Nero returns a 'communication error'. The CDRW is the only drive on the onboard ide - my HDDs run off a Promise RAID card - and I've tried the obvious: download new 4-in-1 drivers for my chipset, flash the firmware, upgrade/downgrade Nero, change ide channels and try other CD writing software. But all in vain.

My system is an old Athlon 600, running win2k.

Anyone? Anyone?


I think you've got a problem getting the data off the Promise card. With a V I A based chipset, you're always pushing your luck with RAID, PCI latency, etc. :( :evil:

I would benchmark your hard drive system with Atto's HDD benchmark to see if it can sustain high speed writes. You can get it from the link on this page along with some others.

If you're really desperate to burn a CD, I suggest you make an image file before you burn, and also defragging your drive should help matters a bit.

If your hard drive is partitioned, make sure that the boot partition has at LEAST 1 GB of free, defragged space.


edit: It'd be better also if your HDD was on the onboard IDE, unless there was a serious problem which caused you to use the Promise controller.


OK - finally got it together. After hours of fighting, changing IDEs, defragging etc, someone finally suggested I flash upgrade my mainboard BIOS. Now the writer works perfectly :D

FYI, I have an old FIC mobo from 2000.

Thanks for the suggestions - can't tell you how relieved I am :)


Hello, I have also problems with my cd-writer. First it burned nicely 16x cd-roms and I didnt care about it because those cd-r?s where only supported to 16x. Now I got better roms and those are supported to 32x. If I try to burn them with Nero I can?t do it at all. Every single burn has failed. I installed the bundle version that i got with the drive ( and I can burn cd?s with 8-16x. I have read these boards now many hours and noticed that firmware update is what I need. Well I went to dl page and took the correct firmware and installed it. I rebooted my pc and tried to burn cd. Surprise, surprise it failed again.

What to do? Buy new burner that is not MSI?

KT3 Ultra-ARU MS-6380E
amd athlon 1200
40gt samsung Ide master (dm mode 5)
40x12x48 Dragonwriter 2nd ide (master dma mode2)
geforce1 ddr
winxp pro
nero or

I just wonder that what I?ve done wrong because others seems to get help from firmware update. I really appreciate answers. And the burn fails, it doesn?t matter if I try to backup cd or just burn simple data.