audio issue after latest realtek driver update on creator x299

lingaraju.g

New member
PRIVATE E-2
Joined
Jul 10, 2020
Messages
26
so i updated to latest realtek driver version listed on msi download page and after installing by going through the process of uninstalling and rebooting and installing driver and then installing nahimic restore driver i am not hearing any audio, already have nahimic 3 installed from windows store and reinstalled that as well rebooting after step but not working, i use windows 10 20h2, any help please, thank you.
 

vick1000

Member
PRIVATE E-2
Joined
Dec 2, 2019
Messages
269
Are you using HDMI connection? Make sure the Realtek device is set to default in Sound options.
 

katbornride157902e3

New member
Joined
Mar 9, 2021
Messages
1
Hi I'm having the same issue . I have gone on MSI Support and there isn't any drivers for GE73 Raiders laptop which i bought new just over 2 years ago so its not that old . Going on trouble shoot which couldn't repair as there's no audio out. The Audio used to be Realtek but now that's saying it doesn't support my laptop Can any one help ? Please. i have factory reset my laptop but that didn't help . The issue started after the update yesterday
 

lingaraju.g

New member
PRIVATE E-2
Joined
Jul 10, 2020
Messages
26
As I understand the nahimic 3 is probably not updated to support the new driver but who knows what it is, can't seem to find the old driver before latest release, I got tired of the issue and just let windows install default built in drivers and works now but might have to wait until something is fixed.
 

pinoyerpx

Member
SERGEANT
Joined
Nov 18, 2019
Messages
73
is this your MSI motherboard, lingaraju.g?
latest Realtek audio driver for that one is currently v6.0.9102.1.

v6.0.9084.1 Realtek audio driver is available here but listed for certain MSI laptops (when MSI releases new Realtek audio drivers for MSI boards, they replace the old ones with new versions) - the nahimic integration APO driver is not included for this one, so you need a separate nahimic APO driver.
 

lingaraju.g

New member
PRIVATE E-2
Joined
Jul 10, 2020
Messages
26
No my board is creator x299 that released for 10th gen Cascade lake x cpu and driver version is right one and it did have the nahimic apo restore with it, when I was updating windows yesterday it did install some a volute components which might be the update for the nahimic app and believe it should fix it but haven't tried it again as the default windows hd audio driver works just fine.
 

lingaraju.g

New member
PRIVATE E-2
Joined
Jul 10, 2020
Messages
26
ok so windows has installed a-volute updates and i see nahimic mirroring device and re-installed driver and now all is well.
 

pinoyerpx

Member
SERGEANT
Joined
Nov 18, 2019
Messages
73
No my board is creator x299 that released for 10th gen Cascade lake x cpu and driver version is right one and it did have the nahimic apo restore with it, when I was updating windows yesterday it did install some a volute components which might be the update for the nahimic app and believe it should fix it but haven't tried it again as the default windows hd audio driver works just fine.
whoops. sorry, my mistake - should have been this one (I got confused between "creation" and "creator")

this other person who have realtek + nahimic driver problems but using a much different MSI board decided to re-install Windows to resolve the problem, also running Win10 20H2. sometimes Microsoft screws something up with some of their recent Win10 updates
 
Top