B360-A Pro No ethernet after bios update

bill.cole578

New member
PRIVATE FIRST CLASS
Joined
May 25, 2020
Messages
6
Hi everyone, I recently updated my bios and after my ethernet would not work I read multiple solutions online which involved uninstalling all network adapters and drivers and reinstalling to no avail, ive reinstalled windows twice now and still nothing, ive seen on other threads people have had the same issue and discovered my mad address was wiped, I have the I129-V lan and ive tried different mac address tools to restore my address but each time it says no adapter available, in device manager I see the Intel(R) Ethernet Connection I129-V but it has a yellow exclamation mark. if anyone could help it would be appreciated, it might also be worth noting I have nothing in my network adapter settings Local area connection isn't there or anything.
 

fatedust

Survey Corps
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
2,043
Hi bill.cole578,

What version of BIOS are you using? Could you take a screenshot of your Device Manager?
Btw I guess it is "Intel(R) Ethernet Connection I219-V" not "Intel(R) Ethernet Connection I129-V" right? Have you tried to update it?
 

bill.cole578

New member
PRIVATE FIRST CLASS
Joined
May 25, 2020
Messages
6
I attached a picture of my device manager, The bios is version 7B22v29 which Is the current on the support page, I had just updated the bios to this which is when the problem occurred.
 

Attachments

fatedust

Survey Corps
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
2,043
You need to install the correct driver for your "Intel(R) Ethernet Connection I219-V" so that you can go on restoring the mac address. 
Try to download the driver and install/update it from the product page of your motherboard >>here<< (LAN Drivers > Intel Network Drivers)
 

bill.cole578

New member
PRIVATE FIRST CLASS
Joined
May 25, 2020
Messages
6
So I updated the drivers again, and I've tried using a change Mac program in free dos, I used the Mac address located on the board, it's just gives me the message : No supported adapters were located. Is there anything else I need to do beforehand?
 

fatedust

Survey Corps
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
2,043
Does Intel(R) Ethernet Connection I129-V still have a exclamation mark now? How did you update your BIOS? 
 

bill.cole578

New member
PRIVATE FIRST CLASS
Joined
May 25, 2020
Messages
6
Yes the exclamation mark is still there and there's nothing at all in network adapter settings unless I'm using my phone as a WiFi tether, I updated the bios using m-flash through the bios and using the bios update on my motherboards support page
 

fatedust

Survey Corps
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
2,043
Since your LAN controller still has an exclamation mark, it will fail with Mac recover tool too. 
Did you do anything else except updating BIOS atm?
 

malossi15cd02e1

New member
Joined
Sep 12, 2020
Messages
1
Same here, MAC address of onboard card wiped after BIOS update (it is now FF:FF:FF:FF:FF:FF) but with an older board (MS-7293VP). Any chance to get the MAC flashing software? Thanks in advance
 

lene154a02d3

New member
Joined
Nov 23, 2020
Messages
1
I got a B360 Gaming Plus motherboard that have the same problem, mac address is FF:FF:FF:FF:FF:FF after I flashed the the latest 7B22v2C BIOS. Ethernet does not work in either linux or win10.
 

slckuz15ba02ed

New member
Joined
Nov 27, 2020
Messages
8
Hey, i have H410M A pro motherboard and having the same problem. My ethernet isnt usable now. Can you help me please ??
 
Top