B550 tomahawk mag SSD Help.

xymonphoeni14f902da

New member
Joined
Sep 13, 2020
Messages
7
Hi.
I have issue with my SSD nvme ofc.
Just let me make sure i understand right. if there 2 m2 slot Gen4 and Gen3. if only use 1 slot that nvme must be full speed able. and only use graphic card in pcie slot.
So Samsung 970 Evo Plus 1TB, (2 particion 1 300gb for system 700gb for softwares)
Must be that SSD 3.5k write and read but only do half!. any idea?
and Yes i put in LightingGen 4 socket that.
so
1600980592837.png
Sams1_LI.jpg
 

laurence1211

Active member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
421
What happens when you turn off anti virus programs? Also do you have dragon center installed? I am assuming you are running up to date ssd firmware and windows with the latest amd chipset drivers and motherboard bios.
 

citay

Active member
SERGEANT
Joined
Oct 12, 2016
Messages
813
The answer is right there in your second screenshot. "PCIe Gen3 x2".

Here's the same screen for my 970 Pro:

Unbenannt.png



So your SSD is somehow only running on two PCIe lanes instead of four. This is the cause of those lower numbers.

I would just try it in the other M.2 slot, and if it works with four lanes there, just leave it in there.
 

laurence1211

Active member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
421
The answer is right there in your second screenshot. "PCIe Gen3 x2".

Here's the same screen for my 970 Pro:

View attachment 141340


So your SSD is somehow only running on two PCIe lanes instead of four. This is the cause of those lower numbers.

I would just try it in the other M.2 slot, and if it works with four lanes there, just leave it in there.
Nice catch, I missed that. Still it is odd it's only x2.
 

citay

Active member
SERGEANT
Joined
Oct 12, 2016
Messages
813
Yeah, quite odd.

xymonphoeni14f902da (why are the forum names so weird sometimes at the end?), you can also try a Clear CMOS first (see manual), and updating the BIOS if you are on an older version.
 

badboy2k

Well-known member
Global Moderator
Joined
Feb 11, 2012
Messages
9,196
also as its running in 3.0x2 it may be worth taking it out and reseating the SSD as it may not be in the slot all the way leading to the lower link speed.
 

citay

Active member
SERGEANT
Joined
Oct 12, 2016
Messages
813
I had that idea too, but then i thought, wouldn't the screw make sure that it must be all the way in the slot? I guess there could be a little wiggle room left in there.

Yes, it has to be fully pushed in at a 30° angle first, before pushing it down and securing it with a screw.
 

xymonphoeni14f902da

New member
Joined
Sep 13, 2020
Messages
7
Ty guys i try replace from lighting gen 4 to other nvme slot. As 970 evo plus gen 3 anyway so that slot is good for it. But if i buy gen 4 nvme then have same issue with that? Btw yes latest bios and softwares. Just builded last week this pc.
Ryzen 5 3600xt
32gb 3600mhz vengeance
Gtx 1660ti.
And b550 tomahawk mag.
Performance awesome in this cheap config and so happy how the prices falles last 10 year lol xD
 

citay

Active member
SERGEANT
Joined
Oct 12, 2016
Messages
813
That's more like it. It won't get the same write speed, that's normal. Write is always under 3 GB/s. Even the 970 Pro 1TB doesn't write faster. Only the 980 Pro improves that to around 4 GB/s.
Not that it makes a big difference anymore. Most of the time, the bottleneck is somewhere else.
 

laurence1211

Active member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
421
If you move the drive back to the other m.2 slot, does the issue come back?
Edit: do you have any other pcie devices plugged in?
 
Last edited:

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
76,089
(why are the forum names so weird sometimes at the end?),
To prevent showing email addresses, the default names are auto pickup from register.msi.com
and email address are replaced with those random at the end,
the username are changeable if someone doesn't likes the default one.
 
Top