BIOS UPDATE - Z87-G45

Digitally

New member
CORPORAL
Joined
Jul 27, 2014
Messages
20
Hi,

i have some issues with my Z87-G45 . it start with the fact that i couldn't change my RAM speed and now i basically cannot save any changes. i thought maybe  update the BIOS might help but i got a bit confused after watching this video:
https://www.youtube.com/watch?v=1Z76WuN8eTg

on the download page of the BIOS update v1.9 it says "update BIOS & ME" but in the video he choose to onlu update the BIOS. So which one should i choose?
 

Chike

New member
GENERAL
Joined
Nov 20, 2013
Messages
7,186
How exactly you cannot make any changes?
Have you tried clearing CMOS?

Fix the board model in your sig, 4670k is LGA 1150, we have a saying: All that adds subtracts, we know what socket is 4670k
 

Digitally

New member
CORPORAL
Joined
Jul 27, 2014
Messages
20
well, i make changes and then press F10 for save and restart (i actually tried to save and restart in other ways too) and then when the unit turns up its let me choose between F1 for setup or F2 to continue and somewhere above, its say the all setting are back to default. as if i just cleared the CMOS. And yes i did tried to clear the CMOS but no change.

 
 

Chike

New member
GENERAL
Joined
Nov 20, 2013
Messages
7,186
I assume you change settings in the OC section.
Suppose you just change ram frequency from auto to the actual valu it is set to bu default, would that fail?
Or change CPU Voltage Mode to ovvevride, and leave CPU Volta auto, would that fail?
 

Digitally

New member
CORPORAL
Joined
Jul 27, 2014
Messages
20
it dosent matter im trying to change, it wont save it later.
i can't even set my SSD to boot first. after i press F10 it goes back to default. so all i want to know is if i should update 1.8 to 1.9 from BIOS or BIOS & ME ?
 

Chike

New member
GENERAL
Joined
Nov 20, 2013
Messages
7,186
I know what you are asking, but I'm confident BIOS 1.8 did not have such bug as saving any kind of settings or it would have been removed from the download page for being useless.
Is this a new build or was it OK before?

I suggest you first follow >>Clear CMOS Guide<< and leave it with the jumper on for the night, see if it's any better in the morning.

The simple answer to your question is follow manufacturer instructions, not some youtube video you have found.
 

Nichrome

Active member
Global Moderator
Joined
Nov 7, 2013
Messages
18,895
Hi

Follow the >>Clear CMOS Guide<< as already been suggested.

Also you could try replacing the motherboard battery with new one and see if that fixes the issue.

Try above first before you attempt to flash.

For flashing, you can either use MFlash and file from MSI's website (use BIOS+ME update one) or you could try Forum flashing tool (bit more advanced but some users find it to be more trustful)
 
Top