BSoD issues with new MSI X570 Tomahawk

ahmad.elpaso

New member
Joined
Jul 30, 2020
Messages
6
I have built a new PC:

Mobo: MSI Tomahawk X570
CPU: AMD Ryzen 5 3600
GPU: AMD Radeon RX 5700 XT
16gb ddr4 ram
1TB SSD NVme

I have been suffering from different BSoD errors:

KERNEL_SECURITY_CHECK-FAILURE

REFISTERY_FILTER_DRIVER_EXCEPTION

DRIVER_IRQL_NOT_LESS_OR_EQUAL

IRQL NOT LESS OR EQUAL

KMODE_EXCEPTION_NOT_HANDLED


I have tried everything:
1- I updated the all the drivers from MSI website, and made sure that windows and all the drivers are up to date

2- I restored windows. And later I did a clean installation of windows

3- I run all the diagnostic tool that I could found: chkdsk. Memory diagnostic tool, SFC, DISM: No issues were found!!


I just want to know what the issue is, is there a way to identify which component is failing, is it possible that there is a problem with the mobo itself?

Thanks in advance for your help!
 

zerijelly

Member
FIRST LIEUTENANT
Joined
Jul 5, 2016
Messages
489
1.Under what condition the BSOD occurs?
Are you running game?
You could monitor CPU, GPU temperature when issue occur:
HWinfo: https://www.cpuid.com/softwares/hwmonitor.html
And search "Configuring MSI Afterburner + HWinfo64 for On Screen Display (2014)" on Youtube for setting OSD using HWiNfo.(Due to Forum block my Youtube link atm)
2. Did you enable A-XMP in BIOS?
3. Update BIOS to the latest 7C84v10 if the MB is X570 TOMAHAWK WIFI.
 
Last edited:

ahmad.elpaso

New member
Joined
Jul 30, 2020
Messages
6
1.Under what condition the BSOD occurs?
Are you running game?
You could monitor CPU, GPU temperature when issue occur:
HWinfo: https://www.cpuid.com/softwares/hwmonitor.html
And search "Configuring MSI Afterburner + HWinfo64 for On Screen Display (2014)" on Youtube for setting OSD using HWiNfo.(Due to Forum block my Youtube link atm)
2. Did you enable A-XMP in BIOS?
3. Update BIOS to the latest 7C84v10 if the MB is X570 TOMAHAWK WIFI.
Thank you for your answer:
1-BSoD happens in different situations, but mostly in idle. Also it happened once as I'm playing games and several times while just surfing the internet.
Temperatures are fine, nothing weird here.
2- It was enabled, but I turned it off after the issues started, but the issue was not resolved.
3- I have the same mobo and the same BIOS
 

Svet

Active member
Administrator
Joined
Nov 20, 2003
Messages
75,900
Provide more details about your memory sticks, brand/model, at what mem. freq. and timmings they are running.
How many sticks are they in which slots are installed?

Do run test with Memtest:

And/+ Prime95:
Use "In-place large FFTs"
 

ahmad.elpaso

New member
Joined
Jul 30, 2020
Messages
6
Provide more details about your memory sticks, brand/model, at what mem. freq. and timmings they are running.
How many sticks are they in which slots are installed?

Do run test with Memtest:

And/+ Prime95:
Use "In-place large FFTs"
Thanks for your answer.

I am using Corsair Vengence DDR4 16GB (2*8) 3200MHz C16. And they are working at 2133MHz.

I have run both tests, no error was found and the system was working fine as they were working.

The windows keeps crashing and providing an error related to driver failure. I have contacted Windows support today, and they said that it's probably a motherboard related issue. Currently I have the last (not Beta) version of the BIOS, but I am afraid that it is a hardware issue, would you advise me to send the mobo back (I hope not).
 

Svet

Active member
Administrator
Joined
Nov 20, 2003
Messages
75,900
I have run both tests, no error was found and the system was working fine as they were working.
for how long you keep them testing?

The windows keeps crashing and providing an error related to driver failure.
What PSU you are using?
Can you also check in Windows, Event Logs, Windows Logs, System
for the exact logged BSOD error code(s)? [Source: BugCheck]
 
Joined
Aug 2, 2020
Messages
8
I have built a new PC:
Mobo: MSI Tomahawk X570
CPU: AMD Ryzen 5 3600
GPU: AMD Radeon RX 5700 XT
16gb ddr4 ram
1TB SSD NVme
I have been suffering from different BSoD errors:
KERNEL_SECURITY_CHECK-FAILURE
REFISTERY_FILTER_DRIVER_EXCEPTION
DRIVER_IRQL_NOT_LESS_OR_EQUAL
IRQL NOT LESS OR EQUAL
KMODE_EXCEPTION_NOT_HANDLED
I have tried everything:
1- I updated the all the drivers from MSI website, and made sure that windows and all the drivers are up to date
2- I restored windows. And later I did a clean installation of windows
3- I run all the diagnostic tool that I could found: chkdsk. Memory diagnostic tool, SFC, DISM: No issues were found!!
I just want to know what the issue is, is there a way to identify which component is failing, is it possible that there is a problem with the mobo itself?
Thanks in advance for your help!
 
Joined
Aug 2, 2020
Messages
8
I have built a new PC:
Mobo: MSI Tomahawk X570
CPU: AMD Ryzen 5 3600
GPU: AMD Radeon RX 5700 XT
16gb ddr4 ram
1TB SSD NVme
I have been suffering from different BSoD errors:
KERNEL_SECURITY_CHECK-FAILURE
REFISTERY_FILTER_DRIVER_EXCEPTION
DRIVER_IRQL_NOT_LESS_OR_EQUAL
IRQL NOT LESS OR EQUAL
KMODE_EXCEPTION_NOT_HANDLED
I have tried everything:
1- I updated the all the drivers from MSI website, and made sure that windows and all the drivers are up to date
2- I restored windows. And later I did a clean installation of windows
3- I run all the diagnostic tool that I could found: chkdsk. Memory diagnostic tool, SFC, DISM: No issues were found!!
I just want to know what the issue is, is there a way to identify which component is failing, is it possible that there is a problem with the mobo itself?
Thanks in advance for your help!
 

sie_uk

New member
PRIVATE E-2
Joined
Jul 18, 2020
Messages
21
Thank you for your answer:
1-BSoD happens in different situations, but mostly in idle. Also it happened once as I'm playing games and several times while just surfing the internet.
Temperatures are fine, nothing weird here.
2- It was enabled, but I turned it off after the issues started, but the issue was not resolved.
3- I have the same mobo and the same BIOS
This is a graphics driver issue. I had the same with 5700xt. It wont be the power if its happening on idle and not under load.
Go to AMD and get an older driver. I think im using 20.4 not 20.7 series. The 20.7 seeies are unstable for me and the latest is still in beta stage. Use DDU to remove then install 20.4.
 
Joined
Aug 2, 2020
Messages
8
Have GTX 1080TI and the same problems, been working all weekend with my build and when I deactivated Ethernet it worked for me, when I activated Ethernet it crash when I tried to install a game, but with only wifi it didn't crash when I install software and games
 
Joined
Aug 2, 2020
Messages
8
Have GTX 1080TI and the same problems, been working all weekend with my build and when I deactivated Ethernet it worked for me, when I activated Ethernet it crash when I tried to install a game, but with only wifi it didn't crash when I install software and games
 
Joined
Aug 2, 2020
Messages
8
Have deleted Ethernet and downloaded the latest driver. Installed it again and now it seems to work. I only tried to update the driver earlier but apparently it didn't work then.
 

ahmad.elpaso

New member
Joined
Jul 30, 2020
Messages
6
for how long you keep them testing?



What PSU you are using?
Can you also check in Windows, Event Logs, Windows Logs, System
for the exact logged BSOD error code(s)? [Source: BugCheck]
I have left the test running for about an hour, it was totally fine.

I am using Seasonic 750W platinum.

I am receiving different error code with every crash, I can send you the dump file if you like.

Thanks for your help by the way.
 

ahmad.elpaso

New member
Joined
Jul 30, 2020
Messages
6
Have deleted Ethernet and downloaded the latest driver. Installed it again and now it seems to work. I only tried to update the driver earlier but apparently it didn't work then.
Thank you for your reply.

I don’t have access to a near Ethernet cable and thereforI only use WiFi, but the system keeps crashing.

I am starting to think of sending the motherboard back and search for something else :/
 

ahmad.elpaso

New member
Joined
Jul 30, 2020
Messages
6
This is a graphics driver issue. I had the same with 5700xt. It wont be the power if its happening on idle and not under load.
Go to AMD and get an older driver. I think im using 20.4 not 20.7 series. The 20.7 seeies are unstable for me and the latest is still in beta stage. Use DDU to remove then install 20.4.
Thank you for your reply.

I did as you suggested and rolled back to 20.4, no luck unfortunately.
This is why I’m guessing now it’s a motherboard issue rather than a GPU issue.
 
Joined
Aug 2, 2020
Messages
8
Thank you for your reply.

I don’t have access to a near Ethernet cable and thereforI only use WiFi, but the system keeps crashing.

I am starting to think of sending the motherboard back and search for something else :/
Ok, then I can't help. For me it was the Ethernet driver that crashed the system, been working fine since I reinstalled a week ago. Good luck
 

michaelstae44f20655

nothing to see, move along now.
Joined
Aug 9, 2020
Messages
1
I had the BSOD every 5-10 minutes with the KMODE_EXCEPTION_NOT_HANDLED error. This was constant for 3 days and I may have fixed it. The error is the RX 570 driver I was using (which was the most up-to-date), and by installing a previous version of the driver I have not had a crash for 45 minutes.
 
You must log in or register to reply.
Top