dGPU is always on even with forced Integrated graphics

amartyne9152a02d3

New member
Joined
Jan 27, 2021
Messages
8
Hello everyone,
I have GE75 10sgs. I've noticed that battery discharges very fast in idle mode if I won't even move a mouse. It takes 1.5 hours. Eventually, I was able to determine that dGPU is always on and very recently I realized what that small led on top right near power button means. It shows if laptop uses dGPU when it's red and lights up with white when iGPU is used. It's almost always red, but sometimes randomly switches to white and then back to red.
Funny thing is that if I put laptop to sleep and enable it after several minutes it shows that iGPU is used and batter doesn't drain fast. After some time the led indicates dGPU is used if I do some web browsing. Whenever laptop starts to use dGPU for no reason there is no way to make it use iGPU without putting it to sleep mode. I opened Process Explorer and kill everything that is killable. I stopped NVIDIA services, uninstalled every MSI software and Nahimic, every monitoring application. I even did factory reset and used listed NVIDIA driver on MSI website. It simply won't stop using dGPU. NVIDIA GPU activity doesn't show any programs using dGPU. Process Manager doesn't show any process that would use dGPU. If I switch to "Integrated graphics" mode in Nvidia Control Panel it still won't work. If I restart laptop with "Integrate graphics" mode enable it still shows that dGPU is used.
Eventually, I realized the more I keep laptop in sleep mode the longer I will be able to use programs before this bug will start reproducing. MSI, no more! I swear to gods, this is the last MSI laptop I bought :'(

My post on reddit: Reddit- GE75 10SGS-222 drains battery too fast on idle. With no load at all it has 40W average discharge rate.
 
Last edited:

amartyne9152a02d3

New member
Joined
Jan 27, 2021
Messages
8
Today I noticed that if I play some video my dGPU led goes white and doesn't switch to red anymore. Battery discharge is great and there is no more dGPU activity!
 
Last edited:

jojo.lin

Member
STAFF SERGEANT
Joined
Oct 11, 2013
Messages
71
Please check Windows Update to insure your system has applied the lasted Windows10 20H2.
Good luck.
 

amartyne9152a02d3

New member
Joined
Jan 27, 2021
Messages
8
Please check Windows Update to insure your system has applied the lasted Windows10 20H2.
Good luck.
Just updated to 20H2, but the problem still persists. dGPU led goes nuts and changes color each 30 seconds. Started a video playback and the led got white.
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
2,529
DRAGON/GENERAL/GPU-switch - igpu
and it is impossible for d-gpu to run

or MIX ,.,,and must set app profiles "browsers" HW acceleration off // or profile for igpu
 

amartyne9152a02d3

New member
Joined
Jan 27, 2021
Messages
8

app/setup for optimus
LINKS

it's hard to translate everything .,,,try links and learn :-)

edit ,,.., SUPER BATTERY in DC -- ECO profile

https://i.ytimg.com/vi/p2bSg7ix7os/maxresdefault.jpg
fast way --gpu mode
First of all I wanna say that I really appreciate that you are helping me! Thank you so much for that!

My DC doesn't how option to select iGPU or dGPU, that's being controlled by OPTIMUS only.
I tried to kill all processes 1 by one using Process Explorer. I disabled all services that wouldn't make Windows to restart. Neither Process Manager nor Process Explorer do not show dGPU usage. Nvidia activity doesn't show apps using dGPU. It seems to me it is a problem with nvidia driver. That's looks weird, but whenever iGPU runs video processing and decoding dGPU doesn't get activated without a reason. You can trust that I googled everything and did factory reset. I was able to reproduce the problem right after factory reset as well. Any other suggestions are very welcomed! :)
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
2,529
First of all I wanna say that I really appreciate that you are helping me! Thank you so much for that!

My DC doesn't how option to select iGPU or dGPU, that's being controlled by OPTIMUS only.
I tried to kill all processes 1 by one using Process Explorer. I disabled all services that wouldn't make Windows to restart. Neither Process Manager nor Process Explorer do not show dGPU usage. Nvidia activity doesn't show apps using dGPU. It seems to me it is a problem with nvidia driver. That's looks weird, but whenever iGPU runs video processing and decoding dGPU doesn't get activated without a reason. You can trust that I googled everything and did factory reset. I was able to reproduce the problem right after factory reset as well. Any other suggestions are very welcomed! :)
check NVIDIA FOLDER
C:\Program Files\NVIDIA Corporation
exist NVSMI folder ???


some system sup-process -- native HWaccelaration or web browser !
NVSMI -better than taskmanager " "may not exist on DCH driver" " ,.,.,.optimus --better using DCH

from my system ,.,.what use all time gpu " add profile or in nvidia panel for this APP -i-gpu
Name : C:\Windows\explorer.exe

Name : C:\Windows\SystemApps\Microsoft.Windows.StartMenuExperienceHost_cw5n1h2txyewy\StartMenuExperienceHost.exe

Name : C:\Windows\SystemApps\Microsoft.Windows.Search_cw5n1h2txyewy\SearchApp.exe

Name : C:\Windows\SystemApps\MicrosoftWindows.Client.CBS_cw5n1h2txyewy\InputApp\TextInputHost.exe
 
Last edited:

nysmeee155102da

Active member
Joined
Jan 4, 2021
Messages
600
Can you list some action that you were performing when you see the LED on the power button switch from using iGPU to using dGPU (besides web browsing)?
Which browser you use? It happens to all browsers?

Did you connect the laptop to the Internet right after you did the factory reset?

From the system info file you provide, you updated the NVIDIA graphics driver.
What if you don't update the NVIDIA driver? Although you've updated drivers on your own a few times, still recommend that you try the following and monitor the situation again.
1. Download graphics drivers from MSI website.
2. Disable the wifi connection to prevent the laptop from being updated by Windows Update.
3. Clean install both graphics drivers with DDU, and install the drivers from msi website.
 
Top