Fix for 25w Power Limit Throttling on GF63 and some other models

aronfaine

New member
PRIVATE E-2
Joined
Jun 20, 2020
Messages
5
TL;DR You can leave Dragon Center or Silent Option installed, but you cant use it. Setting the fan mode to anything besides Auto is what causes the throttling issue. Leave the fans on Auto, or uninstall DC or SO and you get normal performance. This will cause higher temps, as Auto doesnt let the fans get to 150% like Advanced and CoolerBoost do, but thats the solution for this bug. It could potentially be fixed with an EC firmware update.

More details follow:

Ive recently purchased the GF63 Thin 9SC, with the i5-9300H, 1650 MaxQ, and a 1080p 60hz screen.

I had weird issues with the CPU throttling *hard* under load, starting at 45 watts for only a few seconds before going down to 25 watts and having very power performance. The GPU never had any issues.

I stumbled across two threads, https://forum-en.msi.com/index.php?threads/311865 shows someone with the older model of my laptop, with an i5-8300H and a GTX 1050 MaxQ. They suffered the exact same problem.

They eventually found that deleting Dragon Center (and not installing Silent Option) fixed the issue entirely, as they figured that out from installing Ubuntu, and doing a fresh install of Windows 10 where DC and SO arent installed.

It was then found by another user that you can leave DC and SO installed, but you cant use any fan profile except Auto. Using any other fan profile besides Auto will cause the CPU to go into "passive cooling" mode.

Passive cooling means when temps get high, the CPU will pull back and throttle down BEFORE the fans will speed up. Passive cooling reduces power usage and fan noise, but of course severely reduces performance. Its almost certainly a bug or oversight in MSI's EC firmware. Because when using any fan mode except Auto,the fans are set to a fixed speed or user-defined curve, the EC cant control the fans, and assumes they cant be relied on, so it throttles the system since thats the only other thing it can do to combat high temps. Its like taking away control of the fans from the EC causes it to enter a fallback mode.

It should be noted that because of the proprietary EC having exclusive control over the fans, no other third party fan control software works. SpeedFan, HWinfo, and even MSIs own Afterburner cant control the fans at all.

So, from my understanding of my research, the EC assumes total control over the fans. When software takes over the fans, and only MSI's software can do so, the EC forces the system to behave as if there are no fans, or that the fans are not strong enough. You can do this yourself by going into Windows power settings, and choosing advanced power options, and setting the Cooling Policy to Active or Passive. Setting it to Passive does the same thing the EC does when DC or SO assumes control of the fans, i.e. any fan mode besides Auto is used.

MSI seems to not have addressed this issue as of today, as several BIOS and EC firmware updates have been released, even recently, and this is still an issue. Its not likely this was done on purpose for cooling's sake, as even though the GF63 Thin and similar models only have one cooling fan, the CPU turbos high and normal as long as the fans are set to Auto, regardless of whether DC/SO is installed or not.

Whats bad though, specifically, is leaving the fans on Auto means you dont get the maximum cooling performance, as the fans wont go to 150% like they can on Advanced mode or CoolerBoost mode. So, its a trade off between high performance and and slower fans, or lower performance with faster fans. Makes no sense to me, MSI.

There is a trick to getting a huge boost in performance and bypassing this weird bug, but it involves using some BIOS settings tweaks and modifications which may harm your computer and most likely are not supported by MSI. Because of that, I will not post them here, but it is most certainly an option if you want to keep your laptop but also want the performance youd expect from it.
 
Joined
Aug 5, 2020
Messages
1
Hey @aronfaine thanks for the solution but it does not work on my GF63 9RC.
Been searching for every single post related to power limit throttling of 25w and found yours.I have tried each and every single option by deleting the dragon center,changing power options,but it seems to stuck at 25 w .
There is only one fix i have found to be working.It is by disabling my gtx 1050 and after doing that the 25 w tdp lock is removed and the cpu always stays at 4.0ghz no matter what you throw at it.
Can u help me by providing the trick for huge boost as you stated in your post.
Any help would be appriciated.Thx in advance
 

next3r

Active member
MAJOR
Joined
Jun 22, 2018
Messages
1,933
solved ,,my testing some models unlock "NO limit"

no need any mod
[IMG]
,,msi config25w is maximum for some notebooks "cooling design "
example GF63 9RCX-- one fan

THIN
nb - no space for better config ,,still need any limit iccmax or core ratio
only for specific usage need unlock "all cores load
-lower cpu freq// or after mod cooling" --only

,,for all
---max temps is 90C for normal performance // 94C is first thermal limit
get 90C on 25w ?? ,,,no need unlock really
 
Last edited:

Crazydonkey

Active member
SECOND LIEUTENANT
Joined
Jun 30, 2020
Messages
610
Hey @aronfaine thanks for the solution but it does not work on my GF63 9RC.
Been searching for every single post related to power limit throttling of 25w and found yours.I have tried each and every single option by deleting the dragon center,changing power options,but it seems to stuck at 25 w .
There is only one fix i have found to be working.It is by disabling my gtx 1050 and after doing that the 25 w tdp lock is removed and the cpu always stays at 4.0ghz no matter what you throw at it.
Can u help me by providing the trick for huge boost as you stated in your post.
Any help would be appriciated.Thx in advance
Maybe there is a power limit setting when DGPU on.:shocked:
Have you ever asked MSI about this problem?
 

next3r

Active member
MAJOR
Joined
Jun 22, 2018
Messages
1,933
Maybe there is a power limit setting when DGPU on.:shocked:
Have you ever asked MSI about this problem?
,.,,limit is for bad VR cooling design ?? or cooling --setup in bios/EC "extract your bad bios and check lock"

edit ,,uunlock no problem ,,easy and save way
but really no need this --get extreme overheat or boot loop --tested lot models
all need unlock -no need ,,,test up ,.,full load --check power/vs temperatures "ideal MSI kombustor /cpu burner gpu/cpu load"

example -25w for me -40-50C max full load all cores
75w -maximum 90C+++

+ hwinfo ,,,possible testing only GPU or add CPU load /// add OSD --best tool for TUNE
 
Last edited:
Top