Forum UEFI Shell Flash tool [V1.16] for MSI boards! ✔

teletubby_po

To infinity and beyond.
FIRST LIEUTENANT
Joined
Apr 6, 2020
Messages
1,537
Do you know if it would work on a MSI A320M-A PRO MAX? (MS-7C52)
Important:
Do NOT use it on a MSI AMD boards from 3xx boards Series. [like X370/B350]

(its OK to use for X399 AMD models as 3xx exception)
not recommended by the moderator. it's safer to update with M-flash

Also I just visited the Global Page of MSI (https://www.msi.com/Motherboard/A320M-A-PRO-MAX/support) and saw that there is a newer version available than on the german one (https://de.msi.com/Motherboard/A320M-A-PRO-MAX/support).
I went ahead and checked a few other pages (ua.msi/ru.msi/tw.msi) and realised that the german is the only one that doesn't have the newest version available on the BIOS page. Is there proper reasoning behind it or is germany just slower than the rest of the world?
try ctrl+F5 to refresh the page or browse in incognito mode.
 

bobopr0

New member
Joined
May 12, 2022
Messages
2
not recommended by the moderator. it's safer to update with M-flash
Yeah, updating works just fine, it just won't let me downgrade, which I am trying to do. Sorry for not mentioning my purpose in the first place.
So I need to use tool95, which you linked on page 5, correct?
try ctrl+F5 to refresh the page or browse in incognito mode.
I even tried different browsers, still doesn't show up. But I should be safe using the versions of the Global Page right? It wouldn't make much sense to restrict countrys or does it? :D
 

teletubby_po

To infinity and beyond.
FIRST LIEUTENANT
Joined
Apr 6, 2020
Messages
1,537
Yeah, updating works just fine, it just won't let me downgrade, which I am trying to do. Sorry for not mentioning my purpose in the first place.
So I need to use tool95, which you linked on page 5, correct?

I even tried different browsers, still doesn't show up. But I should be safe using the versions of the Global Page right? It wouldn't make much sense to restrict countrys or does it? :D
from my understanding, you might brick 300 motherboards if you flash BIOS with this tool. and the tool in page 5 is for older motherboards, not for 300 series. why do you want to downgrade BIOS?
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
79,100
For A3xx series should be fine to use it, its also MAX version with 32MB
 

Ostraq

New member
Joined
Jun 16, 2013
Messages
1
Hi Y'all, just wanted to add that the tool works with MSI X370 Gaming Pro Carbon. It was my last resort, I had to try downgrade. Luckily everything worked out just fine.

(After flashing the BIOS to the latest beta version, my system began acting crazy. Freezing on boot, falling into boot-loop etc. I attempted BIOS downgrade with M-flash which failed due to "old BIOS flash restrictions". Last option was this UEFI flash tool - the rest of story you read at the beginning :D ).
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
79,100
Hi Y'all, just wanted to add that the tool works with MSI X370 Gaming Pro Carbon. It was my last resort, I had to try downgrade. Luckily everything worked out just fine.

(After flashing the BIOS to the latest beta version, my system began acting crazy. Freezing on boot, falling into boot-loop etc. I attempted BIOS downgrade with M-flash which failed due to "old BIOS flash restrictions". Last option was this UEFI flash tool - the rest of story you read at the beginning :D ).
Super :emot-tip-wink:

@Svet hi i am running into the "too many BIOS file on the drive " issue as well. its an X270 SLI. ive tried with 2 bios versions 1A and 19, on 3 different flash drives 2 no names and one sandisk. i tried copying the files from the extracted folder on my computer and extracting them directly to the drive. it is a bios version that appears to be from a mining setup or something i dont really know or understand that, but it is not a normal bios. the current bios model name e7a59iz1 version v1.j1 any ideas? when i type dir in the shell it only shows the 1 file and the efi directory.

any ideas?
This also was sorted :pompom: and also the crossflash worked fine :pompom:
 

truebluewit12e402b2

New member
Joined
May 19, 2022
Messages
4
Super :emot-tip-wink:



This also was sorted :pompom: and also the crossflash worked fine :pompom:
I tried this for a B350 Tomahawk and got the too many BIOS file on drive error as well.

unfortunately MFLASH no longer works(enters MFLASH and screen is blank) after I'd updated to 7A34v1OU version. Trying to update to the latest 7A34v1Q4
I've tried everything I could find to get MFLASH to work in 7A34v10U. I switched back to HDMI, disconnected all USB other than going back to wired USB keyboard and a flash drive..
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
79,100
unfortunately MFLASH no longer works(enters MFLASH and screen is blank) after I'd updated to 7A34v1OU version. Trying to update to the latest 7A34v1Q4
I've tried everything I could find to get MFLASH to work in 7A34v10U. I switched back to HDMI, disconnected all USB other than going back to wired USB keyboard and a flash drive..
For B350 there is a possibility that can cause brick.

I tried this for a B350 Tomahawk and got the too many BIOS file on drive error as well.
If you want to try it anyway, for this issue, extract the BIOS file from archive file to some folder 1st.
Then copy the file from the extracted folder to the USB key, then retry.
 

truebluewit12e402b2

New member
Joined
May 19, 2022
Messages
4
For B350 there is a possibility that can cause brick.



If you want to try it anyway, for this issue, extract the BIOS file from archive file to some folder 1st.
Then copy the file from the extracted folder to the USB key, then retry.
1652980162132.png

Is this the correct setup? I copied from a folder on my C: drive where I'd unziped the BIOS file.
 

laurence1211

Well-known member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
1,924
I tried this for a B350 Tomahawk and got the too many BIOS file on drive error as well.

unfortunately MFLASH no longer works(enters MFLASH and screen is blank) after I'd updated to 7A34v1OU version. Trying to update to the latest 7A34v1Q4
I've tried everything I could find to get MFLASH to work in 7A34v10U. I switched back to HDMI, disconnected all USB other than going back to wired USB keyboard and a flash drive..
Doesnt the live update 6 program not work for you either?
 

laurence1211

Well-known member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
1,924
My Live update hasn't had BIOS available in a while.. maybe since went to windows 10? Is there an earlier version of Live Update that works for BIOS update on Win 10?

View attachment 159908
There is another section, click on the right triangle button above the setting. Keep pressing till you get the bios update section. Any bioses will be there, BUT check it is showing you the right one before going ahead. I wouldnt normally suggest this, but its less risky than the other option. Still has some risk to it because live update doesn't always flash correctly. I think this is because of a server data mismatch sometimes. Live update doesnt seem to check the version before flashing, so make sure its right.
 
Last edited:

truebluewit12e402b2

New member
Joined
May 19, 2022
Messages
4
There is another section, click on the right triangle button above the setting. Keep pressing till you get the bios update section. Any bioses will be there, BUT check it is showing you the right one before going ahead. I wouldnt normally suggest this, but its less risky than the other option. Still has some risk to it because live update doesn't always flash correctly. I think this is because of a server data mismatch sometimes. Live update doesnt seem to check the version before flashing, so make sure its right.
Thanks for the Tip! Unfortunately it isn't showing the new 1Q4 BIOS in there yet.. I'll keep checking.

1652999750697.png
 

smmarabban154302d7

New member
Joined
Jun 13, 2022
Messages
1
Hi there,

I've just noticed that I've made a big BIG oopsie.
Ages ago, I used this tool to flash my BIOS as I couldn't get the update to work through M-Flash.
Turns out I've flashed the BIOS file for a completely different board, the B450M Mortar instead of the B450M Mortar Max, basically what @zombyp15cb02ea did.

I've tried to flash back to the correct bios, but I get error 0x39: "Multi Tank ROMs' ROM ID do not match platform ROM ID".

Is there anyway to resolve this by forcing an update or am I stuck with the other board's BIOS forever?

Here's the links to the BIOS':
BIOS I flashed: https://download.msi.com/bos_exe/mb/7B89v1E.zip
BIOS I should have flashed: https://download.msi.com/bos_exe/mb/7B89v28.zip

I'm lucky to not have a bricked board, I know, but any help would be appreciated.


EDIT: I have resolved this using a tool normally for modded BIOS', which skipped the platform check and allowed me to restore the correct bios onto my board. Many thanks for your great work however!
I have done the same mistake. Have had to be x470 Gaming Plus Max, But flashed with x470 Gaming Plus.

Would you like to share your method of restoring to the original BIOS version?
 
Top