Forum UEFI Shell Flash tool [V1.19] for MSI boards! ✔

mauriciogn126902a3

New member
Joined
Oct 28, 2020
Messages
3
I have a Z270-A Pro (MS-7A71 Ver: 1.2) with what i believe is a weird mining focus bios mod, i bought the card second hand. It reports v1.J1 as bios version, i cant use Mflash since i doesnt recognize any of the bios file from MSI, i tried all the versions on the website, several usb sticks, several ports, it recognize the stick and the folder structure but none of the bios file shows up.

I believe It is a similar problem to this: Two MSI Z270 SLI PLUS have different graphic output quality (BIOS mod?) He had a Z270 SLI PLUS with the same weird bios v1.J1 and got rid of it.

And thats how i ended up here. Now, I tried your tool but it keeps saying that "theres too many BIOS file on the drive", odd since theres only 1 file at the time. I tried with both v12 and v16 bios file for my motherboard and with 2 different USB drives (32 GB USb 3.0 and 16 GB USB 2.0, FAT32 with a fresh format in every attempt) in different usb ports, always with the same message.

EDIT: I tried again and it worked. The only thing i did different was to extract the BIOS file on my pc and then copy the file to the usb drive instead of doing drag and drop to the bios file from the winrar window to usb drive, wird but whatever it worked. Now i have the latest retail BIOS on the Z270-A Pro. THANKS!
 

Attachments

Last edited:

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
79,285
EDIT: I tried again and it worked. The only thing i did different was to extract the BIOS file on my pc and then copy the file to the usb drive instead of doing drag and drop to the file from the winrar file. Now i have the latest retail BIOS on the Z270-A Pro. THANKS!
Super :pompom:
 

lordxale

New member
PRIVATE E-2
Joined
Mar 29, 2020
Messages
8
I'm just some guy, but in case anyone is keeping score: I have a B350M Mortar Arctic on which I had briefly installed the beta 7A37vAKS bios (GSE Lite) before in-place rolling back to 7A37vAI (still color graphical Click BIOS version). I used this tool - as of writing v1.14 in case the thread title changes over when it's updated - to force downgrade 7A37vAI back to 7A37vAA and everything is peachy again (well, except the 1st-gen Ryzen issue I was trying to fix in the first place, but I think I'm dead in the water there even on the latest available BIOS, and I'd rather have an otherwise working VFIO setup on 7A37vAA ).
 

lordxale

New member
PRIVATE E-2
Joined
Mar 29, 2020
Messages
8
I thought the tool doesn't work on b350?
I rolled the dice based on this reply. I would wager it's still worth being prepared for the possibility of bricking if you do use this tool on a 3xx board. In the B350M Mortar Arctic's case I could roll back to a non-GSE lite BIOS (7A37vAI), and then use the tool while running that version to get back behind the hard stop at 7A37vAC. I'm soon to be upgrading regardless so didn't have much to lose even if it bricked (except the 5000 series is currently mostly unobtainium anyways I guess, haha)
 

laurence1211

Well-known member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
1,960
I rolled the dice based on this reply. I would wager it's still worth being prepared for the possibility of bricking if you do use this tool on a 3xx board. In the B350M Mortar Arctic's case I could roll back to a non-GSE lite BIOS (7A37vAI), and then use the tool while running that version to get back behind the hard stop at 7A37vAC. I'm soon to be upgrading regardless so didn't have much to lose even if it bricked (except the 5000 series is currently mostly unobtainium anyways I guess, haha)
Interesting, thanks for the heads up.
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
79,285
Tool version is now updated to V1.15:

* Updated 2nd flasher.
* Update ME-FW for Z490 Series to 14.0.45.1389
 

j.redout158702df

New member
Joined
Dec 12, 2020
Messages
3
I tried the v 1.15 tool to update my H87M-G43 MB, but I got the following error:
using the wrong AFU version, please use Aptio 4 AFU
what should I do?
thank you!
 

j.redout158702df

New member
Joined
Dec 12, 2020
Messages
3
Thank you ! Finally I figured it out by flashing with the DOS utility provided with the ROM (made a USB boot able key with rufus)
I'm now with the latest release! Thank you!
 

zombyp15cb02ea

New member
Joined
Dec 24, 2020
Messages
9
Huge thanks for this tool @Svet .

I spent all of yesterday trying to get the B450 Gaming Plus' firmware upgraded, faffing with m-flash and all I achieved was cleaning all of the dust out of my case.

5 mins with your Flash tool this morning and it's all sorted.

You are a life saver :D

On a side note, do you know if this Flash Tool will work with the MSI A320M-A PRO MAX ?
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
79,285
Huge thanks for this tool @Svet .

I spent all of yesterday trying to get the B450 Gaming Plus' firmware upgraded, faffing with m-flash and all I achieved was cleaning all of the dust out of my case.

5 mins with your Flash tool this morning and it's all sorted.

You are a life saver :D
Super, well done as well :pompom:

On a side note, do you know if this Flash Tool will work with the MSI A320M-A PRO MAX ?
It's untested, but should works.
 

chip_spark

New member
PRIVATE E-2
Joined
Jul 18, 2020
Messages
6
Hi, I'm having issues with the latest B550 mpg gaming itx motherboard, I am currently stuck and unable to go back to an older BIOS no matter what I do. Can I use this for this motherboard?

Edit. I've just used this tool to go back to an older bios and it worked! Originally had problems because I had two bios files on the root folder so had to redo again with just one bios file. Omg it works! I'm back to an older bios and finally have a stable system. Thank you!
 
Last edited:

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
79,285
Yes, you can. Just ensure to pick the correct BIOS for your board.

Well done :pompom:
 
Last edited:

1970ilda159202e3

New member
Joined
Dec 29, 2020
Messages
2
Hi guys...
I have several problems to upgrade bios of my x79a gd45 (8d) rev. 2.0 (lga 2011), 32 Gb, Win 10 64. I need to upgrade for Ivy CPU and having bios 10.x (A), the transition to bios C is really a torment!! I have read some users with the same problem in the forum and the related answers, I followed the advice given to them, but evidently something has changed in the meantime. I downloaded the raccomended version 12.8 (E7760IMS.C80) in a answer by flobelix and I started the procedure in the case identical to mine, but the forum usb flasher (a file .exe) not install and the DOS window closes saying that the files are missing in addition to other errors. I also tried with the new UEFI tool and i just get the shell without entering the UEFI (first boot: UEFI usb key, legacy enabled, but i have not found anything voice or command for "secure boot" in the Bios).

I'm in front of a wall!! Advice? Thanks in advance ;)
 

laurence1211

Well-known member
PRIVATE E-2
Joined
Jun 28, 2020
Messages
1,960
Hi guys...
I have several problems to upgrade bios of my x79a gd45 (8d) rev. 2.0 (lga 2011), 32 Gb, Win 10 64. I need to upgrade for Ivy CPU and having bios 10.x (A), the transition to bios C is really a torment!! I have read some users with the same problem in the forum and the related answers, I followed the advice given to them, but evidently something has changed in the meantime. I downloaded the raccomended version 12.8 (E7760IMS.C80) in a answer by flobelix and I started the procedure in the case identical to mine, but the forum usb flasher (a file .exe) not install and the DOS window closes saying that the files are missing in addition to other errors. I also tried with the new UEFI tool and i just get the shell without entering the UEFI (first boot: UEFI usb key, legacy enabled, but i have not found anything voice or command for "secure boot" in the Bios).

I'm in front of a wall!! Advice? Thanks in advance ;)
Use Windows 7 to run the exe. You only need it for the update. You can plug in your win10 drive afterwards.
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
79,285
Hi guys...
I have several problems to upgrade bios of my x79a gd45 (8d) rev. 2.0 (lga 2011), 32 Gb, Win 10 64. I need to upgrade for Ivy CPU and having bios 10.x (A), the transition to bios C is really a torment!! I have read some users with the same problem in the forum and the related answers, I followed the advice given to them, but evidently something has changed in the meantime. I downloaded the raccomended version 12.8 (E7760IMS.C80) in a answer by flobelix and I started the procedure in the case identical to mine, but the forum usb flasher (a file .exe) not install and the DOS window closes saying that the files are missing in addition to other errors. I also tried with the new UEFI tool and i just get the shell without entering the UEFI (first boot: UEFI usb key, legacy enabled, but i have not found anything voice or command for "secure boot" in the Bios).

I'm in front of a wall!! Advice? Thanks in advance ;)
This tool[uefi flash tool] is not for this class board.
Best open own topic in correct section for troubleshooting.
 

1970ilda159202e3

New member
Joined
Dec 29, 2020
Messages
2
@Laurence Thanks!! Tomorrow I will follow your advice with my notebook. :-)

@Svet Sorry...I didn't realize which procedure was right, between the two, for my motherboard.
If I have problems with the old tool in Win7, I will post in the other section with a screenshot.
 
Top