G31TM-P21 not recognizing 4GB memory module

Joined
Oct 17, 2020
Messages
2
My G31TM -p21 Motherboard has 1MB RAM installed in DIMM 1 slot. I recently tried to upgrade to the maximum 8GB by inserting 2 x 4GB modules but the Modules cannot be detected.
The modules are PC2-6400u. Is there any setting that needs to be changed in the BIOS for the modules to be detected? Both DIMM slots are failing to detect the 4GB RAM modules.
Please help.
 

jakub-p2

New member
PRIVATE FIRST CLASS
Joined
Feb 29, 2020
Messages
29
Firstly you can try resetting your CMOS - unplug your PC and remove the battery for a few seconds. Some time ago I've encountered some cheap, unbranded RAM that is specified for AMD/Intel only on Aliexpress. Is the RAM branded as Kingston/Crucial/etc...?
 
Joined
Oct 17, 2020
Messages
2
Firstly you can try resetting your CMOS - unplug your PC and remove the battery for a few seconds. Some time ago I've encountered some cheap, unbranded RAM that is specified for AMD/Intel only on Aliexpress. Is the RAM branded as Kingston/Crucial/etc...?
The RAM is not branded using a tradename but just a logo. However, I have now realised that if I change the DRAM frequency in the BIOS settings to 667Mhz from 800Mhz the BIOS is able to detect the 4GB RAM module but remains unusable as windows does not see it but sees the 1 GB RAM module only. If I remove the 1 GB RAM module the system will not boot up. The Processor is E-3300 @ 2.5GHz and OS is Windows 10 32-bit.
 

jakub-p2

New member
PRIVATE FIRST CLASS
Joined
Feb 29, 2020
Messages
29
That is just Windows reaction to RAM changes. In order to use that RAM you have to get 64-bit OS.
 
Top