Games not running properly

nivaan3151602d0

New member
Joined
Jan 3, 2022
Messages
2
Hi all,
this is my first post in the community, please bare with me if I make any mistakes. I recently bought a MSI GP66 Leopard, with i7, 32GB ram, 1TB SSD, and RTX3070. I downloaded GTA V, however, it is not running as expected. Although, I am getting 180fps, the game is lagging a lot, like a lot a lot. I have the extreme performance mode activated. I feel like the laptop is not even trying to run it cause it is not making much noise either. This is my first MSI laptop so Im not really familiar with the dragon center, but i dont think Im doing anything wrong. What do you guys think is happening? Any comments are very much appreciated.
 

darkhawk

Well-known member
Global Moderator
Joined
Nov 20, 2012
Messages
14,093
Really need more info. Gotta use something like HWINFO64 or MSI Afterburner with the logging enabled to really look into it more.
180FPS really should be more than enough to feel smooth.
 

nivaan3151602d0

New member
Joined
Jan 3, 2022
Messages
2
Sorry my bad, im attaching a video file so you can see what i am talking about. Again, I am in extreme performance mode. Although I am getting 180fps, the performance is not as expected for the amount I paid for this laptop. GTA V PERFORMANCE As you can see from the video, it is lagging a lot and the graphics are not even high, they are normal. It should be running it without any problems.
 

denverboy2153602d5

New member
Joined
Jun 6, 2022
Messages
7
The game may be 2013, but just because your 3070 doesn’t have a 180 FPS on it doesn’t mean there’s something wrong with the laptop. I have 3 laptops, one is Legion 5 with 3060 to 130 watts and I7, the second is HP Pavillion with gtx 1660ti and r5 5600h and GP66 with RTX 3080 and I7 and not one of them produces GTA5 180 FPS. If you see in the video that RTX 3070 can give out as many frames, then notice what settings are used there for the video card.
 
Top