GE66: Intel Graphic Driver, Intel Rapid Storage Technology Drivers wont install.

eternalwolf

New member
PRIVATE E-2
Joined
Jun 23, 2020
Messages
1
I saw in Dragon Center that three drivers weren't installed, Intel Graphics Driver, Intel Rapid Storage Technology Driver and Intel Rapid Storage Technology F6 Driver. I tried to install them but basically nothing happened, they just created a folder in DownloadsLive UpdateIntel Graphic Driver with the zip file and the files inside the zip extracted. For the Intel Graphics Driver when I run igxpin.exe it gives me an error saying the OS is not supported. For Rapid Storage Technology when I run the .exe it says platform is not supported. The files on msi.com are the exact same files Dragon Center downloads and obviously made no difference.

In Device Manager Intel UHD Graphics is only viewable if I select Show Hidden Devices. I don't want to try to install the drivers this way because I don't want something to go wrong. There is a shortcut to Intel Graphics Control Panel but I cant find any folder related to it on the hard drive. I'm not sure but I believe this shortcut was on the PC before I tried installing the driver. Also, I have the 2070 Super model but for some reason 2080 Super Max-Q shows up in device manage if I select show hidden devices.

What is going on? Should I try to update these drivers in device manager? This is my first laptop so I dont know if it's being blocked by the system for some reason or what.

UPDATE 1: Added Picture
UPDATE 2: After checking each device in Device Manager to try to manually update each driver, all the drivers are already installed even though none of the hardware is usable. I would really like confirmation on two things...

1.) Am I locked out of using Intel UHD Graphics and Rapid Storage Technology, most likely via the BIOS? If so, why?

2.) Is the 2080 Super Max-Q that was "previously installed" and 2070 Super that is currently installed the exact same chip, except with different drivers and clocks/whatever? I find it really hard to believe that somebody installed a 2080 Super Max-Q on this machine and then realized it was supposed to be a 2070 Super... Like, why even bother taking the 2080 out after it's already installed? If it is the same chip, does this mean that theoretically I can disable the 2070 Super and enable the 2080 Super Max-Q(not that I would even want to since the 2070 Super gets better marks).

I don't really want to go screwing around in the BIOS just to check. I got this laptop so these types of things didn't arise and I could have peace of mind. Model is GE66 10SFS-048. I think it's a Best Buy exclusive, if anyone else has the same model and can simply check if these "issues" are the same on their laptop it would be greatly appreciated.
 

Attachments

rinzler0145b8065e

New member
Joined
Aug 6, 2020
Messages
2
I checked and I have the exact issue... not sure.. If I had to guess its that perhaps when these laptops were made either they were originally planned to have the 2080 max q super and then they changed their mind. Whats your build date? Mine is 05/20. Another possibility since I too have the best buy 2070 super model it could be that our laptops were downgraded for the bestbuy specific model. I would guess you could remove it.
 
You must log in or register to reply.
Top