GH50 Immerse Headset - Buzzing In Left Ear.

markhufc

New member
PRIVATE E-2
Joined
Jun 23, 2020
Messages
1
Just bought a GH50 Immerse Headset, there is a constantly cycling buzzing in the left ear.  The buzzing is on for about 8-9 seconds, then off for about 4 seconds.  It spoils the use of these altogether.
I've tried different USB ports, even tried other PC's, it even does the buzzing when my PC is shut down but the headset is still powered by the USB port.  It buzzes at the same volume never mind if the volume is set to low or high.

I've installed the latest Dragon software and the latest firmware 108.

Any ideas? Or do I just have a duff headset?  

Thanks for any help.
 

teletubby_po

Member
FIRST LIEUTENANT
Joined
Apr 6, 2020
Messages
398
Try remove/ reinstall/ update device sound driver
Disable audio device enhancement setting- sound- headset- properties- enhancement- disable all enhancements
Does the buzzing sound only happen on front or rear oanel?
 

bartektrzep157e02db

New member
Joined
Aug 13, 2020
Messages
1
Hey,
I managed to find the issue, its the LED that causing the problem. Download software and change LED style to static or disable it. It will solve the problem.
Regards.
 
Joined
Aug 14, 2020
Messages
3
I've been having the same issue. Bertek you need to be more specific. What software do I install? The only software ANYWHERE that could change the RGB on the headset is the Dragon Center which doesn't have support for the headset in particular.
 

fatedust

Member
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
573
I've been having the same issue. Bertek you need to be more specific. What software do I install? The only software ANYWHERE that could change the RGB on the headset is the Dragon Center which doesn't have support for the headset in particular.
Do you mean Dragon Center can't detect your headset?
But to be honest, this buzzing problem sounds like a hardware issue not software...
Have you tried to plug your headset to another USB port?
 
Last edited:
Top