GS758SG - SSD dead. How can I install Windows etc on a new SSD.

Joined
Jan 16, 2021
Messages
12
Hi all,

I have brought a GS75 8SG Stealth with no SSD installed. I have ordered a new one but I want the Windows key so I can make a bootable USB etc etc. Having problems as the Laptop is a US version and I am in the UK. Can anyone help me undertstand how I can get the key and make the USB drive bootbale?

Thanks.

Gavin.
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
1x M.2 SSD slot (SATA)
2x M.2 SSD Combo slot (NVMe PCIe Gen3 / SATA)
is inside

1x positible m+b key -ssd "nvme sata"
2x - COMBO m+b sata or native m-key - NVME PCIe

m-key nvme PCIe--better "full speed"
m+b --crippled nvme


edit
SAMSUNG NVME -need special drivers NVME in windows + sata controller - AHCI
your defaults in bios sata controller - RST "for raid" not must be compatible to all SSD
 
Last edited:
Joined
Jan 16, 2021
Messages
12
1x M.2 SSD slot (SATA)
2x M.2 SSD Combo slot (NVMe PCIe Gen3 / SATA)
is inside

1x positible m+b key -ssd "nvme sata"
2x - COMBO m+b sata or native m-key - NVME PCIe

m-key nvme PCIe--better "full speed"
m+b --crippled nvme

Thanks next3r, I am trying to understand the first post regarding the OEM - is there no way for me to just recover the original Windows install that the laptop was built with..

I have ordered a Sabrent NVMe PCIe M.2 2280 1tb SSD. I am hoping this is the right drive for the job!
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
Thanks next3r, I am trying to understand the first post regarding the OEM - is there no way for me to just recover the original Windows install that the laptop was built with..

I have ordered a Sabrent NVMe PCIe M.2 2280 1tb SSD. I am hoping this is the right drive for the job!
need recovery ? but it would have to exist on the original disk
f3 in boot for recovery " but this doesn't work when the oem disk has lost the recovery partition"
 
Joined
Jan 16, 2021
Messages
12
oem drivers

alternative -last

,..,no need recovery ,,only small skill for re-install :-)
Thanks mate, I have the bootable disk set up on an old SATA via a USB cable. I am comfortable with the rest as I have installed all the MSI stuff from scratch before, but wanted to say thanks again for pointing me in the right direction. My SSD arrives tomorrow so I should be unleashing my 2080 RTX by the evening :) (curently using a 980..)

Cheers again.

Gavin.
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
SATA via a USB cable ?? this works for you ??
i tested this on my gt75 --impossible get normal access :biggrin:
 
Joined
Jan 16, 2021
Messages
12
Ha yes there is a lot of options for SATA to USB cables, self powered. That disk is about 12 years old and I just tested it, all good.. Just to install windows onto the SSD.
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
Ha yes there is a lot of options for SATA to USB cables, self powered. That disk is about 12 years old and I just tested it, all good.. Just to install windows onto the SSD.
i have similar hdd dock ,.,.but on MSI not works or very slow "only on my old ASUS works normal"
but is old disk / cheap hdd dock :biggrin:

edit
for your new PCIe NVME --need find COMBO slot on motherboard ,..,one is only SATA compatible
1x positible m+b key -ssd "nvme sata"
2x - COMBO m+b sata or native m-key - NVME PCIe
 
Joined
Jan 16, 2021
Messages
12
Nightmare... I installed the new ssd and memory upgrade ( very fiddley). The mouse pad and led charging light aren't working now. Reset bios etc and tried connecting the cable internally a few times, any ideas?
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
Nightmare... I installed the new ssd and memory upgrade ( very fiddley). The mouse pad and led charging light aren't working now. Reset bios etc and tried connecting the cable internally a few times, any ideas?
you see the bios ??

edit .,,.,.info what is upgrade
+ what is inside "some mem OEM is SINGLE RANK + new DUAL not must works"
all is inside connected correctly ??? NEW PCIe ssd --on COMBO SLOT ???

edit ,,translation fix
 
Last edited:

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
when is possible run NB "power button light works" + fans run
30s power button -full bios reset "full CMOS"

edit
ec reset "but think RESET info up --full + EC"
 
Joined
Jan 16, 2021
Messages
12
Yes it boots up into windows and an external mouse works fine. New ssd in primary and new memory module in the second slot. I reset BIOS to optimised settings.

Maybe I need to update or flash BIOS? The internal cable is so small and fiddley, the connector is a tiny piece of plastic that just falls off!
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
when NB works .,,.check only TOUch drivers // HWINFO + PPinput - AC voltage "works or not"
or team

more info .,.,.what works
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
Yes it boots up into windows and an external mouse works fine. New ssd in primary and new memory module in the second slot. I reset BIOS to optimised settings.

Maybe I need to update or flash BIOS? The internal cable is so small and fiddley, the connector is a tiny piece of plastic that just falls off!
and this NEW system installation ? maybe something is missing
I thought you had a bootloop :biggrin:
 
Joined
Jan 16, 2021
Messages
12
No bootloop just the mouse pad doesn't work ☹. I did install the SSD into the secondary slot and install windows there... Mouse pad worked fine. Then I realised it was in the secondary slot so I swapped out when I put the memory module in, to primary. I have since tried to reconnect the internal cable 5 times, it looks connected but still the mouse doesn't work. So annoyed with it.. 🤦
 

next3r

Well-known member
MAJOR
Joined
Jun 22, 2018
Messages
4,482
No bootloop just the mouse pad doesn't work ☹. I did install the SSD into the secondary slot and install windows there... Mouse pad worked fine. Then I realised it was in the secondary slot so I swapped out when I put the memory module in, to primary. I have since tried to reconnect the internal cable 5 times, it looks connected but still the mouse doesn't work. So annoyed with it.. 🤦
You think touch pad ? this need IO drivers

edit ,,translation fix ,..,i need coffee :sneaky:
 
Last edited:
Top