GS77 Won't Charge at All Using PD

darkhawk

Well-known member
Global Moderator
Joined
Nov 20, 2012
Messages
14,204
Which port are you plugging it into?
Keep in mind that I believe there is only 1 port that supports Thunderbolt with PD.
 

beaniima15ea02eb

New member
Joined
Aug 2, 2022
Messages
7
Which port are you plugging it into?
Keep in mind that I believe there is only 1 port that supports Thunderbolt with PD.
I am plugging into the Thunderbolt port. Interesting thing I just found. If I plug in the regular power adapter AND my USB4 cable, the PD port says its pulling up to 100W? I dont need it to charge with that port if I have the regular adapter though lol.

I am using a USB4 cable that displays power draw.
 

cpsoho

Member
FIRST LIEUTENANT
Joined
Jul 5, 2016
Messages
580
BTW the PD charging should be designed for some emergency situations and it can't deliver the full performance when you only charge with PD. :angel:

I am plugging into the Thunderbolt port. Interesting thing I just found. If I plug in the regular power adapter AND my USB4 cable, the PD port says its pulling up to 100W? I dont need it to charge with that port if I have the regular adapter though lol.

I am using a USB4 cable that displays power draw.
 

beaniima15ea02eb

New member
Joined
Aug 2, 2022
Messages
7
BTW the PD charging should be designed for some emergency situations and it can't deliver the full performance when you only charge with PD. :angel:
Yes, I am aware of that, I just wanted to use it on the plane to get a little longer battery life or charge while it's turned off. Unfortunately, I cannot seem to get that to work at all. It says it has PD charging so it should charge over PD.
 

Kujou

Member
Joined
Jun 9, 2020
Messages
78
I assume that you plugged in the pd charger into the port that has lightning icon:
1659721846725.png

when you plugged in the pd charger, is the battery icon charging?
1659721982710.png

if yes and the pd charger cannot deliver the power, try to update BIOS version E17P1IMS.109
1659722202048.png
 

beaniima15ea02eb

New member
Joined
Aug 2, 2022
Messages
7
Updated the bios no problem, same problem. I have the same issue. Using a PD 100W charger. I have tried other USB 4.0 cables as well.

1659726661927.png
 

rlawlgud200155802d1

New member
Joined
Aug 5, 2022
Messages
3
My laptop is a GS77 12UGS. The BIOS is E17P1IMS.109, and it was updated on August 4th, but it shows the same symptoms.
OS : Win 10
PD Charger : Baseus 17 in 1 Docking Station (100W)

1659750852736.png


1659750781096.png
 
Last edited:

rlawlgud200155802d1

New member
Joined
Aug 5, 2022
Messages
3
Sending a ticket to MSI only advises to update the BIOS.
Or, it tells me to reinstall the latest Thunderbolt driver, but I've already reinstalled it more than 10 times.
MSI doesn't seem to be fully aware of the problem.

* The power output from the docking station was confirmed with other products.
 
Last edited:

beaniima15ea02eb

New member
Joined
Aug 2, 2022
Messages
7
Everything other than getting some charge works great for me. The GS77 is the perfect beast for what I need. I just wish I could get this working so I can use a PD charger overnight and have a full battery in the morning.
 
Top