H170A PC MATE cant enter CMOS setup and machine only boots with USB.

patni13021153102d3

New member
Joined
Jul 6, 2022
Messages
3
Dear Members,
After flashing latest version B.E0 BIOS on my MSI H170A PC MATE motherboard on a restart the IGD graphic display remains blank and red led of VGA lights up on EZ Debug LED. The machine boots only EFI USB drive and i am typing this from linux live usb. The dmidecode shows:
# dmidecode 3.3
Getting SMBIOS data from sysfs.
SMBIOS 3.0 present.
85 structures occupying 4026 bytes.
Table at 0x8B2CA000.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
Vendor: American Megatrends Inc.
Version: B.E0
Release Date: 06/27/2018
Address: 0xF0000
Runtime Size: 64 kB
ROM Size: 8 MB

Any idea how to recover BIOS so i can have full access to usual CMOS setup?

Hardware details:
1) CPU : Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz
2) I have tried with both internal graphic & external pcie one
a) Intel Corporation HD Graphics 530 (rev 06)
b) MSI R7750 pcie card but same behavior.
3) 2x8gb F4-3000C15-8GVS DDR4 RAM operating at 2133 MT/s

Please help on how to restore/reflash BIOS to get it back to normal. Thanks.
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
8,791
Did you try a Clear CMOS (bridging two pins with a screwdriver or metal object)?
 

patni13021153102d3

New member
Joined
Jul 6, 2022
Messages
3
Thanks for your reply. I have tried CMOS clear multiple times, including removing CMOS battery and leaving machine powered off overnight. It is only booting through USB drive. I think i need to use the usb flashing tool of the forum. Will latest version 1.18 work for H170A PC MATE ver 2.0 motherboard?
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
8,791
You need to check the thread, some people with a 100-series board probably used the tool before.
 
Top