HDD lost after sleep mode

anilbahs156c02d4

New member
Joined
Jun 21, 2022
Messages
5
I have MSI MAG B660M Mortar. My HDD and SSD not recognized after sleep mode. If I reboot it shows my devices. How can I solve this issue?
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
7,934
Try updating to the latest BIOS version. The early BIOS for the 600-series boards had a lot of sleep-related bugs.

Take your pick, i don't know your exact board model (DDR4/DDR5/WIFI or not):

Update how-to:
1) Get the latest BIOS. It's the topmost one on the MSI support page for your board.
2) Extract the file and you will get a text file and the BIOS file. Put the BIOS file into the root folder of a USB stick/drive.
3) Enter the BIOS by pressing DEL during boot, go to "M-FLASH" in the BIOS.
4) Once M-Flash (the updater) is loaded, it will show a list of your drives. Select the USB stick and select the previously extracted BIOS file on there.
5) It will ask for confirmation and then update the BIOS. It's fully automatic from there, takes about two minutes.
 
Last edited:

anilbahs156c02d4

New member
Joined
Jun 21, 2022
Messages
5
Hi, I updated latest BIOS. The problem still continues. Sometimes my computer wakes up normally but today I realized my HDD and SSD not recognized after sleep.
board model: MAG B660M MORTAR DDR4
 

fatedust

Survey Corps
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
2,065
Hi, I updated latest BIOS. The problem still continues. Sometimes my computer wakes up normally but today I realized my HDD and SSD not recognized after sleep.
board model: MAG B660M MORTAR DDR4
What HDD and SSD do you have and which ports are they connected to? Have you tried other ports?
 
Top