How to fix issues with Killer Lan

Status
Not open for further replies.

Peejayess

New member
PRIVATE E-2
Joined
Oct 24, 2014
Messages
1
I can't say the following will work for everyone, but it does for me:  Install Killer as normal so that Ethernet files etc., are installed, then go to Task Manager and under Start Up, stop Killer from starting.  All that happens is that the Killer software doesn't start but it doesn't affect the Ethernet Connection.  My download speeds are over 70Mbs with Uploads at around 10Mbs
 

redangel745

New member
PRIVATE FIRST CLASS
Joined
Dec 17, 2014
Messages
8
Peejayess said:
I can't say the following will work for everyone, but it does for me:  Install Killer as normal so that Ethernet files etc., are installed, then go to Task Manager and under Start Up, stop Killer from starting.  All that happens is that the Killer software doesn't start but it doesn't affect the Ethernet Connection.  My download speeds are over 70Mbs with Uploads at around 10Mbs
Are you sure this'll help? Seems like the easiest fix than, if it's confirmed working.

Also having slow internet speeds and serious doubts about this software, I've got a B85-G43 Gaming Mobo. Are there a lot of differences between NIC's of MSI mobo's?
 

rock1m1

New member
STAFF SERGEANT
Joined
Jun 4, 2014
Messages
59
This was a long time coming, thank you! Their bandwidth control is the major culprit for most of the issues which for some reasons blocks a ton of internet packets and hence makes browsing and communication full of errors. What is worse, you simply can't turn it off permanently, it turns itself back on everytime  you start your computer. I tried contacting Qualcomm so many times, they have yet to get back to me once. Really disappointed. I hope MSI changes their NIC and goes with much more reliable Intel NICs.

Also you might wanna post this on the Gaming Motherboard section as well.
 

prettyscetchydude

New member
PRIVATE E-2
Joined
Dec 29, 2014
Messages
3
Currently this hardware device is not connected to the computer(Code 45).
To Fix the problem reconnect this hardware device to the computer.
I'm really clse but I still can't connect to the internet please help
 

ptysper

New member
PRIVATE E-2
Joined
Jan 11, 2015
Messages
2
I was getting sporadic DRIVER_IRQL_NOT_LESS_OR_EQUAL BSoD and following fixed the issue:

First I checked blue screen dump file (C:\Windows\Minidump) with BlueScreenView and it pointed to Ethernet drivers so I found this website.

As link to Killer Cleaner is not available on Qualcomm website anymore I found mirror on some site that is not available anymore too... shout if you need them, I have x64 version on my drive. Can't post external links here...

So for Windows 7:
0.Download cleaner and drivers first!
1.Use Killer Cleaner
2.Uninstall Qualcomm Software Suite (Programs->Uninstall)
3.Reboot
4.Install clean drivers

Clean drivers mentioned in this topic works (https://forum-en.msi.com/index.php?threads/174229), however original version gave me some error, new January version works like a charm!

Hopefully MSI will fix this soon as Killer software suite is great but random bsod's are unacceptable!!

 

ptysper

New member
PRIVATE E-2
Joined
Jan 11, 2015
Messages
2
One more thing. It started giving me BSoD after updating avast antivirus from version 7 to 9, and installing several Windows 7 updates (around 90 last important updates). It may be somehow related.
 

tsumi45

New member
PRIVATE E-2
Joined
Jan 11, 2015
Messages
3
I got an MSI GP60-Proi545FD. GP60 Leopard Pro. And i got a Killer E2200. So i can use the driver from the second post or not? The post from the Jan 6. https://forum-en.msi.com/index.php?threads/174229 This wil work for me?

When i unzip it there is folder named KE2200. But i got a E2200. So i can use the driver or not? This is the latest driver or not?

Thank you!
 

luisandrerfgchaves

New member
PRIVATE E-2
Joined
Jan 13, 2015
Messages
1
Having Issues with some internet required programs. Have MSI Z97 Gaming 7, Windows 8.1 64bit.

Would it correct my problems if I uninstall the Qualcomm software and install the driver in the link from January 6th?

Also tried to use the links in the original post, but they're not available anymore...

@ptysper: would your killer cleaner work for Windows 8.1 64bit?
 

marsmillo

New member
PRIVATE E-2
Joined
Feb 23, 2015
Messages
1
Links to the KillerCleaner tool are dead because the qualcomm download page does not exist any more at the moment (February 2015).

Solution is to use the Internet Archive's version (indexed December 2014):
* not allowed to post external links *
--> https : // web.archive .org /web/20141220022603/ http : // www .qca.qualcomm .com /resources/driverdownloads/ <-- without spaces


Both versions of the cleaner tool are for download there
And also the base AR816X driver (Killer E2200 is a AR816X) you can find there.

Also know, if you want to use the latest Killer driver without the software, you can download the latest Killer Suite, open the zip file, don't click install but go to \drivers\Production\ choose you OS and manually install the driver as explained in the opening post by flobelix

Backup this downloads. I don't know if the internet archive will have them forever or not.









 

lukaivt

New member
PRIVATE FIRST CLASS
Joined
Feb 27, 2015
Messages
6
Does any one have a valid link for killer cleaner? I couldn't find it online.
 

flobelix

Well-known member
Global Moderator
Joined
Jan 25, 2007
Messages
39,544
64bit: https://www.dropbox.com/s/t9219ta8lt8jegh/KillerCleaner_64bit.rar?dl=0

32bit: https://www.dropbox.com/s/onoc9xnpn894it9/KillerCleaner_32bit.rar?dl=0
 

lukaivt

New member
PRIVATE FIRST CLASS
Joined
Feb 27, 2015
Messages
6
Hey flobelix, I followed all of your instructions, and it seemed a little bit better than before.
I used to have BSOD once per hour. Now it becomes once every 3 hours.

Do you have any ideas? I
 

Attachments

lukaivt

New member
PRIVATE FIRST CLASS
Joined
Feb 27, 2015
Messages
6
I downloaded from the link you provided above.

http://download.msi.com/dvr_exe/Killer_network_inf.zip

Win64
 

Shakhawathossinict

New member
PRIVATE E-2
Joined
Mar 13, 2015
Messages
3
, I using MSI H61M-P20 G3 mainboard about four years, with  Intel dual core prosser 3g 1155 pin and 2gb REM ddr3.

I have installed Window 7 32 bits, and when I turn it ON or restarting it, system doesn't starts it shows a black screen with a 99 code below at right side of the screen.
I want to know why show this.is it mother bord problem?
Pless help me.how can i solve this?
 

flobelix

Well-known member
Global Moderator
Joined
Jan 25, 2007
Messages
39,544
Your query has obviously NOTHING to do with this thread. Please don't try to hihack other threads but open your own!
 

bartb

New member
PRIVATE FIRST CLASS
Joined
Mar 15, 2015
Messages
6
I've tried everything, but can't seem to activate Gbit lan on my X99S Gaming 7. I know its not my connection, as my previous pc was able to get gbit. Any idea's that could fix it?
 
Status
Not open for further replies.
Top