How to fix issues with Killer Lan

Status
Not open for further replies.

bartb

New member
PRIVATE FIRST CLASS
Joined
Mar 15, 2015
Messages
6
flobelix said:
Also try with the older driver
That was one of the drivers I tried, still not getting gbit. I'm guessing i'm missing something really big...
 

danimoncada

New member
PRIVATE E-2
Joined
Mar 31, 2015
Messages
1
I installed recently a MSI Gaming 3 mobo with Killer networking ethernet. IMHO the easiest way to remove the annoying software of ethernet is to disable for running on boot, and disable the service too. With this way you don't have to use another software to remove, with related problems that can suffer remove in it. Although the software it still installed but not running.

(sorry for my english)
 

gordy.iphone

New member
SERGEANT
Joined
Mar 15, 2015
Messages
24
This could very well be the cause of a problem I've been having for the last sleepless night lol.

Have only ever installed the killer driver only from msi site but can't get my torrents running at anything other than pathetic speeds.  I've been messing around with firewalls, torrents and clients and also my team viewer was locking up all the networks on bootup for 2 or 3 minutes.  I've been trying all sorts of stuff and this thread would explain my problem.

I rremoved the driver and disabled lan in the bios but still have this problem. It's driving me so crazy I haven't even finished building the pc properly lol.

Any tips apart from trying the cleaner and different drivers?

I see a post somewhere this morning detailing the original chip model/driver that was non killer. I'll drag it out the history layer and post it up.
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
latest killer driver installation has build in cleaner
 

Mr. C

New member
PRIVATE E-2
Joined
Jan 3, 2014
Messages
1
Hello guys.

Motherboard MSI Z87 G45 Gaming:

I'm getting BSoD caused by tcpip.sys and crash adress: ntoskrnl.exe+72a40.

I have tried the cleaner tool and uninstalled the Killer Performance Suite and installed the driver one of you provided a link to. No luck.

Its been like this for about 1,5 week or so. I'm getting the BSoD just when watching Youtube videos or when PC is left alone with multiple connections out and ingoing in the background. When gaming no problems at all.
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
@Mr. C
best open new own topic for troubleshooting
 

VDileonardo

New member
PRIVATE E-2
Joined
Jun 29, 2015
Messages
1
I know I'm Kind of late but hopefully this helps people who are still having issues with these motherboards, I seemed to have solved the issue of my connection problems for now so hopefully this helps anyone still having connection issues (Mine would drop connection completely at random or not recognize the Ethernet port after start up) PLEASE read the steps before starting the process and make sure you understand them, even tho they are very simple.

STEP 1: Get a USB with at least 350MB of free space and plug it in.
STEP 2: Go to the killer networking Website, under the support tab, driver downloads, and DOWNLOAD Killer Suite ONTO THE USB.
STEP 3: Re-Boot Your PC
STEP 4: My computer, Select your USB Drive with the newly downloaded Killer Suite on it, right click, RUN AS ADMIN.
STEP 5: A window should appear with three options, Modify, Repair, and Remove. SELECT REMOVE, It will remove everything associated with Killer Ethernet from your PC, It will ask you to RE-BOOT, Select YES.
STEP 6: Your PC is Rebooting, After Startup make sure there is NO Connection to the internet, this means it has successfully removed everything.
STEP 7: Go back to your USB with the Killer Suite and again and RUN AS ADMIN.
STEP 8: It will ask you for language, and then it will install killer suite again. ****PAY ATTENTION*** It will Promt for anther Reboot, SELECT **NO**, Notice your PC Now has an internet connection.
STEP 9: After DECLINING THE REBOOT, Go back again to the USB with the killer network and again RUN AS ADMIN.
STEP 10: Select MODIFY This Time, Another window with selection boxes will appear, UN-select EVERYTHING (no blue box or checkmark)  **EXCEPT FOR THE DRIVERS YOUR MOTHERBOARD REQUIRES (Mine were the E220x)** Make sure the Drivers you require have a completely blue square selection Box!!!!
STEP 11: Click INSTALL, It will remove killer suite and everything else EXCEPT FOR YOUR DRIVERS. It once again will prompt for re-reboot, thus time select YES.
STEP 12: After boot up, insure you have an internet connection, if you do then it should have been successful, mine has been working no problem for the past 2 weeks, if not repeat from STEP 4.

Hopefully this helps anyone still stuck in this boat or who hasn't gotten a new board yet!
   
 
 

Lula

New member
STAFF SERGEANT
Joined
Nov 7, 2014
Messages
56
pretty clear!it works. thank you.
It's my first time to use this
 

thomasbmorris

New member
PRIVATE E-2
Joined
Jul 22, 2015
Messages
1
This may work sometimes, but the real issue is a conflict with the NDIS 6.30 driver.  Check your windows event viewer, and you will likely see some critical events. In my case they were all Event  ID 41.  My computer was restarting every 10 minutes or so as long as I was not doing anything on it.  It would run for hours if I were typing or gaming.  Eventually I ran WhoCrashed and it pointed me to the NDIS 6.30 driver.  I removed the Killer driver, and installed an intel network card and voila, no more restarts, no more critical errors in event viewer since I did that.  Two weeks now and absolutely no issues.
Killer should acknowledge the issue and MSI should replace all of these boards.
 

ne7ven

New member
PRIVATE E-2
Joined
Jul 21, 2015
Messages
1
Could someone have Killer Cleaner 64 bit link download ? the link in this post is not available anymore ? :(
 

flobelix

Well-known member
Global Moderator
Joined
Jan 25, 2007
Messages
39,448
:lookandok:

flobelix said:
64bit: https://www.dropbox.com/s/t9219ta8lt8jegh/KillerCleaner_64bit.rar?dl=0

32bit: https://www.dropbox.com/s/onoc9xnpn894it9/KillerCleaner_32bit.rar?dl=0
 

cyborgmsi

New member
PRIVATE E-2
Joined
Dec 24, 2013
Messages
1
Thank You sir for this invaluable post.. i was struggling with internet speeds from my provider and had like 3 -4 technicians visit to identify the  problem.. until I finally figured something could be wrong with the mobo's lan card.. which shouldn't have been the issue if msi had proper drivers for the lan card on this mobo ( max power z87 ) from the beginning it self...

Thanks again...
 

wspldng

New member
PRIVATE E-2
Joined
Sep 1, 2015
Messages
3
I can connect to internet but get "limited", might this fix that?

Here's a post I created on the subject if you might need more details on my issue.
https://forum-en.msi.com/index.php?threads/260524;topicseen
 

flobelix

Well-known member
Global Moderator
Joined
Jan 25, 2007
Messages
39,448
This thread is for Intel mainboard section. Stick to your thread in notebook section.
 

ceebeejohnson

New member
PRIVATE E-2
Joined
Oct 31, 2015
Messages
1
Right,

The reason why this fix is not applicable to some because they 'clearly have another problem' or 'cant follow the non official representative of MSI's instructions' is because the information is half baked and theres some insistance that as admins they are absolutely correct. Despite following the various different instructions and bad work arounds here, i have still constantly had the issue of dropouts. Its not another issue, its not windows, its not my hardware, its exactly the same problem that admins here claim to have found a solution for, that they havent fixed. Ive finally completely smashed it out on my machine and have found additional clues to the problem on my MSI GE62 2DQ Apache - The SOLE issue i have with this wonderful machine has been the god awful killer ethernet drivers.Why the f some clown thought it would be a good idea to have a hard wired ethernet port that disconnected will still interfere with a connected wifi network is beyond dumb, and anyone who thinks these types of devices ACTUALLY increase any network traffic flow must be about 12 years old. Even the theory is suspect... but i digest. I dont use a wired ethernet connection at all, i use WiFi exclusively, so to have an ethernet device cause issues with my wifi network p****s me off to no end.

First of all - Remember its actually an ATHEROS AR8161 PCI-E Gigabit Ethernet Controller (NDIS 6.30) - This is what it will display directly in device manager WHEN YOU HAVE CORRECTLY FIXED THE ISSUE
OTHERWISE IT WILL KEEP ON DISPLAYING AS A KILLER ETHERNET DEVICE AND WILL REMAIN NON FUNCTIONAL.

Heres the poop -
Disabling the ethernet in your device manager doesnt stop the dropouts. It DOES however result in faster and sometimes even instant reconnections. This is sketchy tho.
I have no idea what this killer cleaner stuff does, as it seemed to do literally nothing that using the standard windows 'uninstall program' function does. It doesnt remove keys or drivers, only the killer suite. That is all.

Heres how to fix it, so it actually works.
Go to the atheros website and download the suggested standalone drivers, ive given you the device name above.,
UNINSTALL the killer suite using the programs and features menu NOT killer cleaner. (didnt make any difference at all whether i used this or not. i suggest dont use it because i know my steps work)
UNINSTALL the device in device manager, checking the box for deleting the drivers. I find at this stage, im still connected to the internet, as at this stage your wifi card is working exactly the way it should, as a standalone device not connected by software to some half arsed rebranded network card. DISCONNECT from the internet. DO NOT go into airplane mode or anything. Just disconnect.
HERES THE PART THE ADMINS ARE MISSING
REGEDIT - Do repeated searches for 'killer' and 'e2200' - D.F.E. (Delete Effing Every) single key you find with either of those terms in it. ALL KEYS LISTING KILLER OR E2200 NO EXCEPTIONS. THIS IS HIGHLY IMPORTANT. IF YOU DO NOT DO THIS, THEN EVEN IF YOU 'SUCCESSFULLY' INSTALL THE ATHEROS DRIVERS IT WINDOWS WILL A) - STILL LIST YOUR DEVICE AS KILLER ETHERNET AND B) - STILL ATTEMPT TO OVERRIDE YOUR OEM ATHEROS DRIVERS WITH RIVET/KILLER NETWORKS MICROSOFT SUPPLIED DRIVERS. - DO NOT RESTART AT THIS STAGE. Youll also notice when you read some of the notes on the registry keys something called 'Rivet networks' appearing - This also appears to be important but more on that in a moment.

THEN - Scan hardward for changes in device manager. Your device will now come up as a generic unknown ethernet device, THIS IS GOOD
Right click on the device not working - Properties - Update driver - Browse my computer - Let me pick from a list of drivers - Have disk - Locate the files for the drivers you just downloaded, and select the device i listed above **GO THROUGH IT IN THAT ORDER OR IT WILL STILL INSIST ON AUTOMATING THE PROCESS AND WILL RE-INSTALL THE DRIVERS YOU TOLD WINDOWS TO UNINSTALL AND DELETE, AND NOT THE DRIVERS YOU ARE TELLING IT TO INSTALL**

You will then see in your device manager - A Qualcomm Atheros AR8161 entry instead of Killer e2200 and youll very quickly find that you no longer get any dropouts. I did this last night, and have not had a dropout or connection problem since.

A FURTHER OBSERVATION - I then fired up my laptop this morning to keep an eye on whether this has worked and found that my computer had 'Failed' an update..... Windows has again, ATTEMPTED TO OVERRIDE MY DRIVER INSTALLATION by attempting to install what seems to be called some 'Rivet Networks' :censored:  so im guessing this is what micropoo are using to insist their software needs to be installed. Ill now have to find a way to block that from ever happening again so i can maintain some functionality during an update cycle. Ive never trusted an OEM with new drivers.

So, now you have the actual lowdown on why A) this problem was FAR from 'Solved' in these forums and B) what the issue is and how to fix it.

_NOW_ the problems are fixed.

Have a nice day.
 

zbelcas

New member
PRIVATE E-2
Joined
Nov 2, 2015
Messages
5
Hi all.  Just about to start a Z97 Gaming 5 build and the Killer Lan issue has my attention (big time!)  I've parsed everything in this forum and others as well and most (?all) of the proposed fixes assume that the Killer Suite/drivers have already been loaded (different approaches on ensuring complete removal of the Killer Suite bits and pieces).  My question is whether this problem can be wholesale avoided by loading the 'non-Killer' drivers made available by MSI (and/or Qualcomm) from the get-go and not the Suite??  Anyone have experience with this?  If it is possible, which NIC driver (MSI or Qualcomm) would be preferable?  Thanks for the collective wisdom...
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
you can go for latest one from Qualcomm
 

zbelcas

New member
PRIVATE E-2
Joined
Nov 2, 2015
Messages
5
Tnx Svet.  Can anyone supply a link to directly download the latest Qualcomm driver?  I've poked around and have only found nonofficial sites...
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,922
its this one
http://www.killernetworking.com/support/driver-downloads
 
Status
Not open for further replies.
Top