How to fix issues with Killer Lan

Status
Not open for further replies.

armyndefamily

New member
PRIVATE FIRST CLASS
Joined
Jul 9, 2016
Messages
7
Svet date=1468150762 said:
i would suggest using standard killer drivers:
http://www.killernetworking.com/product-support/driver-downloads/standard-drivers
they are troubles free
So definitely don't bother with the Atheros drivers then? Just curious because isn't the Killer driver, even without the suite, still optimized to prioritize gaming traffic?
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,917
no, standard drivers don't control anything
 

armyndefamily

New member
PRIVATE FIRST CLASS
Joined
Jul 9, 2016
Messages
7
Svet date=1468175672 said:
no, standard drivers don't control anything
OK I'll take your advice then, but I have 1 last question just because I'm curious.

I compared the new bare Killer driver to the Atheros driver and it's the same 3 files types. A .cat file, an .inf file and a .sys file. The Killer files are all way smaller than the Atheros files, like super tiny. Any idea why? Are the Atheros drivers really bloated or something?

I just like to learn any time I can and am just asking the question to gain information and knowledge.

Thanks for your help!
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,917
which Atheros drivers you mean?
 

armyndefamily

New member
PRIVATE FIRST CLASS
Joined
Jul 9, 2016
Messages
7
Svet date=1468177766 said:
which Atheros drivers you mean?
If you look at post #19 in this thread, I followed their information and links.

Not sure if I can link other sites here, but the post and download link for the Atheros drivers which now cannot be obtained directly from Qualcom, can be found by doing the google search suggested in post #19 and will take you to a forum post on techpowerup.

Reviews I've read around the web about those drivers all seem to be very positive and that is why I am so curious about all this information.
 

Svet

Well-known member
Administrator
Joined
Nov 20, 2003
Messages
75,917
dunno can't comment such modification,
but official one stand alone drivers are working fine
 

armyndefamily

New member
PRIVATE FIRST CLASS
Joined
Jul 9, 2016
Messages
7
Svet date=1468179010 said:
dunno can't comment such modification,
but official one stand alone drivers are working fine
Oh no, I don't think they are modded drivers, just older drivers that people claim are very stable.

Anyway I won't worry about trying to use those drivers unless I have issues. Instead I will use the ones you suggested. Thank you for replying to all my questions. :)

Also in the future I will update in this thread to let people know the results I get with the drivers you suggested in case others have concerns and want confidence about them working well.
 

valyyapryadko

New member
PRIVATE E-2
Joined
Oct 12, 2016
Messages
1
Hello 
Since 9 hours without any breaks i've been searching forums trying different solutions to fix my !!!!!IRQL_ NOT LESS OR EQUAL!!!! problem at windows 10 running system with i7 6700k msg gaming M7 motherboard.Rams work fine as i can see them on bios and they are totally new. Yesterday For installing Gears of War 4 i deleted Killer network suite then i decided to instal Suite again because i didn't know it causes that much problems.. then msi app wanted to restart comp, then BSOD all attempts.==== Can't format my hard drives with windows 10 neither windows 8 dvds coz each attempt i can't reach any screen instead that error page IRQL_ NOT LESS OR EQUAL!! Also Can't run my pc on safe mode  .Also I tried disable network lan from bios and it didn't work out as well. I'm stucked. Please suggest me some solutions.
 

sp00kz

New member
PRIVATE E-2
Joined
Mar 7, 2014
Messages
3
Maja199 date=1397153775 said:
It doesn't work... I've uninstalled the old driver and the Killer Suit, used the Killer Cleaner and installed the new driver from the "Killer E220x/Win7"-Folder. The installation worked fine but it seems that there is no lan-connection. Before, with the old driver, I had a ping about 17, download speed about 12mb and upload speed 1mb. Now I have a ping about 52, download speed 5mb and a upload speed about 0.60mb. This is the same result as if I'm just connected with wLan.

By the way: I'm going through a dlan-adapter in the internet.

And before I had the problem that the connection has often disrupted for no reason and I had internet speed-drop downs.

Has somebody an idea?
First off, get rid of the powerline adapter.  Seriously, worst networking idea since token ring.  You're better off using 802.11B wireless.  
If you prefer using a wired connection, I know I do, then pick up a cheap Intel NIC on amazon and disable the KillerNIC in the bios.  You'll save yourself a lot of time and a massive headache ;)
PCI Single Port NIC $26 https://www.amazon.com/dp/B00030DEQE/ref=wl_it_dp_o_pd_nS_ttl?_encoding=UTF8&colid=UN9DN32VCLVL&coliid=INIWTZ5R8CIMC
PCIe x1 Single Port NIC $27 https://www.amazon.com/dp/B001CY0P7G/ref=wl_it_dp_o_pd_S_ttl?_encoding=UTF8&colid=UN9DN32VCLVL&coliid=I334OUHYTJSMHS
PCIe x2 Dual Port NIC $24 https://www.amazon.com/dp/B004T01KOC/ref=wl_it_dp_o_pd_S_ttl?_encoding=UTF8&colid=35DW2KS7XDY27&coliid=I20VPZLQ6Q6OCF
 

cmaree076

New member
PRIVATE E-2
Joined
Jan 22, 2017
Messages
1
Hi guys

Just a useful tip that also might be causing this issue. I thought I also had this issue but it was something different entirely. After trying to re-install all the drivers and use killer cleaner, I discovered that my idiot brother blocked my network port on our router using a parental control application. I removed my PC from the list and then I got my internet connection back. Hope this helps you guys!

Motherboard: MSI Gaming 5
CPU: i5 4670k 3.4Ghz
RAM: Crucial Ballistix 16GB 1866Mhz
GPU: MSI GTX960 Gaming 2G
PSU: Gigabyte 650W
OS: Windows 7 64 Bit

 

TroyR

New member
PRIVATE FIRST CLASS
Joined
Feb 4, 2008
Messages
9
This is why I have never purchased MSI with Killer softwares...Just a total turn off....!
 
Status
Not open for further replies.
Top