Laptop battery stuck at 89% (GP66 LEOPARD)

anwerr3154a02da

New member
Joined
Dec 8, 2022
Messages
3
I have an (MSI) GP66 Leopard laptop. Suddenly, the battery showed me to be stuck at 89%. if I unplug the charging port the laptop dies instantly. Noting the battery was fine the day before giving me up to 5 hours of gaming mode performance. Every time I power my computer it starts at 89%.

I can not click the battery-saver button as shown in the picture. Is this a software issue or is the battery dead?

I would appreciate any help.
1670462523746.png

Now, if the answer is that the battery is dead for good where would I buy a new battery. none of the famous websites I know sells it. Does MSI sells batteries for these products?
 

anwerr3154a02da

New member
Joined
Dec 8, 2022
Messages
3
I tried to reset and battery calibration. reset does nothing while battery calibration forces the laptop to shut down.
1670509075095.png

1670509126682.png
 

gregrond158a02db

New member
Joined
Dec 12, 2022
Messages
1
Mine's doing the same thing just this past month; good thing I just went over the year warranty too! :(
My battery report is about 2 pages long if not more and it's a web page so I can't upload it here (GP76 Leopard over here).

This sucks! (Dies during battery calibration/drain as well so I can't even do one of those). Does anyone know of a fix for this or is sending it to the only service center in Ontario, Canada the only way to get the hardware replaced?
 
Joined
Jan 13, 2021
Messages
1,007
I tried to reset and battery calibration. reset does nothing while battery calibration forces the laptop to shut down.
View attachment 166547
View attachment 166548
Regarding the battery saver, you need to unplug the power adpater before using this function.
There is one function called Battery master is related to battery charging behavior.
There are some explanation from the official document.
In your case, the battery percentage is not over 90% so it should be charged.
I am wondering if the behavior is related to the faulty software or setting.
You can try to reinstall the latest MSI Center to check again.
 
Top