Looking for original Bios for the RX470 Armor OC 8GB...

catinahat

New member
PRIVATE E-2
Joined
Mar 24, 2018
Messages
18
but I don't know which RAM it has without taking it apart. Anyway to tell without taking it apart? GPU-Z originally showed this 4GB reference card*. GPU-Z now links to correct card when clicking "LookUp" after flashing, but the Pixel Filrate and Texture Filrates indicate "unknown" Only thing I suspect is a BIOS flash problem at this point. Also has Error 43 in windows. In GPUZ core and me clocks are not active, temp is "-- C" and GPU and Mem Loads are 0% when using the 470 as a secondary card. Want to make sure I have the correct BIOS. Any help is appreciated.

EDIT: Tried to flash the imagfe from tech power up with Samsung RAM and get "P/N mismatch" wtih AMDVBFlash.

*GPUZ was linking me to this 4GB card (113-V34121-X3) when I received it: https://www.techpowerup.com/gpu-specs/radeon-rx-470.c2861

Tried this one but get "SubsystemIDs mismatch" in amdvbflash.
 
Last edited:

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
7,874
but I don't know which RAM it has without taking it apart. Anyway to tell without taking it apart? GPU-Z originally showed this 4GB reference card*. GPU-Z now links to correct card when clicking "LookUp" after flashing, but the Pixel Filrate and Texture Filrates indicate "unknown" Only thing I suspect is a BIOS flash problem at this point. Also has Error 43 in windows. In GPUZ core and me clocks are not active, temp is "-- C" and GPU and Mem Loads are 0% when using the 470 as a secondary card. Want to make sure I have the correct BIOS. Any help is appreciated.

EDIT: Tried to flash the imagfe from tech power up with Samsung RAM and get "P/N mismatch" wtih AMDVBFlash.

*GPUZ was linking me to this 4GB card (113-V34121-X3) when I received it: https://www.techpowerup.com/gpu-specs/radeon-rx-470.c2861

Tried this one but get "SubsystemIDs mismatch" in amdvbflash.
Sorry but not allowed to assist with you request
 

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
7,874
Could I PM the serial and you tell me which RAM this card has? I doubt this is still under warranty, but I still do not want to break the warranty seal. Just tried to open a request...seems MSI does not want to help owners...?
There is nothing we Moderators can do MSI have said no to Direct Vbios assistance best I can suggest is do a search for you Card model may be a link in the Forums still active.
 

catinahat

New member
PRIVATE E-2
Joined
Mar 24, 2018
Messages
18
There is nothing we Moderators can do MSI have said no to Direct Vbios assistance best I can suggest is do a search for you Card model may be a link in the Forums still active.
100% not blaming you Alan, but MSI is not on my to buy list.
 
Top