Low RAM write speed on B550 with Ryzen 5 3600

MikiLoz

New member
CORPORAL
Joined
Mar 21, 2013
Messages
20
I went from B450 to B550 few days ago and i noticed that my RAM write speed is way lower than before with new RAM sticks which are just a bit faster than previous! Before it was 3200mhz, now it`s 3433mhz. Read and copy seem fine, latency is about 67ms. No matter what speed i set for ram it`s always way lower than it was. I have Ryzen 5 3600 OC to 4.4ghz at the moment. Write was about 49xxx mb/s and now it`s barely 28xxx mb/s. RAM is Kingston Hyper X Fury 3433mhz cl16 now, and was the same before only slower, 3200mhz cl16 but overclocked to 3600mhz with same stock timings. I tried new ones from 3200 all the way up to 3800 and resultas are within margin of error. Write is constantly low. At this moment RAM speed is 3600 and same problem

Can anyone share any idea why is that!?

Untitled.png
 

SeoulFinn

Lover of budaejjigea
SERGEANT
Joined
Sep 26, 2015
Messages
159
That much of a difference? Are you sure you are using your RAM in "Dual Channel" mode? In other words, are the RAM sticks in right slots?

In my x570 ACE the correct RAM slots are:
CPU - empty - RAM stick - empty - RAM stick. Check your manual as the recommendation might be different as the chipset is not the same.

If the sticks are in right places, I suppose there's something wrong in your BIOS. Is your "IF Clock" (FCLK) set correctly? For the best performance it should be 1:1. If you are aiming for DDR4-3600 speeds, then it should be set to 1800MHz.
 
Last edited:

MikiLoz

New member
CORPORAL
Joined
Mar 21, 2013
Messages
20
That much of a difference? Are you sure you are using your RAM in "Dual Channel" mode? In other words, are the RAM sticks in right slots?

In my x570 ACE the correct RAM slots are:
CPU - empty - RAM stick - empty - RAM stick. Check your manual as the recommendation might be different as the chipset is not the same.

If the sticks are in right places, I suppose there's something wrong in your BIOS. Is your "IF Clock" (FCLK) set correctly? For the best performance it should be 1:1. If you are aiming for DDR4-3600 speeds, then it should be set to 1800MHz.
Everything is the same from RAM slots to FCLK speed and it`s all like it should be.. Sticks in second and fourth slots, and FCLK is 1800 automatically when selecting 3600mhz... I even flashed BIOS again and same thing. I called my friend whom i sold my previous RAM to and asked him to do the write benchmark on his board which is B450 Tomahawk, and write speed was 48xxx mb/s. Those sticks run at 3200mhz XMP...

I`m not sure i know what is going on but something is not wright and would like to get to the bottom of it

One more thing that is weird is that BIOS shows both XMP profiles the same and they should be different like on page about memory where's XMP 1 is 3466 and XMP 2 is 3000.

I know for a fact that happened on B450m Mortar MAX i had previously but it went back like it should be after flashing latest BIOS. I flashed two different BIOS versions on this B550 and every time it`s the same write score and same settings in BIOS. No change at all. So, again, i`m assuming faulty BIOS which is not that strange when it comes to MSI
MSI_SnapShot_01.jpg
MSI_SnapShot.jpg
 
Last edited:
Top