Mega Player 533- F/W v2.00.02 & Driver v1.672- Possible Problem & Fix to Recover

V

v2.pain

Guest
:wall: Does anyone know where or in which country you can use frequencies from 65 MHz-125 MHz FM..which I can now search/scan when I listen radio on my MEGA-mega :agrees:-(5)533..for those who don't know some guy named Garry Sun (he is maybe from MSI who knows) posted file "stmpsys.sb", topic is "Expand frequency from 65 Mhz to 125 Mhz in MSI-533" https://forum-en.msi.com/index.php?topic=99116.0, which I installed (updated firmware again just with this file instead original in v2.000.002-fw).

P.S. [to bickel72]: I don't know why don't you just find someone with XP windows and update firmware there [it takes about 2 min to install 1.672 drivers and FW-v2..and than format it and update firmware] and than use it on your winMe at home [if your only problem is win XP ..maybe I don't understand what your problem is..I don't know anyone who still has win Me so I can't try it myself].
P.S.2. It still amazes me how resistant MEGA 533 is ..to all this installs/formats  :bonk:..I even unplugged the USB cable during format process just to see what will happen..nothing..after reinstallation it worked again..in all I maybe formated it and reinstalled it for about 25-30 times until I made it to work as it should..at the time I even made it to work with v2 fw but it was showing 000.000.000 version for "Boot Manager" in updater prog. details and I thought that was some kind of bug and it is normal and I used it for a week until i started to mess with it again until I succeded :shocking:
 
L

linhart.ondrej

Guest
v2.pain said:
I finally solved "the v2.00.02/v1.672 firmware update problem" [after 20 install/reinstall Edited for language]
[I also tought (at the time) that my player is dead/fried...doesn't matter now dough..]

It's almost funny now how easy I made it to work again with updated firmware..
point is that when you connect it on USB without pressing anything and start updater
and when it says "Media state not initialized" you check "Format" and run it..when completed
unplug it..and then again connect it with play pressed all the time (as described in instructions)..
start updater again with format option checked and wait to complete..thats it!
now finally everything works fine as it should be (v2.00.02).. :agrees:

P.S. "Questioon" wrote that he didn't figured how to work with playlist..just, when you are in the "playlist", need to press next/previous key for about half a second to navigate through folders (when you copy music to player you put it in folders if you want to use playlist feature)

v2_no_more_pain_manual
edited for language. Same problem as I mentioned above. Firmware update successfully completed, but player does not start and drives are not recognized...
 
T

Tiresmoke

Guest
watch the language folks. This is the family channel and I will enforce it if this keeps up.
 
A

abc

Guest
No problems here.. been using my mega player for about 3 weeks now. (OS: winxp)
 
R

rpphorums

Guest
Just a note that I installed that new firmware and driver, and all went okay. I did take out the battery and kept the button down before and during the whole process, like the instructions say. Also formated the volume. The most unnearving thing was that upon connecting the device (whilst holding the button down) I received a message from my operating system saying that a USB v2.0 was connected via only a v1.0 port (even though I'm pretty sure the port is v2).

I then received 'Playlist' function. So now I can navigate throughout the folder tree and select all the files/folders I want to play. Although you only have one playlist, it is still a good feature, vital I'd say for my personal needs.

I notice that when I sometimes rearrange the device's files from the computer, that the device hangs upon next boot up. I'm guessing that it fails if it can no longer find folders/files last recorded on its playlist. So if that happens, I remove the system file in the root folder (I can't remember the name, offhand) that it uses to record the playlist files, and all seems to be okay.

Never having used an MP3 player before, it took me some time to understand how to construct a playlist. The new English manual certainly doesn't tell you. grrrr, that's very slack MEGA.

I've also noticed that when I'm finishing the playlist and I wan't to navigate out of the root folder, I can't hold that left-button down too long, else it reboots.

I also had problems determining the play order of files/folders. Most of the time it seemed to be alphabetical, but sometimes not. I think the play order is alphabetical but only the first 6(?) characters of the file name / folder name are significant. So the beginning part of all my file/folder names look something like 01.01. The "Title" (an MP3 tag?) that you can set is what is displayed on the unit's interface, but it does not determine the play order.

I've turned the backlight off, and that seems to conserve a lot of power.

At the moment, I'm pretty happy with the unit. The only thing I really miss is a built-in rechargeable battery. That would be sweet.

The quality of the built-in recording is quite good (for voice, anyway). I was surprised that it only records to WAV, and has no MP3 option.

It's a pity there was so much time wasted stuffing around with dowloading and installing firmware, drivers and manuals. And figuring out how to use the thing - THAT IS NOT DOCUMENTED PROPERLY.
 
G

G3R1NC

Guest
I didnt manage to do this...

Could somebody please write down clearly what do I have to do? I have Mega Player 533 without radio, I think its not problem, but tell me if it is...
I tried everything...
The Playlist function would be very useful for me
Please help!!!
 

spadayu

New member
PRIVATE E-2
Joined
Nov 22, 2006
Messages
1
I have had the same problem and I solved it.
1. flashed it to firmware v.2.00.2
2. device was death
3. installed old drivers from CD
4. I have pressed play button, but player was recognized like as "recovery device".
5. driver installation window pop out and I browsed it to CD:\\533Setup\MSI\Drivers\StMp3Rec.ini file
6. after everything installed player was flashed to v.1.0.1
7. disconnected the device
8. then I've uninstalled old and installed new drivers MS5533 driver V1.672
9. copied firmware files to specified dir C:\Program Files\MSI\MS-5533\
10. push the play button and started update program
11. the player was flashed to  firmware v.2.00.2
12. disconnect it, connect it, if it don't work try 10. and 11. step w/o pressing the button
13. or try everything from 4. step but pointing to new driver unpacked folder

good luck
 
T

Tiresmoke

Guest
Nice post Spadayu... This should help folks understand that step by step.
 
K

korner12

Guest
hey... i need a msi mega player 533 original firmware(v1.0.0.2 or 1.0.0.6)... pls add here...
 
B

bickel72

Guest
The link that Stu added earlier (ie. 29 April 2006) on this main thread should help you out with your request.

It appears to still be valid.

MSI MS5533 Firmware v.1.00.06 zip file link

https://forum-en.msi.com/index.php?action=dlattach;topic=96066.0;attach=2061

:biggthumbsup:
 

Vashtard

New member
PRIVATE E-2
Joined
Mar 7, 2007
Messages
1
so based on the whole topic it seemed the new software driver is the cause of the problem....

i thought my Mega Player 533 128mb ver, is doomed beyond my cause..... as i tested to connect and reconnect my player until it reads "recovery" and downgrade my firmware to 1.00.06 (which is in my original firmwear ver. in my player)

and i did a very nasty procedure due to my laziness and i thought it fried my player because i forgot to take out the batt... and even almost killed my player in the process....

based on my carelessness did it happened to you when you left your earphones near the player that causes most of the text to go jibberish... =P
 
Y

y0shi007

Guest
hello guys, i lost my original driver CD can anyone post or upload the drivers? pls. my mega player 533 is dead and i need to fix it..
 

Stu

New member
GENERAL OF THE ARMY
Joined
May 25, 2004
Messages
19,551
y0shi007,

have you actually read through this thread? ???

you can find all downloads and information for this product here:
MSI MegaPlayer 533 series
 
M

mArlInJ

Guest
Hi all,
I have same problem. but my player can't recognize by computer after update firmware.
Can't open.
how do i do? or shop new one. :bonk:
 

steve_h

New member
PRIVATE E-2
Joined
Oct 31, 2008
Messages
1
Hi all,

Well after a hour or so I've cracked it ...  :emot-tip-wink:

The DRIVER installed files (ver 2.6) from the MSI website  :nooo: are BAD / corrupt ... so heres the workaround ...

I haven't isolated the exact file(s) as some are resourse for others but if you do the following you should get the 533 working

Simple: replace DRIVER installed version 2.6 files with FIRMWARE (download zip) files and manually run upgrade from folder.

Detail: Go to program files, msi, ms-5533
          Delete or rename the six (6) files of the same name that are in the FIRMWARE downloaded zip file
          Copy the files from the FIRMWARE extracted folder to the ms-5533 folder
          Connect 5533 and Run stupdaterapp.exe by double clicking on it
          Follow the prompts ...

(Note to MSI reps - I need work or freebies / hardware)

Greets to Claire :biggthumbsup: @MSI

 

Kengoor

New member
PRIVATE E-2
Joined
Oct 5, 2009
Messages
1
I hate this.... I tried to update the software and now my player is dead! I can't even turn it on, or connect it to computer! I can't get it back to older version because it is not recognize by my system.... What do I do???? :( And I tried to hold the PLAY button! Still nothing!
 

gars

New member
PRIVATE E-2
Joined
Nov 9, 2009
Messages
1
i cant make my 1 gig sd card work while my unit is on, it just kept flashing the hour glass and the mega logo waited for almost an hour but to no avail but i managed to update its firmware and i really liked the playmode/playlist function the only problem is i can only put music on the built in memory but when i use it as a card reader my cards work
 

Frankenputer

New member
GENERAL OF THE ARMY
Joined
Apr 16, 2004
Messages
9,815
http://global.msi.eu/index.php?func=downloaddetail&type=firmware&maincat_no=124&prod_no=69
 

bokica

New member
PRIVATE E-2
Joined
Apr 27, 2011
Messages
4
1. download driver 1.672 and firmware 2.00.02
2. install driver
3. copy firmware files to C:\Program Files\MSI\MS-5533\ ,REMOVE BATTERY from mp3
4. press and hold on/off button on mp3 (and hold all time)
5. connect mp3 with usb to comp
6. start/programs/msi run aplication
7. chek empty slot and click start (mp3 delete all files,and upgrade new files)
8. remove mp3 from usb and remove finger from button on/off ;)
9. put battery in mp3, if is mp3 die, try same job again u make something wrong, i finish job in 3 trys.
10. connect mp3 to comp and download mp3 files
enjoy :))
 
Top