MS-6167 Drivers

fastvan67@charter.net

New member
PRIVATE FIRST CLASS
Joined
Feb 9, 2017
Messages
17
Hey guys.. Been a while.. I picked up on a brand new MS-6167 Slot A board. Everything there but the driver CD. I will either install Windows 98se or XP. Haven't decided yet. Either way, gonna be a great retro-build!
Anyone know where I can download all of the original drivers including the most recent bios update?
Also have a NVIDIA GeForce FX 5200 (FX5200TD128LF). Would like the drivers and vbios for it as well. (if possible)

Thanks!
 

fastvan67@charter.net

New member
PRIVATE FIRST CLASS
Joined
Feb 9, 2017
Messages
17
Well, got all the drivers I needed. I went with Win98. BUT... Got a couple issues.
Never found the bios ver 1.6 in the links above.
Second, my CPU is an Athlon 750Mhz. Bios (1.5) sees it as 500Mhx. Since the system I believe is supposed to be auto-detect as stated in the manual, could it be because the bios needs updating to ver 1.6?
Third, I have no sound. Card is detected correctly and drivers installed. Is this mobo one of those that requires the -5v for sound to work?
 

fastvan67@charter.net

New member
PRIVATE FIRST CLASS
Joined
Feb 9, 2017
Messages
17
Digging around in my stuff, I found a power supply with the -5v. Now have sound! :p

Next, how to I get this mobo recognize the 750Mhz CPU?
 

jakub-p2

Member
PRIVATE FIRST CLASS
Joined
Feb 29, 2020
Messages
172
Digging around in my stuff, I found a power supply with the -5v. Now have sound! :p

Next, how to I get this mobo recognize the 750Mhz CPU?
Ok, let's try manually set multiplier/BCLK - if I recall mine Slot A is 6.5X100MHz. In Your case it should be 7.5X and 100MHz.
 

fastvan67@charter.net

New member
PRIVATE FIRST CLASS
Joined
Feb 9, 2017
Messages
17
Unfortunately there is no option in the bios to set multiplier/BCLK. Under "Frequency/Voltage Control", the options are "Auto Detect DIMM/PCI Clk" and "Spread Spectrum Modulated".
Auto Detect gives "Enabled/Disabled". "Spread Spectrum" gives "1% Down" and -0.5% Down".
The only other thing in the bios that can be adjusted is the ram clock.
 

jakub-p2

Member
PRIVATE FIRST CLASS
Joined
Feb 29, 2020
Messages
172
Man, I really wish that either of mine MSI slot A boards was working at this point... OK, slot A CPUs were controlled with resistors - link!
You can try updating BIOS, I don't think it will help, but still.
If that doesn't work then I guess that Your Athlon has been repackaged(shell only, mine 650 has 850 written on the core :) ), or MoBo is damaged in some way.
Well as a last resort You might want to buy/make a GFD (goldfinger) - they were recently redesigned and 'revived', with this You will be able to OC this chip.
 

fastvan67@charter.net

New member
PRIVATE FIRST CLASS
Joined
Feb 9, 2017
Messages
17
Well, finally got it figured out. I purchased this CPU 5 years ago. This is when I finally decided to actually make a full build. So, this is what I did.. The black case on the CPU says AMD-K7750MTR52B.
I pulled the case off and checked the core. Immediately my feeling were hurt. The core says AMD-K7500MTR51B. So its a 500Mhz! :mad: The person I bought this from must have been laughing when that thing sold.
Thanks guys for your time. At least I have a fully working vintage system. Even if it is 250Mhz slower than I thought.
 
Top