MSI A520M-A Pro: AMD 5600G: CPU Debug Light Red

Joined
Jan 23, 2022
Messages
8
I installed an AMD 5600G on the MSI A520M-A Pro. The CPU Debug light stays white. All other Debug lights are off. Nothing on the screen. I took the CPU cooler and CPU off. There are no bent pins. The CPU drops in with no force at all, and cannot be moved side-to-side. Same problem on boot. Very sure that there are no bent pins and that it was put in correctly because both times, the CPU literally dropped into the socket without any force. Took the RAM DIMMS off and tried again. What would you recommend?
 

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
7,897
I installed an AMD 5600G on the MSI A520M-A Pro. The CPU Debug light stays white. All other Debug lights are off. Nothing on the screen. I took the CPU cooler and CPU off. There are no bent pins. The CPU drops in with no force at all, and cannot be moved side-to-side. Same problem on boot. Very sure that there are no bent pins and that it was put in correctly because both times, the CPU literally dropped into the socket without any force. Took the RAM DIMMS off and tried again. What would you recommend?
It is very likely you will need to do a BIos update

RYZEN 5Cezanne100-0000002525600G1003.9GHz3MB16MBA065AMDRadeonGraphics 1900MHz7C96v17.zip


You can ask at local Computer store or apply to AMD for boot kit>>AMD Drivers<<
 
Joined
Jan 23, 2022
Messages
8
Thank you for the response. Is there any way to determine if the BIOS update is the problem based on the serial number of the motherboard? I would rather get a motherboard with BIOS flashback than wait for a boot kit.
 

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
7,897
Thank you for the response. Is there any way to determine if the BIOS update is the problem based on the serial number of the motherboard? I would rather get a motherboard with BIOS flashback than wait for a boot kit.
Perhaps you will need to match date of bord build with BIOS page

Bios on board for this example would be the one dated 2021-01-25
As Board date is 2021 February.

Bios date.jpg

Bios date 2.jpg
 
Joined
Jan 23, 2022
Messages
8
Perhaps you will need to match date of bord build with BIOS page

Bios on board for this example would be the one dated 2021-01-25
As Board date is 2021 February.

View attachment 156076
View attachment 156077
Thank you so much for your help! It turns out that the board was made in 9/20 so it wouldn't have the 5600G BIOS. In any event, I exchanged it for a MSI B550 Pro VDH Wifi, which is causing me problems. =(
 
Top