MSI B550-A PRO Attempting to flash BIOS without cpu. No response from the board, no LED lights

Joined
Jan 27, 2021
Messages
3
Hi, I'm wondering if my motherboard is dead. I just received it yesterday, and attempted to update the BIOS using a flash drive. I've followed the various instructions I found online. The motherboard is connected to a brand new PSU with the 24 pin and the 8 pin connector, and I'm inserting the flash drive into the correct slot. When I power on the PSU, there's nothing on the motherboard to indicate it's receiving power. Pushing the flash bios button next to the flash drive does nothing - the LED light doesn't go on at all. I've also tried the board with a known working PSU.

I'm due to receive a 5600x tomorrow, and I'm contemplating trying to install the CPU and just hoping that the BIOS was already updated after manufacture. I'm thinking the motherboard was just dead when I received it. Any thoughts/advice?
 

plutomate

Well-known member
MAJOR GENERAL
Joined
Jul 30, 2015
Messages
4,313
wut's your serial number (ex. 601-7C91-010B2012......)?
if the number is bigger than 2008, you should be able to boot with ryzen 5000 CPU.
it means the MB manufactured date is in aug, 2020 and if you compare to BIOS download page, it means the board has A3 BIOS and should boot with Ryzen 5000 out of box.
1611742256498.png
 
Joined
Jan 27, 2021
Messages
3
That's great advice, thank you very much. The serial number is 2012. It's a little concerning that there appears to be no power on the motherboard, but I'll try it with the CPU tomorrow.
 

Alan J T

GRUMPY OLD FART
Joined
Sep 11, 2020
Messages
2,906
That's great advice, thank you very much. The serial number is 2012. It's a little concerning that there appears to be no power on the motherboard, but I'll try it with the CPU tomorrow.
Press in the button and count to 3 and release. you should feel it click when you push it I use a match stick to press it in as it is recessed on my board. And will leave some directions just in case you need them
Good luck with the Build
:lookandok:

Some directions for you
I only use USB 3.0 drives of a known brand not mystery drives.
It appears that cheap mystery drives may be problematic.
FOR BIOS FLASHBACK
Following Directions are for windows based OS
Right Click on the Downloaded Bios Zip File, select properties if you see the message this file is blocked by windows tick the box to unblock and click OK.
When in windows File Explorer make sure that you select the View tab and Tick the box Show Hidden Files and File Name Extensions.
Extract the BIOS file from the Downloaded ZIP file Open the folder it was extracted to.
Right click on the BIOS file, select copy and then paste it into a USB drive Formatted to FAT32,
When in Windows File Explorer make sure that you select the View Tab and Tick the box Show Hidden Files and File Name Extension.
Now rename the BIOS file to MSI.ROM
There should be no other files or folders on the USB drive, just the BIOS file you have renamed to MSI.ROM
For more details see this post By Mattech
I always strip any partitions out of USB drives when I buy them, Delete the partition or Volume and then make a new simple volume and Format to FAT32 I do this with every USB drive I get as I detest the formatting and software on them done by the Manufacturers is more trouble than they are worth.

I Normally do this with Windows Disk Manager

However if you are having trouble Deleting the Partitions on you USB drive or you have a failed attempt pleas download and use Partition Magic to remove all partitions on the USB and then create a new a single partition formatted to FAT32
Or try as suggested by jaytripathi if that also fails.
QUOTE jaytripathi10156c02dd
This happened to me, so I used diskpart to clean the drive completely and format it to MBR and then I was able to flash it successfully.
Use these steps:
Open cmd as admin and type these commands one after another
Diskpart
list disk
select disk (id)
clean
convert mbr
create partition primary
select part 1
active
format fs=fat32 label=(name) quick
assign letter (letter)Just be careful not to erase the wrong drive.
QUOTE END

FlashBack can be used on a fully assembled PC even if CPU is one of the new 5xxx series.
PC must be turned off for BIOS Flashback to be started do not turn on your PC the Bios Flashback will do it for you
If that Fails see directions below.


OK turn off and PSU and remove the power cord. Carefully take the PC apart remove all the components from the case as well as the Motherboard Place on a cardboard box or insulated surface, and plug in the 24 pin and the CPU power plugs for the Motherboard. Do not plug in any other leads to the board.
Plug in and turn on the PSU
Wait about 2 minutes before next step just in case there is a power on and off cycle when you turn on the PSU
Plug the USB Drive in to the USB port just below the Bios Button,
Do not touch any Jumpers on the Motherboard
Push the FlashBack button and then release it,
About 5 seconds later a led just above the USB port will start to flash, after 15 seconds of so the speed of the flashing light will double this is the writing to the BIOS period.
Once done writing to the it will stop flashing and PSU will turn off
For 16MB BIOS it will take about 4 to 5 minutes, and flashing stops.
For 32MB BIOS it will take 6 to 7 minutes, and flashing stops.
People have said that it may turn back on if so just turn off and unplug the PSU.
And Bios should be flashed if just one of these steps does not happen it is a failed flash.
jukka.savilaaks154e02d4 said:
Just to check out if the MB even understands the drive itself I have also made some testing:
Wrong file format: (Ie. ExFAT, NTFS etc) the drive flashes, but no power to the motherboard.
Wrong file name: The USB drive led flashes few times, the flash LED flashes few times, but no power to the motherboard
Correct file format and name but other error: the USB LED flashes few times, The flash LED flashes few times, power turns on, USB flashes again few times, flash LED flashes two times and then turns on and stays on.
Successfull flash: same as above except flashing keeps on for several minutes, until the flash LED stays off
 
Joined
Jan 27, 2021
Messages
3
Thanks for the helpful responses plutomate and Alan J T. I've followed those steps to the letter, checked the power connections countless times, and there's still no sign of life from the motherboard. It doesn't seem too promising. I'll try it with the CPU tomorrow and see what happens.
 
Top