MSI Center/Mystic light buggered something

Joined
Aug 24, 2023
Messages
5
I installed MSI Center and Mystic with it and was using it for a bit. I then openen OpenRGB Alongside to try that, and everytihing was fine. Untill i uninstalled MSI Center. The LED's on the fan went off and the Windows USB disconnect/connect sound began playing constantly on loop. (Its still happening) I then saw that in OpenRGB my motherboard was no longer detected.
So i went and installed MSI Center and Mystic again to try to fix it. But it did not. uninstalling it again didnt work, and mystic wont even control the LEDs now. I then tried to update the BIOS to latest, i tried removing the cmos for 5 minutes to no success. When i was in the BIOS it was also extremely laggy. my mouse was stuttering and the menu's were stuttering. Sometimes the BIOS would just crash/lock up too. This is the first time i am experiencing these issues in the BIOS.

In Device manager there is no yellow exclamaition mark to signal there is a problem with a device.
I can see the USB device icon in my tray appearing constantly, and in my Windows devices menu i see "MYSTIC LIGHTS" apearing every few seconds.
I read someone contacted MSI about their Mystic not actually being gone and MSI gave em a tool to completely remove it.

Any ideas/suggestions? Other than just reinstalling windows cause i am not doing that.

-----------------------
B550-A PRO (no wifi) 7C56cAE bios
R5 5600
Win 10
 

Attachments

  • gif of mystic light appearing.gif
    gif of mystic light appearing.gif
    33.8 KB · Views: 31
I was eventually able to solve it last night.

I read about disabling the LED switch on the motherboard, and that fixed all the problems i was having. But of course then any LEDs i have are useless.

Then for some reason I reinstalled MSI Center again and did another Advanced scan, and there suddenly was a LED firmware update. I guess because the firmware was freaking out it could not request an update, so when I turned the switch off it could?

So after installing the firmware according to the given instructions the problems were all resolved.

Only thing now is that MSI Center wont go away from my Start Menu. Even thou it is uninstalled. Small inconvenience.
 
I was eventually able to solve it last night.

I read about disabling the LED switch on the motherboard, and that fixed all the problems i was having. But of course then any LEDs i have are useless.

Then for some reason I reinstalled MSI Center again and did another Advanced scan, and there suddenly was a LED firmware update. I guess because the firmware was freaking out it could not request an update, so when I turned the switch off it could?

So after installing the firmware according to the given instructions the problems were all resolved.

Only thing now is that MSI Center wont go away from my Start Menu. Even thou it is uninstalled. Small inconvenience.
Use this to fully uninstall MSI Center
MSI removal tool [newest version]
https://download.msi.com/uti_exe/nb/CleanCenterMaster.zip
 
Back
Top