MSI Crosshair 15 (B12U) Latest driver updates.

IMG_5065.jpeg


bt.png
Intel® Bluetooth23.20.0 (intel took the link down for some reason)
ime.png
Intel® Management Engine (WMI Provider)
Intel® Management Engine (Interface #1)
Intel® Dynamic Application Loader Host Interface
2338.5.1.0
2345.5.3.0
1.44.2023.710
tp.png
Intel® Serial IO30.100.2328.32
wlan.png
Intel® Wireless LAN23.20.0
lan.png
Realtek LAN1124.016 , 1125.016 , 1126.016, 1166.016 , 1168.016 (2023/12/25)
audio.png
Intel® MVA
Intel® Smart Sound Technology
A-Volute AudioProcessingObject + A-Volute Extension
Realtek Audio
1.0.3218.0
10.29.0.10040
4.10.4.0 + 1.5.37.0
6.0.9629.1
gpu.png
GeForce Game Ready Driver
Intel® Graphics
551.23 (Last stable one is 537.58)
31.0.101.5086/31.0.101.5234
chipset.png
Intel® HID Event Filter
Intel® GNA Scoring Accelerator module
Intel® Chipset INF Utility
2.2.2.6
3.5.0.1574
10.1.19627.8423
dt.png
Intel® Dynamic Tuning Technology
Intel® Dynamic Tuning Technology Extension
Intel® Innovation Platform Framework Processor Participant
Intel® Innovation Platform Framework Extensible Framework
9.0.11404.39881
9.0.11404.39881
1.0.11404.39976
2.1.10103.18

I would also recommend the program wushowhide to disable auto update on the intel graphics. This because if you use intel auto updater (or intel website) to update the Intel ARC driver windows update always kicks in and downgrades the driver to a much older one. Which in many cases you have to do multiple reboots unnecessary.

* Delete the
nvidia telemetry
* Fix the realtek audio delay
 
nieuws-updates-1400x450.jpg

bt.png
Intel® Bluetooth23.20.0 (intel took the link down for some reason)
ime.png
Intel® Management Engine (WMI Provider)
Intel® Management Engine (Interface #1)
Intel® Dynamic Application Loader Host Interface
2338.5.1.0
2345.5.3.0
1.44.2023.710
tp.png
Intel® Serial IO30.100.2328.32
wlan.png
Intel® Wireless LAN23.20.0
lan.png
Realtek LAN1124.016 , 1125.016 , 1126.016, 1166.016 , 1168.016 (2023/12/25)
Intel Rapid Storage Technology.png
Intel® Rapid Storage Technology F6 Driver
How to load IRST driver or other third party driver during the Windows installation?
19.5.7.1058
audio.png
Intel® MVA
Intel® Smart Sound Technology
A-Volute AudioProcessingObject + A-Volute Extension
Realtek Audio
1.0.3218.0
10.29.0.10040
4.10.4.0 + 1.5.37.0
6.0.9629.1
gpu.png
GeForce Game Ready Driver
Intel® Graphics
551.23 (Last stable one is 537.58)
31.0.101.5186/31.0.101.5234
chipset.png
Intel® HID Event Filter
Intel® GNA Scoring Accelerator module
Intel® Chipset INF Utility
2.2.2.6
3.5.0.1574
10.1.19627.8423
dt.png
Intel® Dynamic Tuning Driver
Intel® IPF Driver
Intel® IPF Driver Extension
9.0.11404.39881
1.0.11404.41023
2.1.10103.18

I would also recommend the program wushowhide to disable auto update on the intel graphics. This because if you use intel auto updater (or intel website) to update the Intel ARC driver windows update always kicks in and downgrades the driver to a much older one. Which in many cases you have to do multiple reboots unnecessary.

* Delete the
nvidia telemetry
* Fix the realtek audio delay
 
Last edited:
new (2024) MSI Crosshair D14V laptops {14th gen Intel} released (no driver downloads posted for these yet except for the lone mouse driver - they'll come later this Jan. 2024)

full set of driver downloads for 14th gen Intel based Crosshair 16 HX & Crosshair 17 HX D14V series laptop pcs are recently available as of Mon., Feb. 5, including the slightly older 6.0.9626.1 audio driver {slightly different package than this 9626 driver} & the Nahimic APO4 v4.10.4 driver which has A-volute extension 1.5.38 driver instead of 1.5.37.
 
@Grieverokami


I did notice that there is a small sound delay at the beginning of playing a sound (like a error message in windows that you hear for half, or the begin sound when windows starts). I did not bother about it because in games or playing movies i don't have a delay BUT i whas thinking what could be the cause. So i did some research of my own and after that i was looking online to confirm it (the sound has some sort of power saving as i thought). This regedit will fix the issue (found it online). After you changed the values you need to reboot in order to get it to work. I have tested this and i can confirm this solved my sound delay and the plopping sound.

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0001\PowerSettings (This one is for the realtek card)

Old value:

View attachment 183049

New value:
View attachment 183050

about this.

mine is in "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0000\PowerSettings" for realtek audio instead of HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0001\PowerSettings {that's 0000 instead of 0001 as it may differ between different boards, aio desktop & laptop pcs [may have "0002" or else on a few others] - simply search for the "PowerSettings" key in registry editor}
 
Last edited:
about this.

mine is in "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0000\PowerSettings" for realtek audio instead of HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0001\PowerSettings {that's 0000 instead of 0001 as it may differ between different boards, aio desktop & laptop pcs [may have "0002" or else on a few others] - simply search for the "PowerSettings" key in registry editor}

I noticed it is switching when you reinstall using the setup.exe. mine is mostly located at 0001 but it has been 0002 and 0003 for once (don't know why).

Values for my Crosshair 15 BUGSZ machine:
0000 = NVIDIA High Definition Audio
0001 = Realtek High Definition Audio
0002 = Realtek High Definition Audio
0003 = Realtek High Definition Audio
0004 = Intel Smartsound Technology for digital microphone
0005 = Intel Smartsound Technology for Bluetooth
0008 = Intel Smartsound Technology for USB audio

I made reg files so i don't have to do everything over and over again. Everytime realtek is updating or nahimic it changes the values.

Schermafbeelding 2024-02-07 192345.png
 
Last edited:
Slider_News_TEX-DESIGN.png

bt.png
Intel® Bluetooth23.20.0 (intel took the link down for some reason)
ime.png
Intel® Management Engine (WMI Provider)
Intel® Management Engine (Interface #1)
Intel® Dynamic Application Loader Host Interface
2338.5.1.0
2345.5.3.0
1.44.2023.710
tp.png
Intel® Serial IO30.100.2328.32
wlan.png
Intel® Wireless LAN23.20.0
lan.png
Realtek LAN1124.016 , 1125.016 , 1126.016, 1166.016 , 1168.016 (2023/12/25)
Intel Rapid Storage Technology.png
Intel® Rapid Storage Technology F6
How to load IRST driver or other third party driver during the Windows installation?
19.5.7.1058
audio.png
Intel® MVA
Intel® Smart Sound Technology
Nahimic
Realtek Audio
1.0.3218.0
10.29.0.10040
4.10.4.0 (EXTv1.5.38.0)
6.0.9629.1
gpu.png
GeForce Game Ready
Intel® Graphics
551.46 (hotfix)
31.0.101.5194/31.0.101.5252
chipset.png
Intel® HID Event Filter
Intel® GNA Scoring Accelerator module
Intel® Chipset INF Utility
2.2.2.6
3.5.0.1574
10.1.19627.8423
dt.png
Intel® Dynamic Tuning
Intel® IPF
Intel® IPF Extensible Framework
9.0.11404.39881
1.0.11404.41023
2.1.10103.18

I would also recommend the program wushowhide to disable auto update on the intel graphics. This because if you use intel auto updater (or intel website) to update the Intel ARC driver windows update always kicks in and downgrades the driver to a much older one. Which in many cases you have to do multiple reboots unnecessary.

* Delete the
nvidia telemetry (for older drivers i needed this up to 537.58, need to test it on the hotfix)
*
Realtek audio delay fix
 
Last edited:
Realtek audio delay fix.

You can fix this by using the regedit function and search for "ConservationIdleTime" or "PerformanceIdleTime" or "IdlePowerState". Check the left tab if it says realtek.

You will see this:
rt.jpg


* My realtek is located under 0001, it is possible yours is stored under 0002, 0003 or another number.
2. Click on PowerSettings and change the values (old to fixed ones)

Old value:
old.jpg

Fixed audio:
2.jpg


3. Reboot!

** If you want to use a .reg file, just save it. don't forget to change the values to your own.

Backup:
Code:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0001\PowerSettings]
"ConservationIdleTime"=hex:05,00,00,00
"PerformanceIdleTime"=hex:05,00,00,00
"IdlePowerState"=hex:03,00,00,00

Fixed audio:
Code:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e96c-e325-11ce-bfc1-08002be10318}\0001\PowerSettings]
"ConservationIdleTime"=hex:ff,ff,ff,ff
"PerformanceIdleTime"=hex:ff,ff,ff,ff
"IdlePowerState"=hex:00,00,00,00

Last thing, after every audio update you have to redo the steps posted above. If you update realtek, intel smartsound technology or the nahimic drivers you have to redo it.
 
Last edited:
I noticed it is switching when you reinstall using the setup.exe. mine is mostly located at 0001 but it has been 0002 and 0003 for once (don't know why).

Values for my Crosshair 15 BUGSZ machine:
0000 = NVIDIA High Definition Audio
0001 = Realtek High Definition Audio
0002 = Realtek High Definition Audio
0003 = Realtek High Definition Audio
0004 = Intel Smartsound Technology for digital microphone
0005 = Intel Smartsound Technology for Bluetooth
0008 = Intel Smartsound Technology for USB audio

I made reg files so i don't have to do everything over and over again. Everytime realtek is updating or nahimic it changes the values.

View attachment 184724
I get the same results on LatencyMon regardless of the change. And to be totally honest, the speakers on this model are pretty poor in quality anyway. Even compared to the old MSI GP62-6QF Leopard PRO that i had just refurbished. I tried Mass Effect LE on both systems and the sound quality is night and day. Consequently all i do is connect to a smart tv and play it from there.
Screenshot 2024-02-10 175242.pngScreenshot 2024-02-10 175315.png
Sometimes the latency is fine other times its terrible. Its really situational.
 
Is it an essential update or only if you have stability issues?
Well my laptop can't handle the 545.xx and 546.xx drivers (bsod after every game i close (bugcheck 119 or nvlddmkm error)) With driver 537.58 i have a stable systems. The hotfix does work for now as i am currently testing it.
 
I get the same results on LatencyMon regardless of the change. And to be totally honest, the speakers on this model are pretty poor in quality anyway. Even compared to the old MSI GP62-6QF Leopard PRO that i had just refurbished. I tried Mass Effect LE on both systems and the sound quality is night and day. Consequently all i do is connect to a smart tv and play it from there.
View attachment 184825View attachment 184826
Sometimes the latency is fine other times its terrible. Its really situational.

Just did a test for you on my machine.

Naamloos.jpg


Did another run

Naamloos 2.jpg
 
This doesnt show up in Geforce experience. Is it an essential update or only if you have stability issues?
Well. There are many reports of nvidia user which say they have stuttering on webpages and games since a couple of Geforce Drivers.
This hotfix should fix this problem.
Some even say they got more fps now.

I don‘t have any problems and didn‘t test it.

In terms of your latency problems…
Maybe I already asked it, do you got any security suites installed? Any antivirus?
And maybe the msi (not Micro Star International!) tool can help.
 
Forgot to mention that i was referring to the earlier registry fix you recommended last month.
It’s exactly the same thing as i have just posted. But todays post i made it a bit clear step by step.

Don’t forget if you update the realtek update you need to redo the regfix.

There are many reports of nvidia user which say they have stuttering on webpages and games since a couple of Geforce Drivers.
Yep, i am one of them. All drivers after 537.58 stutter. I played old games (men of war) and even that game stutters alot. I didn’t knew it was the nvidia driver until I experienced alot of bsod after closing Ace Combat 7 and Call to Arms. Rolling back to 537.58 fixed all these problems. But that one also gaved me a Bugcheck error 0x119 once (driver issue). I hope nvidia has things sorted now or i am forced to use a driver from april/may 2023.
 
Last edited:
Hey,
After stuttering in game started I am reinstall windows. I got 11 pro.
After reinstall problem with stutter was solved. But I faced a new one. Once I start the game I got black screens for a few seconds at random moments.
I did all the bechmarks, face the issue only when I did a stress test in Furmark 2 times in 17 min test. They don't look related to temperature or anywhing.
Reinstall all the drivers, try to rollback to 537.58, but nothing fix the issue.
Also got IPF 17 error in event log.
My laptop is msi Sword 15 A12UE-487XRU
I would glad for any help.
 
Last edited:
Back
Top