MSI Gaming Carbon Pro X299 TPM Bios Settings Questions?

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
I recently upgraded my system BIOS with 7A95v1H2 (Beta version) on the MSI Gaming Carbon Pro X299. I noticed that TPM setting layout looks a bit different from the previous bios version. I want to make sure that TMP is enabled correctly in my BIOS.

Do I have to make any adjustments with the following TMP settings? I'm also wondering if TMP hampers system performance in anyway?

Security Device Support: Enable
TMP Device Selection: PTT
Device Select: Auto

 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
9,637
It's correct like that. See here, https://www.msi.com/blog/How-to-Enable-TPM-on-MSI-Motherboards-Featuring-TPM-2-0

TPM will not affect performance. On older boards, it can cause slightly higher power draw, but only in the region of 1-3W or so.

If you want to make the PC ready for Win11, you also need to set the BIOS to UEFI mode and convert your boot drive from MBR to GPT (or do a fresh install of Win11).
Win11 strictly requires UEFI mode, so Legacy mode won't do the trick.

You should also enable XMP for your RAM, i see that it's still working at the safe JEDEC profile of DDR4-2133, which will be a bottleneck for CPU performance.
As everything the CPU does goes through the RAM first.
 

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
It's correct like that. See here, https://www.msi.com/blog/How-to-Enable-TPM-on-MSI-Motherboards-Featuring-TPM-2-0

TPM will not affect performance. On older boards, it can cause slightly higher power draw, but only
in the region of 1-3W or so.

If you want to make the PC ready for Win11, you also need to set the BIOS to UEFI mode and convert your boot drive from MBR to GPT (or do a fresh install of Win11).
Win11 strictly requires UEFI mode, so Legacy mode won't do the trick.

You should also enable XMP for your RAM, i see that it's still working at the safe JEDEC profile of DDR4-2133, which will be a bottleneck for CPU performance.
As everything the CPU does goes through the RAM first.
I enabled XMP for my ram. I have 64GB of Quad channel memory that is overclocked at 3200 MHz It seems the bios fails to retain and keep this setting often. My CPU's memory controller should be able to handle this since the CPU is an Intel Intel Core i9-10920X 12 core stock clock speed 3.50Ghz
 

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
I enabled XMP for my ram. I have 64GB of Quad channel memory that is overclocked at 3200 MHz This is the actual frequency it is designed to run at. It seems the bios fails to retain and keep the memory timing settings. I have to hit F1 or F2 or CTRL to reset the bios settings over and over. My CPU's memory controller should be able to handle this since the CPU is an Intel Intel Core i9-10920X 12 core stock clock speed 3.50Ghz. I have a Thermaltake 1500+ watt power supply. If I reconfigure running the memory in dual channel at 3200MHz, the bios is stable running that the 3200MHz OC frequency. If in QUAD CHANNEL @ 3200MHz it won't hold for but a couple of days or less before I have to reset the memory timing over again in the bios. Perhaps this has something to do with the memory controller on the CPU? or BIOS?


IMG20221004140835.jpg
 

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
What's your exact RAM model?
This is one of MSI's preferred vendors and is on the list of supported memory that works with the MSI Gaming Carbon Pro X299

G.SKILL Trident-Z RGB Series 32GB (4 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4-256) Quad Channel Memory

Model version: F4-3200C16Q-32GTZR

DDR4-3200 CL16-18-18-38 1.35v

I have also tired by disabling the XMP Profile, and manually adjusted the memory timing and voltage with the following settings. I ended up with having the same problems as technically noted.

G.SKILL Manual BIOS Memory Timing Settings

Extreme Memory Profile (XMP) > Disabled
DRAM Frequency: Auto > DDR4-3200 (24X100.00X1.33)
DRAM CH_A/B Voltage: 1.400
DRAM CH_C/D Voltage: 1.400
tCL 16
tRCD 18
tRP 18
tRAS 38
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
9,637
I have 64GB of Quad channel memory that is overclocked at 3200 MHz
G.SKILL Trident-Z RGB Series 32GB (4 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4-256) Quad Channel Memory

Model version: F4-3200C16Q-32GTZR
Do you see how that contradicts each other? You have 64 GB, but then you list a kit of 4x 8GB = 32 GB. So do you use two kits, eight modules total?
This is not supported at DDR4-3200:

Screenshot 2022-10-05 at 12-12-08 For PC Case Lighting Custom MSI X299 GAMING PRO CARBON AC Mo...png


See the checkmark at 2 DIMM, 4 DIMM, but not at 8 DIMM? This means that DDR4-3200 only works with up to four modules, not eight modules.
Because eight modules essentially doubles the stress on the memory system compared to four modules. That's why you can't reach that frequency anymore there.
It's no use increasing DRAM Voltage, this is not a limitation of the RAM, it's the entire memory system that cannot handle it anymore.
So you will have to try lower frequencies like DDR4-2933, -2666 to see what works.
 

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
Citay, thanks for pointing this out. I do not use 64GB of memory. I use 32GB in quad channel configuration.

G.Skill Trident Z RGB Series 32GB (4 x 8GB) 288-Pin SDRAM (PC4 25600) DDR4 3200 CL16-18-18-38 1.35V Quad Channel Desktop Memory Model F4-3200C16Q-32GTZR

How can I fix the issue now with only 32GB?

61jL+yMj-DL._AC_SL1000_.jpg
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
9,637
Can you make a screenshot of all the voltages in the BIOS, under OC?
If you can, press F12 in the BIOS to make a proper BMP screenshot to a FAT32 drive, then convert to PNG or JPG for size and upload here.
Your monitor makes the BIOS look very wide and information is cut off. For example i could've seen it was 32 GB, but it was cut off on the right side of your photos.
 

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
MSI Gaming Carbon Pro X299 BIOS settings for memory/voltage. I took multiple screenshots with XMP profile disabled/enabled.

XMP Profile disabled


MSI_SnapShot.jpg

MSI_SnapShot_00.jpg


XMP Profile enabled

MSI_SnapShot_01.jpg

MSI_SnapShot_02.png
 
Last edited:

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
9,637
For XMP disabled, you need to press F10 to save & reboot, then take the screenshots. It still uses the voltages from XMP enabled unless you save & reboot first.
But the XMP voltages are enough. I already see something odd, CPU SA and IO voltages are still at stock there. Those are the IMC-related (memory controller) voltages.
Try raising them both by 0.1V. So you set 1.0V for SA and 1.12V for IO voltage and see if you don't get the F1/F2 screen anymore.
Also you can try something counter-intuitive: Instead of raising DRAM voltage, try lowering it to 1.3V.
 

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
Now after saving the bios settings F10 on my primary bios. I do not get a bios post or display, just a black screen. I see error code 66 on my motherboard. I can still access windows on my secondary bios but nothing on the primary. Now how can I fix the issue with my primary bios so I can access it? I only use the my primary bios not the secondary. I'm forced to now until we can figure out how to get back in and fix it.

IMG20221005204215.jpg
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
9,637
That's error code b6. But just recover your primary BIOS by flashing it from the secondary one, see page 48 of the manual.

I mentioned two things you can try about the RAM.
 

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
Thanks MSI team! I will explore and try all the options provided. It's really great to get a technical scenes of connection with you all online. Thank you! :biggthumbsup:
 

charlesstephenstx

Member
CORPORAL
Joined
May 10, 2018
Messages
48
Got this beast back on the primary bios. Thanks guys for everything! Now I'll give it a go with bios settings and memory/voltages.
 
Top