MSI GE 66 RAIDER REFUSES to give me good upload speeds on Speedtest

Joined
May 10, 2022
Messages
8
I'm absolutely fuming over this issue. I've tried to relentlessly troubleshoot this issue for weeks to no avail. Basically, something is prohibiting my MSI GE 66 Raider from giving me good upload speeds. I've tried another laptop that shows me fine upload speeds when connected to the same wi-fi and running speedtests on speedtest.net. I've also contacted my ISP and they can see no error on their end. I get no more than around 0,11-0,14 mbps in upload speed in spite of getting well over 500 mpbs on download (see screenshot). I'm also using MSI center and NOT Dragon Center so the Lan Manager issue is not at play at here.

Please help me sort this out as it's made the act of streaming on Twitch for me completely impossible for weeks on end now.

Thanks in advance!
 

Attachments

badboy2k

Well-known member
Global Moderator
Joined
Feb 11, 2012
Messages
11,811
How about Killer Network's Traffic Shaping tools have you disabled its Prioritization and auto Bandwidth Setting?
 
Joined
May 10, 2022
Messages
8
I uninstalled Killer Network all together when I tried troubleshooting. Any files or anything else lying around that I should be worried about?

Thanks!
 

badboy2k

Well-known member
Global Moderator
Joined
Feb 11, 2012
Messages
11,811
can you do a test for me and boot your computer into safe mode with networking and see what speed it shows there?
 

badboy2k

Well-known member
Global Moderator
Joined
Feb 11, 2012
Messages
11,811
I'm not exactly a computer whiz haha, could you perhaps give me a step-by-step on how to do it?

Thanks again!

go to the Windows Icon
go To Power
hold down Shift and Click Restart
now it will load you into some options
go to Troubleshoot
go to Advanced
click on Startup Settings
now click Restart
then press 5 or F5 to get into safe mode with networking

then run a speed test from there just to see if its a issue of the Installation of killer network suit has left something behind and its not doing it in safe mode but if it does the same slow upload speed there too then there is something wrong with your Network Adapter

once you have done the test there just tell it to restart and it will load back into normal windows
 
Joined
May 10, 2022
Messages
8
go to the Windows Icon
go To Power
hold down Shift and Click Restart
now it will load you into some options
go to Troubleshoot
go to Advanced
click on Startup Settings
now click Restart
then press 5 or F5 to get into safe mode with networking

then run a speed test from there just to see if its a issue of the Installation of killer network suit has left something behind and its not doing it in safe mode but if it does the same slow upload speed there too then there is something wrong with your Network Adapter

once you have done the test there just tell it to restart and it will load back into normal windows
Thank you so much for this awesome guide!

I did precisely like you did, and sure enough, when I loaded into safe-mode, networking it shows me excellent upload speeds at 500+ mbps.

Any idea on how I proceed from here?
 

badboy2k

Well-known member
Global Moderator
Joined
Feb 11, 2012
Messages
11,811
Thank you so much for this awesome guide!

I did precisely like you did, and sure enough, when I loaded into safe-mode, networking it shows me excellent upload speeds at 500+ mbps.

Any idea on how I proceed from here?
at this point go through and fully Reinstall the Killer network Software and go to its Prioritization Engine and Disable Absolutely everything its messed with to have full Access, once done also Set its speed to something like 5000mb/s for both upload and download and see if in that state it works just fine and you get your 500+mbps and if so then remove the software and just use the driver only as your Previous lot has obviously changed a registry key somewhere and has left alot of junk behind.

its impossible to tell what its changed exactly just make sure to do the above to try get it to a more clean state before you nuke the software
 
Joined
May 10, 2022
Messages
8
Hi again and thanks for looking out!
Do I need to download a specific version of Killer Network Software, as in the exact one I had prior to uninstalling for the next steps to work?

Thanks!

Edit: Nevermind I just downloaded it and reinstalled it and I'm looking for how to best disable all of its features now. I'll keep you updated.
 
Last edited:

badboy2k

Well-known member
Global Moderator
Joined
Feb 11, 2012
Messages
11,811
Hi again and thanks for looking out!
Do I need to download a specific version of Killer Network Software, as in the exact one I had prior to uninstalling for the next steps to work?

Thanks!

Edit: Nevermind I just downloaded it and reinstalled it and I'm looking for how to best disable all of its features now. I'll keep you updated.
let us know what it does. just disable absolutely everything you can find and then run a Speed test to see if your speed is back then Nuke the software and just run the Driver so it cant change anything anymore.
 
Joined
May 10, 2022
Messages
8
Okay, I've now disabled the prioritization engine (screenshot 1) and manually set the bandwidth to 5000mpbs upload and download (screenshot 2).

anything else I should try to do before uninstalling the software again?
 

Attachments

badboy2k

Well-known member
Global Moderator
Joined
Feb 11, 2012
Messages
11,811
Okay, I've now disabled the prioritization engine (screenshot 1) and manually set the bandwidth to 5000mpbs upload and download (screenshot 2).

anything else I should try to do before uninstalling the software again?
yes run a Speed Test (do not use its one it will mess things up) and see if its back to normal if not just go disable every feature it has till it works normally then remove it
 
Joined
May 10, 2022
Messages
8
yes run a Speed Test (do not use its one it will mess things up) and see if its back to normal if not just go disable every feature it has till it works normally then remove it

YES speedtests are looking good now upload wise!

Do I just uninstall the software now normally or do I go about doing it some other way?
 
Joined
May 10, 2022
Messages
8
Man I can't stress enough what a lifesaver this has been! I've been pulling my hair about this for weeks and weeks on end now.

Thank you times a thousand!
 

badboy2k

Well-known member
Global Moderator
Joined
Feb 11, 2012
Messages
11,811
Man I can't stress enough what a lifesaver this has been! I've been pulling my hair about this for weeks and weeks on end now.

Thank you times a thousand!
your welcome. Killer Network Suite has been a problem form day 1 as it messes with things. I use the Program but I disable all its Traffic Shaping stuff if it updates.

Glad I could help you fix your Issue. (I only Use it just to work out how to fix it when it goes wrong as I need to keep on top of the issues)
 
Top