MSI GS 60 SPDIF-out

SolarFlame

New member
PRIVATE E-2
Joined
Jul 7, 2014
Messages
2
Hey! I found that gs60 has combined headphones-spdif out port in manual. So i bought a mini-Toslink cable and plugged it in but realted hd doesn`t see any cables connected and realtek digital output is still inactive. Also i dont see any light as usually in optical otput ports. So can anyone clarify this? Does GS60 really have spdif out and if yes how to enable it? Thanks for any help.
 

BlueAlexFPS

New member
MAJOR
Joined
Apr 3, 2013
Messages
1,110
The SPDIF should goes with Head Phone out, maybe you could try to active it from RealTek sound Driver?
 

chc

Active member
MAJOR
Joined
Aug 5, 2013
Messages
1,421
When plug in cable to the jack, go to Realtek HD Audio manager and tick off SPDIF as shown in pic.
 

Attachments

laszlo

New member
PRIVATE FIRST CLASS
Joined
Mar 17, 2015
Messages
6
Has anyone gotten this to work?  The mini-toslink cable goes into the MICROPHONE jack and is an input only (no light).  It does not fit into the HEADPHONE jack.  Ticking the S/PDIF option (in the Realtek software) on the headphone jack makes windows think it's outputting digital but I couldn't get this to work over the electrical headphone jack connection.  I used a 3.5mm stereo jack -> 2x RCA cable.  I tried connecting both channels to the receiver (in turn) to see if I get any digital audio out but it didn't work.  By that I mean I got no sound from the receiver, even though I could see the sound output (green bars) in windows control panel.

Is the wrong jack installed on the laptops by mistake?  Like maybe the headphone jack is supposed to be the optical?

Is the jack mapped wrong in software/firmware somewhere?  Should the microphone jack become an output somehow?

Is it supposed to be electrical (not optical) S/PDIF out via the headphone jack for real?  If so, what must be done to make that work?

 

ATASG

New member
STAFF SERGEANT
Joined
Apr 18, 2014
Messages
92
Hey Laszlo,

It works for me :yes:
It's the headphone jack which supports the S/PDIF, not the Microphone jack. (I'm pretty sure about that)
I use the Toslink to Mini Toslink cable and connect the male adapter of the mini Toslink to my GS70 and the male Toslink side to my speaker.

I think your problem should be "I used a 3.5mm stereo jack -> 2x RCA cable.", since the notebook only supports Toslink (optical) output. You'll need a Digital Audio Adapters to convert the Toslink optical to RCA Coax cables or vice versa. (depending on your situation)

*Make sure you've set the digital output to S/PDIF-Out in the Realtek Audio Manager.

Here is what I did on the set up:
1. Double click on the realtek speaker icon located at the notification area to open the Realtek audio manager.
2. Double click on the analog icon and choose the S/PDIF-Out.
(You can see the attached picture from chc, it's the same windows.)

If you still don't get it, then I think you should give us a picture of your devices and how you connect them OR visit the service center and ask for help.
Good luck~
 

laszlo

New member
PRIVATE FIRST CLASS
Joined
Mar 17, 2015
Messages
6
I feel really stupid now, I decided to give it another try and take some pics this time, and I realized that the cable I was using was the problem.  I ordered 6 of them from DX just in case one didn't work, since they were < 3 dollars each, and after trying several of them I did get one to fit into the headphone jack correctly.  It's just a tight fit.  I was able to get it to work after this, thank you.  My problem was a poorly made toslink connector which did not fit into the headphone jack, but it did fit into the microphone jack.. just out of tolerance I guess.

To sum it up, you need a mini-toslink <-> toslink cable to connect it to the HEADPHONE jack, just as the instructions above say.  It is an optical connection and a red light should be visible through the cable once the S/PDIF setting is selected in the Realtek application.

Thanks!

In the pics you can see that the jacks are ever-so-slightly different sized, probably just due to tolerances, and this caused my difficulty in inserting the cable.
 

Attachments

Top