MSI gs65 stealth 9se strange noise

lorenzo.micillo

New member
PRIVATE E-2
Joined
Oct 4, 2019
Messages
3
Hello, I have this laptop since last October. Yesterday it started making a strange noise, it is coming more or less from the center of the computer, it happens with fans on or off. I noticed it when i plugged in my mouse. When I closed the pc yesterday it went out for a bit, but today restarted. Here is the audio with the noise: https://drive.google.com/file/d/1p823D0BF8Y113l2h4qwDdCmWnXDGg-6r/view?usp=sharing

Thanks for eventual help.
 

ali.deym.g41130664

New member
Joined
Aug 5, 2020
Messages
3
I got the exact same issue with GL65. When I connect my mouse, the sound can be heard a lot more often (every 0.5 seconds possibly, or whenever I move the mouse). Also, I do not have this problem on Linux, but I only face it in windows. It may be Nahimic that is causing the issue.
 

Big mac

Big mac
SECOND LIEUTENANT
Joined
Jul 1, 2020
Messages
513
Try to mute the speaker to check if the problem comes from the speaker.
Or go to Bios > Advanced > Set “CPU C states “to Disable and check the problem again. (Laptop reboot and press [DEL] continually)
 

ali.deym.g41130664

New member
Joined
Aug 5, 2020
Messages
3
I am pretty sure it is Coil whine.
Tested it, and it seems like the sound is there when Intel Turbo Boost is on.
I didn't want to mess with CPU C States since they make laptop use more battery.

To anyone looking for a fix, here is two things you can do. If you want permanent fix, you have to update your bios, then go to BIOS settings and turn on the acoustic noise mitigation, turn off cpu c state.
If you don't want to change CPU C State (which increases battery usage), then I have a fix for you. It won't take the noise away completely, but reduces it by a lot that you cannot hear it anymore. Follow the steps below: (It will turn off your Intel Turbo Boost, so you may notice a bit lower framerate in games. you can switch back and forth):
1- Press CTRL + X.
2- Click 'Power Options'.
3- Scroll all the way to the bottom, and open 'Additional power settings'.
4- Choose 'Change plan settings' of your current selected power plan.
5- Click on Change advanced power settings.
6- Navigate to 'Processor power management' ---> 'Maximum processor state'.
7- Change both values to 99%. If you still have the noise / coil whine, then reduce both values to 95%.
8- Press 'Apply'.

Also, be sure that your laptop is in 'Comfort' gear/settings in Dragon Center.

Take a note that this may reduce your performance while gaming. So if you want to play games, you can follow the same steps, and switch both values to 100% again.
 

Big mac

Big mac
SECOND LIEUTENANT
Joined
Jul 1, 2020
Messages
513
Nice suggestion.
But it depends on your care more about battery or performance.
In my opinion, turn off the Intel turbo boost is not a good idea to solve the coil whine.
 

ali.deym.g41130664

New member
Joined
Aug 5, 2020
Messages
3
Well, you have to either give up more battery life, or, more performance. It all depends on what you use your laptop for. I choose to turn off Intel Turbo boost because it is easier to turn it back on, by just going to your windows settings and changing it back to 100%. But for Battery, it is not as handy as changing turbo boost, cause you have to reboot, go into bios, save and apply and reboot again, not as easy to switch it as Turbo Boost.
 

Big mac

Big mac
SECOND LIEUTENANT
Joined
Jul 1, 2020
Messages
513
That's right.
Battery life and performance cannot have the best of both worlds.
 
You must log in or register to reply.
Top