MSI GT70 2QD laptop wrong model in bios after update

matpan3

New member
Joined
Jun 13, 2017
Messages
2
Hi,
I have MSI GT70 2QD-2434XPL laptop.
Few weeks before i started to have problems with my GTX970M GPU. Laptop started to turn off immediately when i started any game which used dedicated GPU. I repasted GPU and CPU, updated BIOS and EC firmware. After that GPU was still not working correctly and my BIOS and SCM app started to show that i have MSI GT70 2OC model and not 2QD. I've updated BIOS and EC form official MSI support page for my laptop. For sure i've downloaded right files. Now it is:
BIOS: E1763IMS.11D
EC Firmware: 1763EMS1 7.17
Today i got new GPU - GTX980M which i installed. Now when Windows 10 is starting laptop switches to GPU mode and stays like that (orange power button). On GTX970M when Windows loaded it was working on Intel GPU and only when i started any game it switched to Nvidia GPU.
Does anyone know why my BIOS showing wrong laptop model and why Nvidia GPU is always active in Windows?
 
Last edited:

matpan3

New member
Joined
Jun 13, 2017
Messages
2
Ok, i think i solved.
The problem is... GTX980M. It doesn't work properly in that model because there is only 1 fan and heatsink which works for CPU and GPU both. Temperature is rising above 100'C degrees (Hot spot even 110) and games starting to stutter.
I swittched back to my 970M and everything working good. BIOS is showing GT70 2QD model, GPU is normally switching in Windows between integrated Intel and GTX970M.
So if anyone will ever want to upgrade GT70 2QD to GTX980M... think about that. Maybe my 980 is faulty or something, but its not working for me.
 
Top