MSi MPG B550 can't detect SSD.

nikolassid161d02f2

New member
Joined
Aug 13, 2020
Messages
8
Plz Help,

Spec:
MSi MPG B550 Gaming Plus
Ripjaw DDR4 2x8 GB
Ryzen 5 3600
Sapphire RX 5700 XT Pulse
Lexar NM610 m.2 NVME 500 GB
Seasonic Encore 650 Watt

whats the problem with Light Gen 4 m2_1 slot in this mobo?
tried to put SSD in Light Gen 4, it's undetected
then i put the same SSD, in another m2_ 2 socket it's work fine


Thnks
 

fatedust

Member
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
564
It should work in both slots, could you try M2_1 slot again and make sure it is well inserted?
What BIOS version are you on?
 

nikolassid161d02f2

New member
Joined
Aug 13, 2020
Messages
8
Try to Again, same result.
already flash bios with 7C56V11. the latest from the website.

is it because display port? (I'm not using hdmi?)
looking at others thread that said x570 can't detect SSD from WD because using DP.
(but i don't have hdmi adaptor. so i haven't try it)

or is it because the ssd? ( i used it in another m.2 slot and its working)
 

darkhawk

Active member
Global Moderator
Joined
Nov 20, 2012
Messages
12,823
M2_1 comes from the CPU.
M2_2 comes from the chipset.

If it works in M2_2 and not M2_1, that would generally mean either there's a problem with the connector on the motherboard to the M2, a problem with the CPU socket, or a problem with the CPU.

I don't think the BIOS will have much to do with it, if I'm honest.

Have you tried to set the PCIe port to Gen 3 instead of Gen 4 or AUTO? Maybe it just isn't properly running at Gen 3 speeds, and that's why it isn't detected.
 

nikolassid161d02f2

New member
Joined
Aug 13, 2020
Messages
8
yup did tried set the PCIe port to Gen 3. and the problem still exist.

maybe m2 connector or my cpu doesn't support the ssd (the last thing i'll tried is replacing the cpu).
will try another ssd gen4 (in the future). but in the mean time i will use only the chipset m2_2.

thanks a lot for the advice.
 

k31th04215ad02e4

New member
Joined
Aug 16, 2020
Messages
2
Yes. I tried swapping out my new m.2 with an m.2 from my laptop. The m.2 from my laptop worked, the motherboard discovered it. My laptop was able to discover the new m.2. So, for some reason the mother board cannot detect the new m.2.
 

nikolassid161d02f2

New member
Joined
Aug 13, 2020
Messages
8
maybe the new SSD didn't supported by the MSI. You should open a new thread about it. so the forum will more actively acknowledge there was a problem in MSi B550 M.2 CPU Socket.
 

Svet

Active member
Administrator
Joined
Nov 20, 2003
Messages
75,900
It has been tested and it worked fine, with same config:
MB: B550 GAMING PLUS
BIOS: 7C56V11
CPU: R5 3600
VGA: RX5700 XT GAMING X
M.2 SSD: Lexar NM610 M.2 NVME 250 GB
1.jpg2.png

Try use HDMI cable instead DP cable and retest
 

herbxfedxlio150702d9

Stoned Thinker
Joined
Sep 15, 2020
Messages
17
Plz Help,

Spec:
MSi MPG B550 Gaming Plus
Ripjaw DDR4 2x8 GB
Ryzen 5 3600
Sapphire RX 5700 XT Pulse
Lexar NM610 m.2 NVME 500 GB
Seasonic Encore 650 Watt

whats the problem with Light Gen 4 m2_1 slot in this mobo?
tried to put SSD in Light Gen 4, it's undetected
then i put the same SSD, in another m2_ 2 socket it's work fine


Thnks
You would have to create a simple partition for the unrecognized drive. Under disk management in the control panel it will show all your drives. Even if it doesn't show up in the BIOS. Once you decide which storage it is you will need to right-click it and create a simple volume. There you will designate the drive name(letter) and the space. Let it format the new drive in NTFS and then you can view the change under This pc when it shows all drives connected
 
You must log in or register to reply.
Top