MSI Optix MPG321UR-QD issues

Eienkei

New member
Joined
Dec 22, 2021
Messages
2
Hello, I have just purchased and received this display which I love overall.

However, I have a few problems:
1. After locking my device, the monitor no longer detects the signal upon trying to unlock; I need to manually power it on and off.
2. The KVM function stops working after the computer locks and can no longer unlock using the devices connected to the KVM.
3. The monitor has no signal during POST, doesn't display anything and I cannot access BIOS or see anything before the Windows boots.

Would appreciate your help.
 

fauc

Well-known member
SECOND LIEUTENANT
Joined
Nov 21, 2019
Messages
1,030
Please refer manual on page 17 and then modify " Auto Scan " to OFF.
Please refer manual on page 20 and then modify " Power Button " to Standby .

How to Enter the BIOS on Windows 10 (And Older Versions)
 

sbm781158402e4

New member
Joined
Jan 17, 2022
Messages
5
I'm experiencing the same issue and I have a friend who reported the same problem to me with the MPG321. Clearly this is something MSI needs to look into.
 

Eienkei

New member
Joined
Dec 22, 2021
Messages
2
I'm experiencing the same issue, and I have a friend who reported the same problem to me with the MPG321. Clearly, this is something MSI needs to look into.
All of the issues? I just talked to another friend who also has the same problems with KVM & No Signal after locking. I even saw YouTube videos on the subject. A KVM that cannot wake your device from display standby is completely useless.
I only managed to fix the no signal issue during POST through the vBIOS upgrade for my GPU.
100% agree, we need assistance from MSI on these. Hopefully, just software issues which can be fixed with new firmware.
 
Top