MSI Prestige 15 problem with Fn fast keys

gunev15ba02e7

New member
Joined
Dec 12, 2020
Messages
6
Hello everyone. I have a problem with the fast keys, some of them are not working. Before couple of days I've had a problem with a window coming out on every startup, saying something about MSI-dc link. I managed the problem with reinstaling the Creator Center, but now the keys aren't working. Before there was no need to press the Fn key with the F1-F12 keys, buy now they don't work either way. Anyone have an idea how to fix this? Thanks in advance.
 

gunev15ba02e7

New member
Joined
Dec 12, 2020
Messages
6
A early update - I've uninstalled and installed the creator center and the MSI-dc link message showed up again on startup. Nevertheless the keys are still not working.
tylwyg0kkb541.jpg
 

gunev15ba02e7

New member
Joined
Dec 12, 2020
Messages
6
Many thanks for your answer! I seem to struggle on step 3 - finding the "Utility" tab in the download menu on the product page to get the link, because the there is no prestige 15 in the tabs to choose. Or I might not doing it right..
 

gunev15ba02e7

New member
Joined
Dec 12, 2020
Messages
6
Ok, I've done everything, but after installing and launching the creator center, there is no "Continue" button and i can not get to the OneDC_SDK.exe file... Any other suggestions would be appreciated.
 

Attachments

brian95156402da

New member
Joined
Dec 14, 2020
Messages
6
Ok, I've done everything, but after installing and launching the creator center, there is no "Continue" button and i can not get to the OneDC_SDK.exe file... Any other suggestions would be appreciated.
I see your problem. Hmm... Have you tried the dragon tools?
 

gunev15ba02e7

New member
Joined
Dec 12, 2020
Messages
6
No I haven't. But runnig as admin worked and the after the instalation all the buttons work now. The step for downloading the OneDC_SDK.exe file didn't show, but the buttons work now!

I am very,very thankful for the help you gave me!
 
Top