MSI RTX2070 Armor: USB keyboard not working in BIOS

New member
Feb 12, 2019
got my "MSI GeForce RTX2070 Armor 8GB" today and its working great. One problem I have though, is that my USB keyboard stopped working while booting. That means I can't press DEL to enter BIOS nor can I make a choice which operating system to boot (dual boot with Win10/Ubuntu). Note that keyboard and mouse both work fine once Windows is fully booted to the login screen.

Google told me that a CMOS reset of the BIOS might help. And indeed, after a CMOS reset my BIOS accepts the keyboard again. HOWEVER, once I actually boot into Windows and then shutdown/restart my PC the keyboard stops working again in BIOS. Something is overridden there once Windows boots.

I have this problem since installing the new graphics card today, so I suspect it has something to do with its USB-C port (VirtualLink)? Currently I have nothing connected to that port, though.

Is this a known problem? Any ideas?

Thx :)
Mainboard is an Gigabyte GA-Z87-D3HP, the CPU accordingly an old and trusted i7-4770K.

Will check for FastBoot, but that means I need to do another BIOS reset to get in there (= will take a while).
  • FastBoot is disabled (probably had that enabled before installing the graphics card, but BIOS reset set it to disabled)
  • Legacy USB enabled (tried to disable that too, doesn't help)
I'm trying to organize an old USB to PS/2 keyboard adapter from a colleague tomorrow. That should allow me to connect the keyboard via PS/2, working around the problem.
do you have a different keyboard and mouse to try?
have you tried the video card in another PCI-E slot?
have you tried a BIOS update for your board?
Just to post the resolution of this issue:
Connecting the keyboard via the PS/2 port worked fine in my particular case. I'm using one of those old USB to PS/2 keyboard adapters (purple color coding) that where shipped with every keyboard back in the days. This solution might not work for other people who don't just have plain&cheap keyboard.

A BIOS update would have been a potential option, there is indeed a newer BIOS available. However, no need to risk bricking the mainboard when I can fix the issue that simple.