My Ethernet is not working - H510M-A Pro

aidenpac72158902ea

New member
Joined
May 28, 2022
Messages
3
The ethernet is not working on the motherboard.
I've tried:
Reinstalling the drivers
Updating the BIOS
Resetting network settings
I used the network troubleshooter and it told me "Invalid IP configuration".
An error code I got: "The device could not start (Code 31)"

Network card: Intel i219-v
 
Last edited:

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
6,930
What's on the other end, some router, i suppose? Can you try with a different "counterpart", or reset the router settings? Sometimes in cases like these, it has to do with what the PC is trying to communicate with, not just the PC itself. Also, is this a new build, and did you re-use your old Windows installation?

Try the newest drivers directly from Intel: https://www.intel.com/content/www/u...el-network-adapter-driver-for-windows-10.html
Wired_driver_27.3_x64.zip
 

aidenpac72158902ea

New member
Joined
May 28, 2022
Messages
3
What's on the other end, some router, i suppose? Can you try with a different "counterpart", or reset the router settings? Sometimes in cases like these, it has to do with what the PC is trying to communicate with, not just the PC itsIelf. Also, is this a new build, and did you re-use your old Windows installation?

Try the newest drivers directly from Intel: https://www.intel.com/content/www/u...el-network-adapter-driver-for-windows-10.html
Wired_driver_27.3_x64.zip
It's a new build, and I did not reuse an old Windows installation.
 

Alan J T

🙈 🙉🐝 🤬😈
Global Moderator
Joined
Sep 11, 2020
Messages
8,408
The ethernet is not working on the motherboard.
I've tried:
Reinstalling the drivers
Updating the BIOS
Resetting network settings
I used the network troubleshooter and it told me "Invalid IP configuration".
An error code I got: "The device could not start (Code 31)"
Will see if one of the Mods knows of a fix Have see this problem before a while back.

================================
@Svet

Svet was there not a reset tool for this problem,
Think I remember seeing it a couple of months ago in a Post.
===============================
 

citay

Pro
SERGEANT
Joined
Oct 12, 2016
Messages
6,930
How did you fix it? Please include the solution so future readers can benefit from it.
 
Top