Nahimic enhancements cause desktop audio to play through microphone

mezasemaster

New member
PRIVATE E-2
Joined
May 6, 2020
Messages
3
This is an extremely odd issue. I just got an H991 MSI headset, and quickly found out that any audio that plays through it would play back through my mic. It's not a matter of the mic picking up the audio from the headset itself; in fact, even if I turned the volume slider all the way down, or SWITCHED OFF THE MICROPHONE, it continued to always play whatever audio I was hearing through my mic. This means if I'm on a voice call with someone, for example, they will always hear themselves through my mic.

After enough tinkering, I found out that disabling audio enhancements for the headset (NOT the headset mic, just the headset) would fix this issue. Further investigation revealed the particular source of these problems: Surround Sound and Volume Stabilizer in Nahimic, the latter of which is necessary to get a decent volume from this laptop. If just Surround Sound is on, there is a light echo, while Volume Stabilizer is what makes it a loud echo of whatever audio I'm hearing. With both of these off, or Nahimic off in general, my desktop audio is not picked up through my mic at all.

So for the forseeable future, I'm going to just have audio enhancements disabled for my headset to prevent this from happening, but even at max volume on these settings the volume isn't loud enough without the Nahimic boosts. Is there a way that I can enable them without having them play my desktop audio through my microphone? Thanks.
 

fatedust

Member
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
571
Sounds like a driver issue. Have you tried to manually search for a newer version of driver for your headset on the internet?
 

mezasemaster

New member
PRIVATE E-2
Joined
May 6, 2020
Messages
3
I don't know about drivers for my specific headset, I can barely find information on the headset's existence as-is when I search Google. My Realtek drivers are up-to-date, and I even tried rolling them back to older versions to no avail. I've also discovered that it's not just Nahimic causing the issue, but just if the volume going into them in general is loud enough.

I posted a thread about it on Reddit with more information:

"I just got a new analog headset with a mic, but unfortunately, by default it will play back any audio I hear through the microphone (even with the mic switched off). So for example, if I'm on a Discord call with someone, they will hear their own voice clearly through my mic. The only way to fix that is with AEC (sometimes), but through the Realtek Audio Console, none of my Microphone Effects options are really satisfactory:

Uni-Directional w/ AEC: Occasionally stops desktop echo, but seems to randomly not stop it sometimes (as in, sometimes it will stop all of it, and other times it won't stop it at all). Even when it does work, it creates such a strong noise gate that it's impractical.

Omni-Directional w/ AEC: Same as above.

Enhance Voice Recognition w/ AEC: This one fixes the noise gate issue, but unfortunately, the AEC isn't strong enough and it creates a sort of tinny sound when attempting to subdue the desktop audio. The quality is also the worst of all the options.

High Quality Record: By far the *best* option in terms of my voice getting through and sounding good, but unfortunately, this one grays out the AEC option and doesn't allow you to select it, so this one always has very clear desktop audio playback.

Is there maybe an external program I can use to stop this from happening? I've spent so many days trying to fix this, rolling back my Realtek drivers and other things, but nothing seems to completely fix it (and usually creates new issues in the process). My computer is an MSI GE66 laptop running Windows 10 Home. I've tried Nahimic too, but it offers the same options as the Realtek Audio Console, plus it messes with the audio coming from my Elgato as well so I can't leave its effects on.

Thanks for any help."
 

fatedust

Member
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
571
Find the driver by going to Device Manager > Sound, video and game controller > double click on your headset > "Update Driver" or manually search for a newer version of driver on the internet.
 

nedwards1148060687

OldGregg116
Joined
Aug 10, 2020
Messages
2
To piggyback on this thread, I also have an H991 and can find almost no information on it. I'm not having the same problems at mezasemaster but my mic volume is too low. Now sure how to make the mic pick up the volume. Following this thread (because it's the only one with H991) in hopes that I'll find an answer. Thanks
 

fatedust

Member
FIRST LIEUTENANT
Joined
Apr 9, 2020
Messages
571
To piggyback on this thread, I also have an H991 and can find almost no information on it. I'm not having the same problems at mezasemaster but my mic volume is too low. Now sure how to make the mic pick up the volume. Following this thread (because it's the only one with H991) in hopes that I'll find an answer. Thanks
Have you tried to adjust the microphone levels? Go to Sound Control Panel > Recording > right click on Microphone and select Properties > Levels > play with the slider and apply changes.
 

nedwards1148060687

OldGregg116
Joined
Aug 10, 2020
Messages
2
Have you tried to adjust the microphone levels? Go to Sound Control Panel > Recording > right click on Microphone and select Properties > Levels > play with the slider and apply changes.
Thanks. My main issue is playing on my xbox using the headset plugged into my controller. Not sure if the xbox has a setting to change the mic volume. I'll have to look around a bit more.
 

bschalker

New member
CORPORAL
Joined
Jan 20, 2016
Messages
23
I have this exact same issue on an MSI X470 Gaming Pro Carbon with the latest Realtek drivers. With or without Nahimic installed. Disabling audio enhancements in the Windows audio settings is not an option as that will also not allow you to use spatial audio (Windows Sonic or Dolby Atmos for Headphones). And I love the Dolby Atmos as it improves gaming so much, especially in games that nativly support it.

I have Volume Stabilizer and Surround disabled in Nahimic. And then indeed the echo is less present, but still present non the less. Maybe disabling audio enhancements does fully mitigate the issue, however that is not an option for me as I really want to use Dolby Atmos for Headphones.

This obviously is a driver issue, happy to see other users have this problem as well as I was worried my motherboard or headphones had a hardware issue. Nonetheless there is currently no newer driver available from the MSI website. I have not been able to try an older driver since I did not save the installer.

Updating to a universal Realtek driver is also not an option as that will result in no audio at all as there is a special Nahimic patch included with the MSI Realtek drivers that need to be installed in order for it to work (with audio enhancements enabled).
 
You must log in or register to reply.
Top