network problem-post hubs etc do not work with onboard lan

C

CBob

Guest
Any reports on Belkin el cheapo 3 port hubs or Hawking?

I really don't feel like playing around with hubs after having just ordered 2x512 from Mushkin because MSI won't play nice w/hardware.
 
N

nForcer

Guest
Well, I'd like to rescind my earlier critism of the onboard nic in my K7N420. It turns out I had bad wiring. Strange that one bad wire out of eight would stop network traffic to the router but not if I had a hub in between. I found out the truth after installing a pci nic and still had the same problem. I then checked continuity on all eight wires and the brown/white was open.

Anyway, the wiring is fixed and all works fine now.
 
W

Whitecelicagts

Guest
add another one to your list of onboard lan cards not working properly with the linksys 4 port router. I will be playing an online game which i play a lot, after about 15 minutes of play, it totally lags me and my sister on her computer, seems like I am wanting to draw too much bandwidth and its causing conflicts. After a reboot its fine again for another 10-15 minutes, think they came out with this card too soon...
 
O

okie_tex

Guest
First time to install a MSI K7N2G-L was last night ... had help from another msg board person on these boards and helped me get past my on board lan issue - some video issue associated with the lan issue - and then some higher temps which were solved by updating to bios 3.4.

anyway, going to report on this as everyone is keeping track ...

Plugged my K7N2G-L (running BIOS 3.3 at the time) onboard LAN into a LINKSYS 5-PORT 10mbps hub ... NO WORKIE. So, I found out quickly with this stickie that there was a problem with the on board lan.

Next, installed a 3rd party NIC card (a cheapo D-LINK) into one of the pci slots. Well, I couldn't boot up ... or it did but my video was all messed up. So, answer from msg board helped me out again .... ;)

I disabled on board lan in the bios settings ... sure enough - boom, machine booted up ... and LAN was working with my 3rd party card.

Now, flashed to 3.4 (which is the reason I was trying to get online with the machine in the first place ... to update the BIOS!!!) ... and this is what I think is interesting (and could have been covered more in depth but I haven't read all 9 pages of this thread - only the last 3) - but, I also have a D-LINK DI-704 router/switch ... so, I just plugged in my lan connection to it and used the ON BOARD LAN ... and IT WORKS ... I can get out on the ON BOARD LAN. I guess the BIOS setting 3.3 VS 3.4 is a little different and I don't have to have it disabled anymore b/c it doesn't seem to be. Also, I guess running it through a Linksys hub isn't so good ... but the D-LINK is ok. (Also, I didn't test with BIOS 3.3 if the on board lan would work with my D-LINK DI-704 ... I assume so.)

anyway, just tested again - with the 3.4 bios - plugged the lan back into onboard and the Linksys ... only the one light on the back. And, connection is not available. Plug it into my D-LINK NIC ... I'm good ...

Recap - edit - sorry forgot this -
Running Driver 2.8.1.0 - Nvidia nForce MCP Networking Adapter
Doesn't work with my Linksys 5-PORT HUB (Model# EW5HUB) 10mbps
Bios now running @ 3.4

Anyway ... this is interesting. -ot
 
R

ratio

Guest
DSL-Modem - Teledat 300 LAN Deutsche Telekom (10MBit) is not running.
OS: Windows XP (SP1)
Networkdriver: nVidia 3.1.3.0
BIOS 1.2, 1.3, 1.4

System is running with Switch - D-Link DES-1005D
 
M

moot

Guest
K7N2G-L, 3.3 BIOS, on-board LAN works fine... at first with Motorola cable modem, now with the same modem and a LinkSys NR041 four port Cable/DSL router. Using NVidia 2.8.1.0 driver. The router set up easy with the install CD and worked first time.
 
R

Robin Davies

Guest
Useless piece of crap!

Lynksys 5 port workgroup hub EW5HUB
K7N2 Delta-L
AMD Athlon 2600+
512MB 333 Kingston
Audigy 2
ATI 64MB DDR VIVO
350W PSU
XP Pro SP1
80G Maxtor (8MB cache)

All latest MSI drivers installed.

Have to use 3rd party card and use up a PCI slot...
 
Y

Yipcanjo

Guest
Well.... let me add to the fray....

I purchased a K7N2 Delta-L mobo as a quick replacement for my 8RDA+ that had just died (my own fault). Going from an NForce2 board to another NForce2 board shouldn't be a huge problem... and it wasn't. These boards are a lot alike, actually. After booting and rebooting I tried to get onto the Internet but could not. Strange. I've been using the same Belkin Wireless USB adapter for sometime with no issues.... until the K7N2 Delta-L came into my life! I could see that the wireless was able to recognize the router, but would NOT get a DHCP address. I fooled for quite awhile to no avail. Rebooted. Reset my router, and so on. I then tried my onboard LAN and wouldn't you know it... nothing. Link lights good. Cable good. No DHCP address. I could manually enter my IP address and ACTUALLY ping my router, but it would go no further than that. Lame, lame, lame. Now I'm resorting to bringing a 3Com card home *just* so I can (hopefully) browse the web. X(

In any case, I'll be returning this motherboard as soon as I can. As far as I can tell, one of my USB ports does not work, the onboard LAN is buggy, and I cannot get a hold of MSI tech support for the life of me! Back to Epox....

Thanks, MSI: you've helped me remember why I don't buy MSI products...

Yip
 
T

tdmonkey

Guest
Well like many others I have been having problems with the onboard Ethernet on my K7N2-L. However, all of the sudden almost mysteriously I have it working.

There is the part that for various reasons that I believe was the fix. but I'll go through the entire process.... I'm interested in knowing if it works for anybody else.

K7N2-L w/bios 3.50
WinXP Pro Drivers 2.78
Netgear RT-314

1) I removed all extra services from the Network config except TCP/IP (Client for MS network, File Print sharing, QoS packet scheduler were all removed.)

2) Rebooted, went into BIOS and *specified a MAC address* (The MAC address specification was the only thing I have not previously done. Personally I used a MAC address pulled off Sun Interface)

3) The machine came up, obtained an IP from my Netgear RT-314!! I put back in the Other services. Rebooted and it's been running for about 2 days now with no problems.

JoeE
 
A

actinium

Guest
Is all the mac address on the board the same? if so can anyone share it here.. i cannot find mine, thanks alot for the help..
 
K

kri

Guest
Originally posted by actinium
Is all the mac address on the board the same? if so can anyone share it here.. i cannot find mine, thanks alot for the help..
nope, MAC adresses are unique (or at least should be) so each board will have a different number.
finding the sticker can be really hard, especially when the board is already built in the case. I managed to shove a CD underneath the last slot (at the very bottom, underneath the PCI slots) and could finally read the reflection of the sticker that way.. maybe that will help

greets
kRi
 
A

actinium

Guest
I been using msi board ever since my first com and this is the first time i encounter this kinda fatal flaw in msi product.. Building this comp for others of which i may not have the chance to flash the new bios. And this lan thing is really giving me h*ll lots of problem.. Disappointed.. X(
 
K

kudder

Guest
Hmm i have the same problem like many others: My Onboard Lan doesnt work! I have tried everything and it wont work.

I have a Alcatel Speed Touch ADSL Router and NEVER had any problems with it with the old NIC. My mainboard is the K7N2-L with onboard "LAN".

Ok i tried this actions:

* put my old nic in and created df? - connection: it worked on first try...then i disabled the old NIC and enabled the onboard NIC...result: i can only send packages but don't recieve any!

* then i went back to the BIOS and entered the MAC-address. back in windows i typed "ipconfig /all" and the MAC was shown there. then i started df?-connection...result: again no connectivity

* finally i downloaded and updated the rasppoe - protocol with the same result: NO CONNECTION ;(

* i also tried to give the mac address from the old NIC to the onboard but it doesnt change anything!

I have the newest drivers and newest bios version.

If anyone got help i would be very happy!!
 

iangnu

New member
PRIVATE E-2
Joined
Aug 21, 2003
Messages
4
I hope this helps you out .....

I have had all the same problems as detailed on this thread ....

Tried new mobo
Tried a PCI Network adapter
Changing from 100Mb to 10mb connection.
Different memory
Changing the Mac address
Re-installing net drivers
Re-installing all drivers!
Re-installing WinXP (twice!!)

Finally changed my power supply (after a friend suggested theres no other possibility!!)

I bought a 400 Watt supply .... plugged it in and hey presto my internet connection was active and I surfed like a good 'un !!! :D

Just to confirm my problem (as there seems to be a few slightly different problems detailed) .....

I have an Etec ADSL router/modem connected to 3 PC's.
Two PC's (old boards with AMD K6 chips and PCI LAN cards) worked absolutely perfect, they could see each other and surf the net at the same time.

THE PROBLEM: When I plugged in my PC with the MSI K7N2 Delta ILSR Mobo the internet connection (ie the router modem which auto dials and is always on) dropped and wouldn't connect, that is until I unplugged the Problem PC network cable from the router and it connected straight away.

The network between all three PC's actually worked fine (It seems some are having a problem with even the basic network) and I could swap files etc between all 3 PC's no problem.

So I was stumped until the Power Supply was changed!

I suggest all you guys borrow a 400Watt power supply and try that. It seems the Power consumption of these boards is getting greater and greater!!!

Regards

Ian
 
Z

zaphod12

Guest
Hi
I had this same problem my network was not working via cable modem or local network. I tried fixing the mac address but this still did not work.I gave and put in a new network card and disabled internal networking then had no problems.Latter surfing the net I found a leaked nvidia driver ver.3.44 beta (http://www.savagenews.com/?show=3545)so I thought what the hell I will give it a go.I enabled my internal network adaptor and installed the beta driver now everything is working fine I am using the internal on my cable modem no probs.THe mac address did not need to be manualy inserted as was correct.
I hope this helps
zaphod12 :] :]
 
K

Kobra

Guest
Hi folks...

If ya'll have read ALL 9 PAGES, you'll see that I was one of the first to post on this. I am so sad to see that the issue still has not been address'd by MSI and there is no better suggestion that "buy another NIC or router"

It appears to me that MSI doesn't really care about this issue, or it's customers. Aas a few others have said, and I agree with, " I'll just have to buy another brand of board"

EPOX is looking pretty good right now, and since I only build about 5 systems a week, MSI probably won't miss my pittiful few purchases.

And just in case ya'll are wondering......
MY ONBOARD LAN STILL DOES NOT WORK WITH MY HUB...
Good luck to you all....

Kobra
 
U

Unrulyappendage

Guest
FYI, I was able to get the onboard lan to work in w2k after the service pack 4 install. Could not get it to work on windows me. I still had to use the old NIC card so I could upgrade so it still remains in the machine. I do not know what I did, I just used it for grins and giggles and it worked after the upgrade. Running a +2500 Barton using a rented RCA cable modem. I have not tried hooking up a hub since I have been getting my machine back to running smoothly after unsuccesful overclocking episodes and I am happy right now just to get it back to normal. Looking at others problems, I tend to think that the onboard lan is future proof but not backwards compatible. I get good internet speeds that test out 1440 to over 2000 kbs so the speed is the same as the add on card. I will not get rid of the old card since I do not have a burner and cannot burn a copy of the SP 4. If MSI has a fix for this, I hope they will provide a disk as well so this could be working without having to download patches which means you have to have another NIC which defeats the purpose of an onboard lan.
 
G

Gixer

Guest
Well I just got a K7N2 Delta ISLR. Have Windows XP pro, flashed MOBO to the latest BIOS and a Netgear hub (Will have to find out number) My on board LAN worked great from day one!! Had a small problem with my firewall in that I had to tell it to trust the other PC's in the network and that was it. I manually set my I.P. and subnet mask all the time too though.

I am going to be purchasing an ADSL modem/router soon though you guys got me a little worried. Think I stick with Netgear though as mine is working.
 
K

kudder

Guest
I have posted one site ago and i ve also read the last nine pages and none of your suggestions could help me. I wrote MSI 3 times an E-Mail about my problem and they didnt even wrote me back ... isnt this a forum where the members can ask questions and the support team answers them ?( ?(
 
Top