network problem-post hubs etc do not work with onboard lan

M

mikiwoz

Guest
A question:
Wouold ANYBODY disagree with me, if I'd said, that MSI screwed (yeah, that's the proper word, isn't it?.. :biggrin: the integrated Ethernet adapter in K7N2 Deltas?.. 'Cause it is rather queer that a LAN card works only with certain hubs, isn't it?.. Just checking, probably a ACR/PCI LAN or mb change will do the trick...
 
E

Error420

Guest
:angryfire:
I cant believe this board. First a driver for the realtec sound that wasnt on the CD. And now a MOBO that wont connect a hub with a addon card or with onboard lan. For some reason the onboard lan and the addon ethernet card work connected dirrectly to my cable modem, just not this kingston KNE5TP/H (which I know work becuase I was surfN the net with my cable moden + the kingston hub + a P90 computer((WIN98)). I've had problem's with mobo's before, but this is something you expect to find comming off the scrap heap not from you brand new mobo.... o_0 YOU GUYS REALLY SUCK!!!!! I'll NEVER BUY ANOTHER MSI PRODUCT EVER AGAIN!!!!!!
o_0
 
E

Error420

Guest
:angryfire:

Maybe its a broplem in the live2update that flashes up whe the bios and stuff fires. Is there a flash for this mobo without the live2update? Maybe the live2update is really some type of spyware???

o_0
 
R

rosco_madison

Guest
Haven't seen much activity on this thread, but I'm having the same problems with my K7N2 Delta-L. It and my Asante hub blink a bit but never steady link. I've entered the MAC address into bios (v5.4 by the way), it appears under WinXP under ipconfig /all, and no luck. A spare pci D-Link card in this board links just fine. A whole different WinXP box swapped in on the same port works just fine.

I've emailed MSI support without much success. (They told me to enter the MAC address, which I had already tried. I tried again, noted that XP picked it up w/the ipconfig command, still no link.)

Why won't MSI fix this?

- Ross
 
W

wilkid

Guest
It seems I owe MSI an apology- at least with regards to there onboard LAN regarding the netgear FS605 hub. The thing does work.

I think a lot of people's problems they have posted are the same as I had :-
If you enable Internet Connection Sharing (ICS) ICS on a server machine it will overide you TCP/IP settings for your ethernet connection to be a static address - 192.168.0.1 with subnet mask 255.255.255.0.
However, when you come to install Windows XP on a client machine (ie. your new one), the naughty DHCP client (which TCP/IP automatically uses) assigns a subnet mask of 255.255.0.0, from the DHCP server on 255.255.255.255. Result - your client PC does not see the server as they are using different subnet masks, and you naively blame the onboard LAN... Basically your 2 subnet masks must match for the network to see each other.

The fix (copied to the LAN problems post) -
1)Go your your TCP/IP properties in the client machine. (Right click on your network connections/ nVidia/LAN connection/ properties
2) Click the static IP address button instead of the automatically assigned one...
3)Enter a new static LAN IP address eg. 192.168.0.5. Enter your subnet to be the same as your server machine (probably 255.255.255.0 if you have ICS enabled).
Check it using DOS>ipconfig /all on the server.
4) Importantly set your IP gateway to be the same as the server (proabably 192.168.0.1) and the DNS server to be the same. ICS needs this!) Without this your PC's will see each other, but ICS will not work...

Your PC's should now be able to see each other, and ICS should work (if you are using it).

Regards......Dean
 
R

rosco_madison

Guest
Wilkid - I don't think this is the problem. Regardless of what IP settings WinXP uses, the board and the hub refuse to link. OK I'm not a network engineer, but to me if those two devices don't establish a link, you ain't going nowhere. The link should come on momentarily after the system is first powered up. After WinXP comes up then the whole DHCP negotiation takes place.

Correct me if I'm wrong, thanks...

- rosco
 
F

ftonello

Guest
o_0 :angryfire: :wall: :nono: :evil:

My onboard LAN can't receive packets from my WET11...
When i connect the device the windows XP shows a 10mbs connection...but u just can see the onboard LAN sending packets but receiving....
With a realtek LAN card inserted it works prefect!!!
I've tried all these dirvers:
2.8.1
3.1.3
3.6.3
Anyone knows a previously driver or a new one or some hack that could help me?
Thanks...
PS: i've seen somebody talks about shield cable problems? What is this? Try change for a good cable??? Because i've tried two different cables...
 
C

chefkoch78

Guest
Cnet CN8810CX 8 Port Hub also doesn?t work with driver 3.6.3 and before.. Have done all suggestions here made in forums (MAC Address and so on) . Nothing helped.

I have now a 3Com OfficeConnect Switch and it works with 100MBit and Full Duplex Mode.

Greets
 
F

fxgogo

Guest
Like many of you, I have had similar problems connecting to my calbe company. Well After reading through the nine pages, I made a list of things to try to fix the problem. I finally got it working last night, and I am sure it was the MAC address problem that was the culprit. But I will write down my route I followed to see if it may help anyone else:

First I entered the MAC address into my Bios.

When I checked the MAC address with the ipconfig utility, it was exact except for one letter in the sequence.

I then disabled the 'wake on lan from poweroff' in both the bios and nic settings in windows.

I changed the speed of the lan from 100 to 10 mbps.

I checked to see that I was on the latest bios, and I was.

I checked to see that I was on the latest service pack of windows 2k (SP4), and I was.

I then uninstalled and re-installed the lan drivers on the machine. I can't be sure they were the latest ones, as I have a directory of drivers sitting on my temp folder, but when checking the live update, I was upto date with all drivers, so I am almost positive they were.

Now when I rebooted the machine for the last time, I still got no joy. So the following night I brought a laptop from work to test the connection between two pcs. I was able to ping the laptop from my machine, but not the otherway round. I did not have admin access on the laptop so I could not mess with the network settings to investigate that. I then tried the Mandrake Linux boot on my main machine to see if it could connect and maybe show the error to be a windows problem. Well it configured the cards but could not connect, but being a newbie when it comes to linux I put that down to me not knowing what the hell was going on.

I then went downstairs to make some milk bottles for my baby, and thought I would switch off the pc and cable modem for 5 minutes while I did the milk. My cable company always suggest powering down the pc and modem for atleast 5 minutes. Well when I got back upstairs, it was working and talking to the cable modem.

So in my opinion the problem lay with the mac address and the reseting of the cable modem and pc, but I think the re installing of the drivers after the MAC adress input could of helped.

Well I hope that helps some of you. I am certainly pleased it is working now.
 

johnanna

New member
SECOND LIEUTENANT
Joined
Jan 9, 2004
Messages
120
Hi,

i have two LANs: first LAN include my motherboard (not card) and second new card LAN (I will buy new NIC card it), so can I use new card put in my motherboard (two LANs)? or are will work OK (both LANs)?
 
T

The_Magistrate

Guest
After reading almost everything there is on this subject, I have gotten no where.

From all the different posts on this board and the Google board, I have concluded that this is NOT a software issue. This isn't even a BIOS issue. This is completely hardware based. The built-in NIC on the K7N2 based motherboards doesn't work with many popular hubs, switches and cable/DSL modems. (See list at end of this post for a partial list) As far as I can tell, (I have experience with computers, but am not an expert) the problem lies in the recieving of packets sent to the NIC card. There is nothing wrong with your hub/switch/modem, the problem is in the NIC.

The majority of the people who posted said something along the lines of:
I have a <insert K7N2 family model number here> motherboard with the onboard NIC turned on in the BIOS. I tried connecting it to my <insert hub/switch/modem name here> and nothing happened. The light on the <hub/switch/modem> didn't turn on, except when the NIC sent information, and the light on the NIC was consistantly yellow. I have tried <list every possible troubleshooting technique here> and nothing helped. Anyone have any ideas?
There is a partial solution for the routers and switches though:
Manually set your MAC address in the BIOS.(The MAC address can be found on a sticker on the side of the ACR/CNR) This solution only works for routed devices because they actually use the MAC address to send packets. (To find the MAC Address without taking your computer apart, slide a mirror/CD under the last PCI slot on your mother board and write down the 12 digit hex number written there. That is the MAC address that is provided default from the factory.)

As for the hubs and modems, you are out of luck. Go buy a PCI NIC card because you aren't going to get it to work. No amount of tinkering with Windows or BIOS settings will make your onboard NIC work. The NIC is recognized by Windows and will work with other configurations, but when connected to an incompatible hub or modem, nothing.

From what I have read, multitudes of people have written and called MSI Support with little or no response. Their answer is "Buy a PCI NIC." Which is just a workaround. Not very nice. MSI really needs to get on the ball and explain to everyone why their onboard NIC won't work with the hardware they already have. They also need to figure out if there is anyway to fix the problem, and if not just come out and say there isn't a fix. Hopefully though, MSI will distribute a BIOS update that will resolve the problem.

When I was shopping, I really didn't want a motherboard with a built-in NIC, but in the end I settled. Now I know why I didn't want it. I guess I'm off to the store to buy a new PCI card to use up one of my valuable slots for something so redundant. I have two of the hubs that don't work in the list, so I am severly frustrated at this predicament.


This is by no means a complete listing!
These are just the products that have been reviewed in this thread.


3Com OfficeConnect 10Mb/s Ethernet Hub 8 (3C16700A)
Alcatel Speed Touch Home (ADSL modem)
Astrolink 9 Port 10mbps "High Performance" Hub (CT1009D1)
Aztech ADSL Modem (900EB)
D-Link 5 Port hub (DE-805TP)
"D-Link router" (nForcer's, I didn't find any model number?)
Linksys 4 Port Hub (BEFSR41)
Linksys 5 Port Workgroup Hub (EW5HUB)
NetGear 4 Port Ethernet Hub (EN-104TP)
NetGear 5 Port Fast Ethernet Switch (FS105)
RCA Cable Modem (DCM305)
StarTech.com 10BT 5 Port Hub (ER539580702710447)
Surecom 5 Port Switch (EP-805SX)


If someone could make this post sticky so that people who have this problem don't have to read the same 100 posts I just did, I would really appreciate it.
 

Wonkanoby

New member
GENERAL OF THE ARMY
Joined
Jul 7, 2002
Messages
31,259
the post is in the stickies ,sticky threads please look here before you post ,and in good articles so what more do you want
 
F

fxgogo

Guest
RIght I have just changed my Power supply to an Antec Trupower 430 and bling my Lan works with no problems. Connects to my 3com wireless/switch/Router/asdl modem aswell. That to me will be most of our problems with the Lan.
 
Top